Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 678940 - media-tv/v4l-utils-1.16.3-r1 virtual/libelf(?) keyword request or mask USE=bpf
Summary: media-tv/v4l-utils-1.16.3-r1 virtual/libelf(?) keyword request or mask USE=bpf
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrey Utkin
URL:
Whiteboard:
Keywords: KEYWORDREQ, PullRequest
Depends on:
Blocks:
 
Reported: 2019-02-27 16:31 UTC by Alexis Ballier
Modified: 2020-03-13 23:18 UTC (History)
2 users (show)

See Also:
Package list:
media-tv/v4l-utils-1.16.3-r1 media-tv/v4l-utils-1.16.6
Runtime testing required: ---
stable-bot: sanity-check-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Ballier gentoo-dev 2019-02-27 16:31:36 UTC
KEYWORDS.dropped              1
   media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: alpha ppc
Comment 1 Stabilization helper bot gentoo-dev 2019-02-28 07:00:41 UTC
An automated check of this bug failed - repoman reported dependency errors (12 lines truncated): 

> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['sys-devel/clang:*[llvm_targets_BPF]']
Comment 2 Morton Pellung 2019-04-09 17:06:38 UTC
[ebuild     U  ] media-tv/v4l-utils-1.16.3-r1::gentoo [1.10.1::gentoo] USE="bpf%* opengl%* qt5 (-udev%)" 0 KiB

I guess this bug relates to what I'm seeing when trying to build media-tv/v4l-utils-1.16.3-r1:
...
...
Making all in bpf_protocols
make[4]: Entering directory '/var/tmp/portage/media-tv/v4l-utils-1.16.3-r1/work/v4l-utils-1.16.3/utils/keytable/bpf_protocols'
clang -idirafter /usr/lib64/llvm/6/bin/../../../../lib/clang/6.0.1/include -idirafter /usr/include -D__linux__ -I../../../include -target bpf -O2 -c grundig.c
clang -idirafter /usr/lib64/llvm/6/bin/../../../../lib/clang/6.0.1/include -idirafter /usr/include -D__linux__ -I../../../include -target bpf -O2 -c pulse_distance.c
clang -idirafter /usr/lib64/llvm/6/bin/../../../../lib/clang/6.0.1/include -idirafter /usr/include -D__linux__ -I../../../include -target bpf -O2 -c pulse_length.c
clang -idirafter /usr/lib64/llvm/6/bin/../../../../lib/clang/6.0.1/include -idirafter /usr/include -D__linux__ -I../../../include -target bpf -O2 -c rc_mm.c
clang -idirafter /usr/lib64/llvm/6/bin/../../../../lib/clang/6.0.1/include -idirafter /usr/include -D__linux__ -I../../../include -target bpf -O2 -c manchester.c
error: error: unable unabletoerror error : to: create  unablecreateunabletarget:    to'No available targets are compatible with this triple.'target: to 
'No available targets are compatible with this triple.' createcreate 
 target:target:  'No available targets are compatible with this triple.''No available targets are compatible with this triple.'
error: unable to create target: 'No available targets are compatible with this triple.'
1 error generated1.
 error generated.
1 error generated.
1 error generated.
1 error generated.
make[4]: *** [Makefile:565: grundig.o] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: *** [Makefile:565: rc_mm.o] Error 1
make[4]: *** [Makefile:565: pulse_distance.o] Error 1
make[4]: *** [Makefile:565: pulse_length.o] Error 1
make[4]: *** [Makefile:565: manchester.o] Error 1
Comment 3 Roger 2020-02-27 22:41:33 UTC
I just found my old Pentium3 laptop pulling in the heavy resource clang build environment ebuilds due to explicitly v4l-utils having USE=bpf turned-on by default.  (On pentium3, clang build environment can take days to build.)

Seems USE=bpf is a specific feature for IR (infrared  tables) for risc platforms?

If so, this option should be optional.
Comment 4 Sergei Trofimovich gentoo-dev 2020-03-02 11:11:45 UTC
(In reply to Roger from comment #3)
> I just found my old Pentium3 laptop pulling in the heavy resource clang
> build environment ebuilds due to explicitly v4l-utils having USE=bpf
> turned-on by default.  (On pentium3, clang build environment can take days
> to build.)
> 
> Seems USE=bpf is a specific feature for IR (infrared  tables) for risc
> platforms?
> 
> If so, this option should be optional.

Please file a separate bug.
Comment 5 Stabilization helper bot gentoo-dev 2020-03-02 12:00:55 UTC
An automated check of this bug failed - repoman reported dependency errors (54 lines truncated): 

> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop) ['sys-devel/clang:*[llvm_targets_BPF]']
> dependency.bad media-tv/v4l-utils/v4l-utils-1.16.3-r1.ebuild: BDEPEND: ~alpha(default/linux/alpha/17.0/desktop/gnome) ['sys-devel/clang:*[llvm_targets_BPF]']
Comment 6 Andrey Utkin gentoo-dev 2020-03-06 23:13:55 UTC
Sorry for letting this linger for so long. I am going to look into this as my priority.
Comment 7 Larry the Git Cow gentoo-dev 2020-03-13 23:16:30 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=494262bc5f8bf3f7638cbfde059db0c7f8be398f

commit 494262bc5f8bf3f7638cbfde059db0c7f8be398f
Author:     Andrey Utkin <andrey_utkin@gentoo.org>
AuthorDate: 2020-03-13 23:10:16 +0000
Commit:     Andrey Utkin <andrey_utkin@gentoo.org>
CommitDate: 2020-03-13 23:14:37 +0000

    media-tv/v4l-utils: restore alpha, ppc keywords
    
    These arches have been dropped from keywords of a year ago due to clang,
    a conditional dependency, being unavailable on these arches. Now that
    the USE flag enabling dependency on clang is masked on these arches,
    v4l-utils can be keyworded.
    
    Bug: https://bugs.gentoo.org/678940
    Package-Manager: Portage-2.3.66, Repoman-2.3.16
    Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>

 media-tv/v4l-utils/v4l-utils-1.18.0.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1f40b6c03e5baaf880a3248fd741ea86ce461df6

commit 1f40b6c03e5baaf880a3248fd741ea86ce461df6
Author:     Andrey Utkin <andrey_utkin@gentoo.org>
AuthorDate: 2020-03-11 23:34:31 +0000
Commit:     Andrey Utkin <andrey_utkin@gentoo.org>
CommitDate: 2020-03-13 23:14:33 +0000

    profiles: ppc: mask USE=bpf for v4l-utils
    
    Bug: https://bugs.gentoo.org/678940
    Reviewed-by: Georgy Yakovlev <gyakovlev@gentoo.org>
    Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>

 profiles/arch/powerpc/ppc32/package.use.mask | 4 ++++
 1 file changed, 4 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=12db506acdd75673a52d67a874f86ce5da55073d

commit 12db506acdd75673a52d67a874f86ce5da55073d
Author:     Andrey Utkin <andrey_utkin@gentoo.org>
AuthorDate: 2020-03-11 23:28:26 +0000
Commit:     Andrey Utkin <andrey_utkin@gentoo.org>
CommitDate: 2020-03-13 23:14:30 +0000

    profiles: alpha: mask USE=bpf for v4l-utils
    
    Bug: https://bugs.gentoo.org/678940
    Reviewed-by: Matt Turner <mattst88@gentoo.org>
    Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>

 profiles/arch/alpha/package.use.mask | 4 ++++
 1 file changed, 4 insertions(+)
Comment 8 Andrey Utkin gentoo-dev 2020-03-13 23:18:49 UTC
The issue is addressed now, to my understanding.
Thanks everyone involved.