Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 67890 - The latest amule-2.0.0r6 is completely stable
Summary: The latest amule-2.0.0r6 is completely stable
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo net-p2p team
URL: http://www.amule.org
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-17 08:47 UTC by John Helliwell
Modified: 2004-10-22 10:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helliwell 2004-10-17 08:47:10 UTC
Try as I might, I can't break it. It has been running on my AMD64 gentoo system for 14 days without having to restart aMule. It should be considered as stable!

Reproducible: Always
Steps to Reproduce:
1. Build aMule-2.0.0rc with wxGTX 2.5.3 with GTK1 support
2. configure with --enable-webserver --enable-amulecmd


Actual Results:  
An extremely reliable peer to peer client 

Expected Results:  
It should be marked as stable

Portage 2.0.50-r11 (default-amd64-2004.2, gcc-3.3.4, glibc-2.3.4.20040808-r1,
2.6.8-gentoo-r5)
=================================================================
System uname: 2.6.8-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache"
GENTOO_MIRRORS="http://mir.zyrianes.net/gentoo/
http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa amd64 apm arts artswrappersuid avi berkdb bitmap-fonts crypt cups
encode ex f77 foomaticdb gd gdbm gif gpm gtk gtk2 imlib ipv6 java jpeg kde
libg++ libwww mikmod motif mpeg ncurses nls nogcj nptl oggvorbis opengl oss pam
pdflib perl png python qt quicktime readline remote samba sdl slang snmp spell
ssl stats tcpd truetype xine xml2 xmms xprint xv zlib"
Comment 1 Jon Hood (RETIRED) gentoo-dev 2004-10-19 19:59:54 UTC
While i may agree with you, I stand behind my philosophy that gentoo users are not beta testers unless they choose to be. If the upstream developers think it is only worthy to be called a release candidate, I'd rather wait for what they think of as a stable release. If on the other hand you find something horribly wrong with the current version in portage, I'd be glad for an excuse like that to mark an rc stable, especially one like this ;).
Comment 2 Giacomo Perale 2004-10-22 10:25:45 UTC
"hi, rc6 is stable for linux. we call it unstable/testing only cos of mac osx"

http://forum.amule.org/thread.php?threadid=3798&sid=

rc6 has been released more than two weeks ago (there's rc7 out now), so could it go stable in a few days? (I don't remember exactly what policy tells about time in ~arch)
Comment 3 Jon Hood (RETIRED) gentoo-dev 2004-10-22 10:36:46 UTC
The minimum time in portage is 30 days with discression of the maintainer (sometimes more time, sometimes less if you have a really really good reason and don't mind QA drilling you). I will mark rc7 stable if there are no problems with it; however, bug #65413 says rc5 will not compile and bug #66852 says rc6 will not compile. More people are fine with rc7, and I will mark it stable in a few weeks IF there are no bug reports, since the developers deem it stable.