Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 678536 - dev-java/netbeans-platform-8.2 - javac: .../work/nbbuild/antsrc/org/netbeans/nbbuild/ error: ModuleSelector is not abstract and does not override abstract method isSelected(Resource) in ResourceSelector
Summary: dev-java/netbeans-platform-8.2 - javac: .../work/nbbuild/antsrc/org/netbeans/...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Miroslav Šulc
: 682192 (view as bug list)
Depends on: 685782
  Show dependency tree
Reported: 2019-02-21 22:49 UTC by jacques.bernardes
Modified: 2019-09-14 15:38 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,42.51 KB, text/plain)
2019-02-21 22:49 UTC, jacques.bernardes

Note You need to log in before you can comment on or make changes to this bug.
Description jacques.bernardes 2019-02-21 22:49:14 UTC
Created attachment 566050 [details]


When compiling netbeans-platform-8.2 the follow error arised :

    [javac] /var/tmp/portage/dev-java/netbeans-platform-8.2/work/nbbuild/antsrc/org/netbeans/nbbuild/ error: ModuleSelector is not abstract and d
oes not override abstract method isSelected(Resource) in ResourceSelector
    [javac] public final class ModuleSelector extends BaseExtendSelector {
    [javac]              ^
    [javac] /var/tmp/portage/dev-java/netbeans-platform-8.2/work/nbbuild/antsrc/org/netbeans/nbbuild/ error: ModuleStateSelector is not abst
ract and does not override abstract method isSelected(Resource) in ResourceSelector


Comment 1 Stas 2019-03-01 09:37:00 UTC
I had exactly the same error when installing dev-java / netbeans-platform-8.2.
At the same time, app-admin / apache-tools-2.4.38 was installed on the system.

After uninstalling app-admin / apache-tools-2.4.38 and installing
app-admin / apache-tools-2.4.34, dev-java / netbeans-platform-8.2 was installed correctly.
Comment 2 Stas 2019-03-01 15:00:28 UTC
You also need to install ant-core-1.9.2 instead of ant-core-1.10.5-r1
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2019-04-01 08:52:52 UTC
*** Bug 682192 has been marked as a duplicate of this bug. ***
Comment 4 ascendant512+gentoo 2019-05-07 08:46:04 UTC
I encountered this issue and did not have app-admin/apache-tools installed.
I do have dev-java/ant-core-1.10.5-r2 but dev-java/ant-core-1.9.2 is not in the tree anymore
I was able to downgrade to =dev-java/ant-core-1.9.13-r2 =dev-java/ant-junit-1.9.13-r1 (the two are paired)
After this, dev-java/netbeans-platform-8.2 built
Comment 5 Pavel Goran 2019-08-13 15:24:17 UTC
I encountered this error as well. For me, it was not netbeans-platform, but netbeans-php and netbeans-mobility.

Once I downgraded dev-util/ant and its numerous dependencies/components (such as dev-java/ant-apache-resolver) from 1.10* to 1.9*, the problematic netbeans packages could be successfully built.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-09-14 15:38:11 UTC
Package removed.