Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 678404 - dev-lang/luajit-2.1.0_beta3 version bump
Summary: dev-lang/luajit-2.1.0_beta3 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: ARM64 Linux
: Normal normal (vote)
Assignee: Rafael Martins
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2019-02-19 20:43 UTC by Roy Bamford
Modified: 2019-03-22 19:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roy Bamford gentoo-dev 2019-02-19 20:43:57 UTC
luajit-2.1.0_beta3 is the first version to support arm64
Please add to ::gentoo as arm64 is getting more popular.

Reproducible: Always

Steps to Reproduce:
1. Using arm64 hardware, a Raspberry Pi 3b will do, attempt to build  dev-lang/luajit. Notice that arm64 is not supported

2. Got to http://luajit.org/ Observe the News item

LuaJIT 2.1.0-beta3 has been released
    LuaJIT 2.1.0-beta3 is available for download.
    This is the third beta release for the new v2.1 branch. Apart from various fixes, the major new features are JIT compiler support for x64 in GC64 mode, ARM64 and MIPS64. 

3.
Actual Results:  
Described above.

Expected Results:  
luajit-2.1.0_beta3 is in ::gentoo but hard masked, so we can test on arm64.

Hacky patch to ebuild.  Its not up to ::gentoo standards but it builds luajit-2.1.0_beta3

# diff -U3 /usr/portage/dev-lang/luajit/luajit-2.0.5.ebuild  luajit-2.1.0_beta3.ebuild 
--- /usr/portage/dev-lang/luajit/luajit-2.0.5.ebuild    2018-03-22 14:38:52.000000000 +0000
+++ luajit-2.1.0_beta3.ebuild   2018-03-02 22:18:19.136716477 +0000
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -7,10 +7,13 @@
 
 MY_PV="$(get_version_component_range 1-3)"
 MY_P="LuaJIT-${MY_PV}"
-if [[ -n $(get_version_component_range 4) ]]; then
-       HOTFIX="v${PV}"
-       HOTFIX="${HOTFIX/_p/_hotfix}.patch"
-fi
+#if [[ -n $(get_version_component_range 4) ]]; then
+#      HOTFIX="v${PV}"
+#      HOTFIX="${HOTFIX/_p/_hotfix}.patch"
+#fi
+
+# For beta versions only
+MY_P=$MY_P-$(get_version_component_range 4)
 
 DESCRIPTION="Just-In-Time Compiler for the Lua programming language"
 HOMEPAGE="http://luajit.org/"
@@ -20,7 +23,7 @@
 LICENSE="MIT"
 # this should probably be pkgmoved to 2.0 for sake of consistency.
 SLOT="2"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~arm64"
 IUSE="lua52compat"
 
 S="${WORKDIR}/${MY_P}"
Comment 1 Red 2019-03-21 21:35:34 UTC
LuaJIT v2.1.0-beta3 is also required in certain cases (I forget the details) when running a games-action/minetest dedicated server to avoid crashes.
Comment 2 Red 2019-03-22 04:03:56 UTC
(In reply to Red from comment #1)
> LuaJIT v2.1.0-beta3 is also required in certain cases (I forget the details)
> when running a games-action/minetest dedicated server to avoid crashes.

Here is more details:

https://forum.minetest.net/viewtopic.php?f=3&t=18263

LuaJIT v2.1.0-beta3 is needed if Minetest needs more than 2 GB RAM, which is required if you use a lot of mods with the game (either when using single player or when running a dedicated server for players to connect to).
Comment 3 Rafael Martins gentoo-dev 2019-03-22 19:43:50 UTC
added without keywords, if the arm guys want to have it keyworded because it is the only version available, feel free to add.