Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67759 - Hard drive partitions are always automounted by g-v-m
Summary: Hard drive partitions are always automounted by g-v-m
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Project Gentopia
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-16 03:14 UTC by Marcos González
Modified: 2005-10-30 19:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
HAL policy file to stop automount of USB hard disk (sharp-pc-mm10-cradle.fdi,980 bytes, text/plain)
2005-08-06 10:09 UTC, Steve Arnold
Details
HAL policy file to stop automount of extra partitions (local-ide-drives.fdi,1.09 KB, text/plain)
2005-08-06 10:11 UTC, Steve Arnold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos González 2004-10-16 03:14:27 UTC
The problem is, although I have the "noauto" option added in my fstab entries, all partitions in my HD get mounted by hald at boot. I cannot see a way of telling hald not to mount those partitions automatically.

"noauto" does that if no media is present in the drive, hald won't try to mount it. It works with empty CD-ROM drives on boot, but as the partitions are "always inserted", hald just mounts them thinking it's a CD inserted in his drive.

Is there a way of making hald treat those units as partitions as opposite to removable media?

Mutsumi root # emerge info
Portage 2.0.50-r11 (default-x86-2004.2, gcc-3.3.4, glibc-2.3.4.20040808-r1, 2.6.8-gentoo-r8)
=================================================================
System uname: 2.6.8-gentoo-r8 i686 AMD Athlon(tm) XP 2800+
Gentoo Base System version 1.5.3
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache fixpackages sandbox"
GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gentoo.inode.at/source/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/portage /usr/local/overlays/bmg-main /usr/local/overlays/bmg-gnome-current"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow S3TC X aalib acpi alsa apache2 apm audiofile avi berkdb bitmap-fonts bonobo cddb cdr crypt cups dga directfb divx4linux dvdr eds encode esd evo f77 fam fbcon flac flash fmod foomaticdb freetype gdbm gif gimpprint gnome gpm gstreamer gtk gtk2 gtkhtml guile hal imagemagick imlib ithreads jabber java javascript joystick jpeg latex lcms libg++ libwww linguas_en linguas_es lzw-tiff mad mikmod mime mmx mng mozilla moznocompose moznoirc moznomail mozp3p mozsvg mpeg mplayer msn music ncurses net nls nntp nocardbus nptl offensive oggvorbis opengl oss pam pdflib perl pic plotutils png pnp python quicktime readline rogue sdl slang spell sse ssl stencil-buffer svg svga tcltk tcpd tetex threads tiff truetype unicode usb videos wmf x86 xatrix xface xine xml xml2 xmms xprint xv xvid zlib"
Comment 1 foser (RETIRED) gentoo-dev 2004-10-18 09:46:00 UTC
well it's actually a g-v-m bug more likely, it takes care of actually mounting the devices.

Don't think this is supported at this point.
Comment 2 foser (RETIRED) gentoo-dev 2005-01-17 10:53:23 UTC
looking at this again, for me it only mounts if it is user mountable and it's definatly gvm which does the mounting.
Comment 3 Marcos González 2005-01-17 12:12:47 UTC
Here is an extract of my fstab file:

 /dev/hda9  /mnt/desvan  vfat  rw,noauto,users,gid=users,umask=002,utf8=true  0  0
 /dev/hdb1  /mnt/backup  vfat  rw,noauto,users,gid=users,umask=002,utf8=true  0  0

I've tested some things.

 - If i remove the "users" option from fstab, the partions aren't mounted automatically, as we want, but neither appear in the nautilus "Computer" directory as unmounted. Also they can only be mounted as root, and then belong to root, not the regular user.

 - What I want is partitions behave as my removable usb pendrive and digital camera do: appear as unmounted and only be mounted on user demand.

I understand my camera mounts because udev creates the device, but as partitions are "always plugged" they can't behave the same (they are detected "plugged" just after opening the gnome session).

So I think my bug request could be summarized as this:
Ask upstream an option to start a device not mounted, but with the icon in the "Computer" appearing, so the user can mount it when he want, not forcing the device to be mounted on startup. I think people having network partitions would like this feature, too.
Comment 4 Marcos González 2005-01-20 12:51:23 UTC
Found a partial fix: enabling "automount removable devices" but disabling "automount removable media" mounts my usb pen but not the partitions, as it should be. The problem is inserting a CD doesn't make it to mount, either.

A per-mountpoint option would be the final solution. I'm missing something?
Comment 5 Jonas MG 2005-04-26 04:20:59 UTC
It's a problem of Hal. Look here:
https://bugs.gentoo.org/show_bug.cgi?id=85564
Comment 6 Steve Arnold gentoo-dev 2005-08-06 10:03:48 UTC
Well, not so much a problem, as just the default behavior applied by the default 
policy file (/usr/share/hal/fdi/90defaultpolicy/storage-policy.fdi).  The other 
directories under /usr/share/hal/fdi are there (I assume) for additional policy 
files; I put mine under 95userpolicy:

 ~ $ ls /usr/share/hal/fdi/95userpolicy/
fat_no_sync.fdi  local-ide-drives.fdi  sharp-pc-mm10-cradle.fdi

Since HAL processes the directories in order, user-specified stuff goes last. It 
also seems very Gentoo-ish (to me anyway) in that you are free to modify it on 
your own.  See the attached examples and hack away; search the forums as well.
Comment 7 Steve Arnold gentoo-dev 2005-08-06 10:09:02 UTC
Created attachment 65244 [details]
HAL policy file to stop automount of USB hard disk

Use volume names and add device to fstab:

LABEL=mm10_hd2	   /mnt/mm10	ext3	 noauto,noatime,user	 0 0
Comment 8 Steve Arnold gentoo-dev 2005-08-06 10:11:48 UTC
Created attachment 65245 [details]
HAL policy file to stop automount of extra partitions

Keep your Gentoo partitions in fstab like usual, and this policy file will stop

the automounting of any extra (non-Gentoo or whatever) partitions.
Comment 9 Steev Klimaszewski gentoo-dev 2005-10-30 19:05:28 UTC
This is the default, and can be user over-ridden.