Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 677388 - >=media-libs/mesa-19.0.0: fails u_format_test
Summary: >=media-libs/mesa-19.0.0: fails u_format_test
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: https://gitlab.freedesktop.org/mesa/m...
Whiteboard:
Keywords: TESTFAILURE
: 758869 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-06 20:32 UTC by ernsteiswuerfel
Modified: 2021-12-14 00:49 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (mesa-19.0.0_rc2:20190206-181006.log.xz,42.05 KB, application/x-xz)
2019-02-06 20:33 UTC, ernsteiswuerfel
Details
testlog.txt (testlog.txt,290.05 KB, text/plain)
2019-02-06 20:34 UTC, ernsteiswuerfel
Details
emerge --info (file_677388.txt,6.06 KB, text/plain)
2019-02-06 20:34 UTC, ernsteiswuerfel
Details
build.log.xz (19.0.8) (mesa-19.0.8:20190715-153714.log.xz,59.50 KB, application/x-xz)
2019-07-15 17:55 UTC, ernsteiswuerfel
Details
output from u_format_test (output_u_format_test.txt,162.59 KB, text/plain)
2019-07-15 17:56 UTC, ernsteiswuerfel
Details
build.log.xz (19.1.5, ppc64) (mesa-19.1.5:20190903-225904.log.xz,61.95 KB, text/plain)
2019-09-03 23:27 UTC, ernsteiswuerfel
Details
build.log.xz (20.0.0_rc1, ppc64) (mesa-20.0.0_rc1:20200203-234420.log.xz,80.16 KB, application/x-xz)
2020-02-04 00:27 UTC, ernsteiswuerfel
Details
build.log.xz (20.1.0_rc2, ppc64) (mesa-20.1.0_rc2:20200511-154529.log.xz,75.64 KB, text/plain)
2020-05-11 16:25 UTC, ernsteiswuerfel
Details
emerge --info (file_677388.txt,6.10 KB, text/plain)
2020-05-11 16:32 UTC, ernsteiswuerfel
Details
build.log.xz (20.2.4, ppc64) (mesa-20.2.4:20201211-181056.log.xz,45.42 KB, application/x-xz)
2020-12-11 18:17 UTC, ernsteiswuerfel
Details
build.log.xz (20.2.6, ppc) (mesa-20.2.6:20210208-201216.log.xz,42.15 KB, application/x-xz)
2021-02-08 21:04 UTC, ernsteiswuerfel
Details
build.log.xz (21.2.0-rc2, ppc64) (mesa-21.2.0_rc2:20210727-155954.log.xz,54.08 KB, text/plain)
2021-07-27 16:35 UTC, ernsteiswuerfel
Details
emerge --info (file_677388.txt,5.96 KB, text/plain)
2021-07-27 16:36 UTC, ernsteiswuerfel
Details
testlog.txt (21.2.0-rc2, ppc64) (testlog.txt,308.47 KB, text/plain)
2021-07-27 16:37 UTC, ernsteiswuerfel
Details
build.log.xz (21.3.1-r1, ppc) (mesa-21.3.1-r1:20211213-234529.log.xz,50.50 KB, application/x-xz)
2021-12-14 00:49 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel archtester 2019-02-06 20:32:50 UTC
[...]
OK:        46
FAIL:       1
SKIP:       0
TIMEOUT:    0


The output from the failed tests:

44/47 mesa:gallium / u_format_test            FAIL     0.10 s (exit status 1)
Comment 1 ernsteiswuerfel archtester 2019-02-06 20:33:44 UTC
Created attachment 564020 [details]
build.log.xz
Comment 2 ernsteiswuerfel archtester 2019-02-06 20:34:02 UTC
Created attachment 564022 [details]
testlog.txt
Comment 3 ernsteiswuerfel archtester 2019-02-06 20:34:33 UTC
Created attachment 564024 [details]
emerge --info
Comment 4 Matt Turner gentoo-dev 2019-02-07 17:41:32 UTC
Does it fail with 18.3.x? Can you try to bisect the failure if so?
Comment 5 ernsteiswuerfel archtester 2019-02-07 19:13:11 UTC
(In reply to Matt Turner from comment #4)
> Does it fail with 18.3.x? Can you try to bisect the failure if so?
Nope, 18.3.3 passes tests just fine. The "44/47 mesa:gallium / u_format_test" failing in 19.0.0_rc2 is not included in 18.3.3 test suite.

[...]
>>> Test phase: media-libs/mesa-18.3.3
 * abi_ppc_64.ppc64: running multilib-minimal_abi_src_test
ninja -v -j34 -l32 -C /var/tmp/portage/media-libs/mesa-18.3.3/work/mesa-18.3.3-abi_ppc_64.ppc64 test
ninja: Entering directory `/var/tmp/portage/media-libs/mesa-18.3.3/work/mesa-18.3.3-abi_ppc_64.ppc64'
[1/16] /usr/bin/python3.6 ../mesa-18.3.3/bin/git_sha1_gen.py --output src/git_sha1.h
[1/2] /usr/lib64/python-exec/python3.6/meson test --no-rebuild --print-errorlogs
 1/42 mesa / u_atomic                         OK       0.04 s 
 2/42 mesa / roundeven                        OK       0.04 s 
 3/42 mesa / mesa-sha1                        OK       0.04 s 
 4/42 mesa / fast_idiv_by_const               OK       2.42 s 
 5/42 mesa / clear                            OK       0.05 s 
 6/42 mesa / collision                        OK       0.04 s 
 7/42 mesa / delete_and_lookup                OK       0.06 s 
 8/42 mesa / delete_management                OK       0.08 s 
 9/42 mesa / destroy_callback                 OK       0.08 s 
10/42 mesa / insert_and_lookup                OK       0.05 s 
11/42 mesa / insert_many                      OK       0.04 s 
12/42 mesa / null_destroy                     OK       0.04 s 
13/42 mesa / random_entry                     OK       0.06 s 
14/42 mesa / remove_key                       OK       0.09 s 
15/42 mesa / remove_null                      OK       0.05 s 
16/42 mesa / replacement                      OK       0.07 s 
17/42 mesa / string_buffer                    OK       0.05 s 
18/42 mesa / vma_random                       OK       0.09 s 
19/42 mesa / set                              OK       0.12 s 
20/42 mesa / shared-glapi-test                OK       0.11 s 
21/42 mesa / es2-ABI-check                    OK       0.22 s 
22/42 mesa / nir_control_flow                 OK       0.05 s 
23/42 mesa / nir_vars                         OK       0.13 s 
24/42 mesa / glcpp test (unix)                OK       1.42 s 
25/42 mesa / glcpp test (windows)             OK       1.43 s 
26/42 mesa / glcpp test (oldmac)              OK       1.55 s 
27/42 mesa / glcpp test (bizarro)             OK       1.50 s 
28/42 mesa / blob_test                        OK       0.15 s 
29/42 mesa / cache_test                       OK       4.81 s 
30/42 mesa / general_ir_test                  OK       0.19 s 
31/42 mesa / uniform_initializer_test         OK       0.24 s 
32/42 mesa / sampler_types_test               OK       0.23 s 
33/42 mesa / glsl compiler warnings           OK       0.63 s 
34/42 mesa / glsl optimization                OK       0.69 s 
35/42 mesa:glx / dispatch-index-check         OK       0.27 s 
36/42 mesa / glx-test                         OK       0.19 s 
37/42 mesa / gbm-symbols-check                OK       0.11 s 
38/42 mesa / egl-symbols-check                OK       0.21 s 
39/42 mesa / egl-entrypoint-check             OK       0.22 s 
40/42 mesa / r300_compiler_test               OK       0.18 s 
41/42 mesa / st_renumerate_test               OK       0.14 s 
42/42 mesa / st-array-merge-test              OK       0.10 s 

OK:        42
FAIL:       0
SKIP:       0
TIMEOUT:    0
Comment 6 ernsteiswuerfel archtester 2019-02-12 13:51:44 UTC
Took it upstream.
Comment 7 ernsteiswuerfel archtester 2019-07-15 17:54:21 UTC
Same for mesa-19.0.8 and mesa-19.1.2.
Comment 8 ernsteiswuerfel archtester 2019-07-15 17:55:24 UTC
Created attachment 582898 [details]
build.log.xz (19.0.8)
Comment 9 ernsteiswuerfel archtester 2019-07-15 17:56:01 UTC
Created attachment 582900 [details]
output from u_format_test
Comment 10 ernsteiswuerfel archtester 2019-09-03 23:27:31 UTC
Created attachment 589018 [details]
build.log.xz (19.1.5, ppc64)
Comment 11 ernsteiswuerfel archtester 2020-02-04 00:27:24 UTC
Created attachment 611540 [details]
build.log.xz (20.0.0_rc1, ppc64)

Re-tested with 20.0.0_rc1 and a more recent toolchain (gcc 9.2.0, glibc 2.29, binutils 2.32, llvm 9.0.1).

[...]
28/68 mesa:format / u_format_test             FAIL     0.04 s (exit status 1)
40/68 mesa:compiler+nir / load_store_vectorizer  FAIL     0.05 s (exit status 1)
57/68 mesa:llvmpipe / lp_test_format          FAIL     3.10 s (exit status 1)
58/68 mesa:llvmpipe / lp_test_arit            FAIL     0.53 s (exit status 1)


Ok:                   64
Expected Fail:         0
Fail:                  4
Unexpected Pass:       0
Skipped:               0
Timeout:               0
Comment 12 ernsteiswuerfel archtester 2020-05-11 16:25:56 UTC
Created attachment 638206 [details]
build.log.xz (20.1.0_rc2, ppc64)

20.1.0_rc2 fails one test less.

[...]
29/69 mesa:format / u_format_test             FAIL     0.29 s (exit status 1)
58/69 mesa:llvmpipe / lp_test_format          FAIL    13.56 s (exit status 1)
59/69 mesa:llvmpipe / lp_test_arit            FAIL     1.82 s (exit status 1)


Ok:                   66
Expected Fail:         0
Fail:                  3
Unexpected Pass:       0
Skipped:               0
Timeout:               0
Comment 13 ernsteiswuerfel archtester 2020-05-11 16:32:40 UTC
Created attachment 638208 [details]
emerge --info
Comment 14 Thomas Deutschmann gentoo-dev 2020-12-07 01:38:56 UTC
*** Bug 758869 has been marked as a duplicate of this bug. ***
Comment 15 Thomas Deutschmann gentoo-dev 2020-12-07 01:39:58 UTC
Looks more like a general 32bit issue, not?
Comment 16 Matt Turner gentoo-dev 2020-12-07 01:43:35 UTC
(In reply to Thomas Deutschmann from comment #15)
> Looks more like a general 32bit issue, not?

No. The PowerPC failures are due to endianness. The x86 failures are due to x87 FPU precision differences (and are not going to be fixed, short of using -mfpmath=sse -msse2).
Comment 17 ernsteiswuerfel archtester 2020-12-11 18:17:29 UTC
Created attachment 677956 [details]
build.log.xz (20.2.4, ppc64)
Comment 18 ernsteiswuerfel archtester 2021-02-08 21:04:17 UTC
Created attachment 686094 [details]
build.log.xz (20.2.6, ppc)
Comment 19 Rolf Eike Beer archtester 2021-03-22 18:50:42 UTC
same on sparc
Comment 20 Matt Turner gentoo-dev 2021-06-01 22:43:47 UTC
This is now fixed upstream by https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/7776

Will be in 21.2.
Comment 21 ernsteiswuerfel archtester 2021-07-27 16:35:52 UTC
Created attachment 727341 [details]
build.log.xz (21.2.0-rc2, ppc64)

Not quite there yet... At least on my Talos II. I'll update the upstream bug accordingly.

[...]
72/82 mesa:llvmpipe / lp_test_arit                  FAIL               0.63s   exit status 1
>>> MALLOC_PERTURB_=163 /var/tmp/portage/media-libs/mesa-21.2.0_rc2/work/mesa-21.2.0-rc2-.ppc64/src/gallium/drivers/llvmpipe/lp_test_arit

77/82 mesa:amd / ac_surface_modifier_test           FAIL               1.04s   killed by signal 6 SIGABRT
>>> MALLOC_PERTURB_=138 /var/tmp/portage/media-libs/mesa-21.2.0_rc2/work/mesa-21.2.0-rc2-.ppc64/src/amd/common/ac_surface_modifier_test

80/82 mesa:llvmpipe / lp_test_format                FAIL               3.54s   exit status 1
>>> MALLOC_PERTURB_=154 /var/tmp/portage/media-libs/mesa-21.2.0_rc2/work/mesa-21.2.0-rc2-.ppc64/src/gallium/drivers/llvmpipe/lp_test_format


Ok:                 79  
Expected Fail:      0   
Fail:               3   
Unexpected Pass:    0   
Skipped:            0   
Timeout:            0
Comment 22 ernsteiswuerfel archtester 2021-07-27 16:36:47 UTC
Created attachment 727344 [details]
emerge --info
Comment 23 ernsteiswuerfel archtester 2021-07-27 16:37:22 UTC
Created attachment 727347 [details]
testlog.txt (21.2.0-rc2, ppc64)
Comment 24 ernsteiswuerfel archtester 2021-07-27 17:49:41 UTC
Oops, sorry I got confused... This original bug report was about "u_format_test" test failing. Which passes now in 21.2.0-rc2 as Matt stated in Comment #20. What is left failing now is "lp_test_format".

Also I realize now I linked the wrong upstream bug report here, confusing these two again. Will correct this.
Comment 25 Rolf Eike Beer archtester 2021-08-12 07:22:44 UTC
It's still there on sparc:

37/72 mesa:format / u_format_test                   FAIL              4.82s   exit status 1
>>> MALLOC_PERTURB_=69 /var/tmp/portage/media-libs/mesa-21.1.6/work/mesa-21.1.6-.sparc32/src/util/tests/format/u_format_test
Comment 26 ernsteiswuerfel archtester 2021-08-12 10:23:25 UTC
(In reply to Rolf Eike Beer from comment #25)
> It's still there on sparc:
> 
> 37/72 mesa:format / u_format_test                   FAIL              4.82s 
> exit status 1
> >>> MALLOC_PERTURB_=69 /var/tmp/portage/media-libs/mesa-21.1.6/work/mesa-21.1.6-.sparc32/src/util/tests/format/u_format_test
Should be gone in 21.2.0. I think upstream explicitly mentioned testing on sparc.
Comment 27 ernsteiswuerfel archtester 2021-12-14 00:49:27 UTC
Created attachment 758842 [details]
build.log.xz (21.3.1-r1, ppc)

Also tested on 32bit ppc, u_format_test passes meanwhile. Also passes on ppc64 and x86 as mentioned in the upstream bugreport.

[...]
37/79 mesa:format / u_format_test                   OK                0.74s
38/79 mesa:compiler+nir / nir_builder               OK                0.71s
39/79 mesa:compiler+nir / nir_core                  OK                0.46s
40/79 mesa:compiler+nir / nir_vars                  OK                0.38s
41/79 mesa:compiler+nir / nir_control_flow          OK                0.78s
42/79 mesa:mapi / shared-glapi symbols check        OK                1.36s
43/79 mesa:compiler+nir / negative_equal            OK                0.64s
44/79 mesa:compiler+nir / comparison_pre            OK                0.57s
45/79 mesa:compiler+nir / load_store_vectorizer     OK                0.54s
46/79 mesa:compiler+nir / nir_serialize_test        OK                0.58s
47/79 mesa:compiler+nir / nir_opt_if                OK                0.58s
48/79 mesa:compiler+nir / nir_lower_returns         OK                0.55s
49/79 mesa:compiler+nir / ssa_def_bits_used         OK                0.53s
50/79 mesa:compiler+spirv / avail_vis               OK                0.50s
51/79 mesa:compiler+spirv / volatile                OK                0.53s
52/79 mesa:compiler+nir / algebraic                 OK                0.98s
53/79 mesa:compiler+glsl / general_ir_test          OK                0.38s
54/79 mesa:compiler+glsl / uniform_initializer_test OK                0.27s
55/79 mesa:compiler+glsl / sampler_types_test       OK                0.22s
56/79 mesa:compiler+glsl / list_iterators           OK                0.23s
57/79 mesa:compiler+nir / nir_algebraic_parser      OK                4.88s
58/79 mesa:compiler+glsl / glsl optimization        OK                7.27s
59/79 mesa:mesa / main-test                         OK                0.56s
60/79 mesa:glx / dispatch-index-check               OK                1.31s
61/79 mesa:glx / glx-test                           OK                0.64s
62/79 mesa:gbm / gbm-abi-check                      OK                0.18s
63/79 mesa:gbm / gbm-symbols-check                  OK                2.07s
64/79 mesa:r300 / r300_compiler_test                OK                0.51s
65/79 mesa:gallium / pipe_barrier_test              OK                1.11s
66/79 mesa:gallium / u_half_test                    OK                0.26s
67/79 mesa:gallium / u_prim_verts_test              OK                0.22s
68/79 mesa:st_mesa / st_format_test                 OK                0.28s
69/79 mesa:compiler+glsl / glsl compiler warnings   OK               16.53s
70/79 mesa:st_mesa / st_renumerate_test             OK                0.36s
71/79 mesa:st_mesa / st-array-merge-test            OK                0.42s
72/79 mesa:egl / egl-symbols-check                  OK                1.89s
73/79 mesa:egl / egl-entrypoint-check               OK                1.76s
74/79 mesa:compiler+glcpp / glcpp test (windows)    OK               22.76s
75/79 mesa:compiler+glcpp / glcpp test (unix)       OK               23.10s
76/79 mesa:compiler+glcpp / glcpp test (oldmac)     OK               23.05s
77/79 mesa:compiler+glcpp / glcpp test (bizarro)    OK               22.90s
78/79 mesa:util / sparse_array_multi_threaded       OK               26.24s
79/79 mesa:util / fast_idiv_by_const                OK               27.84s


Ok:                 79  
Expected Fail:      0   
Fail:               0   
Unexpected Pass:    0   
Skipped:            0   
Timeout:            0