Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 677210 - www-client/firefox-65.0 - configure: error: System SQLite library is not compiled with SQLITE_SECURE_DELETE.
Summary: www-client/firefox-65.0 - configure: error: System SQLite library is not comp...
Status: RESOLVED DUPLICATE of bug 672918
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-03 17:52 UTC by Vasilis Lourdas
Modified: 2019-02-04 16:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vasilis Lourdas 2019-02-03 17:52:43 UTC
0:15.05 checking for sqlite3 >= 3.25.3... yes
 0:15.05 checking SQLITE_CFLAGS...
 0:15.05 checking SQLITE_LIBS... -lsqlite3
 0:15.23 checking for SQLITE_SECURE_DELETE support in system SQLite... no
 0:15.23 configure: error: System SQLite library is not compiled with SQLITE_SECURE_DELETE.
 0:15.25 DEBUG: <truncated - see config.log for full output>
 0:15.25 DEBUG: /usr/include/features.h:381:4: warning: _FORTIFY_SOURCE requires compiling with optimization (-O) [-W#warnings]
 0:15.25 DEBUG: #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
 0:15.25 DEBUG:    ^
 0:15.25 DEBUG: 1 warning generated.
 0:15.25 DEBUG: configure:12048: checking for wget
 0:15.25 DEBUG: configure:12349: checking for sqlite3 >= 3.25.3
 0:15.25 DEBUG: configure:12356: checking SQLITE_CFLAGS
 0:15.25 DEBUG: configure:12361: checking SQLITE_LIBS
 0:15.25 DEBUG: configure:12392: checking for SQLITE_SECURE_DELETE support in system SQLite
 0:15.25 DEBUG: configure:12415: /usr/lib/llvm/6/bin/x86_64-pc-linux-gnu-clang -std=gnu99 -o conftest -pipe -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread  -Qunused-arguments  -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -lpthread -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-rpath=/usr/lib64/firefox,--enable-new-dtags -fuse-ld=lld -Wl,-z,noexecstack -Wl,-z,text -Wl,-z,relro -Wl,-z,nocopyreloc -Wl,-Bsymbolic-functions conftest.c -ldl  -lsqlite3 1>&5
 0:15.25 DEBUG: configure: failed program was:
 0:15.25 DEBUG: #line 12406 "configure"
 0:15.25 DEBUG: #include "confdefs.h"
 0:15.25 DEBUG:
 0:15.25 DEBUG:             #include "sqlite3.h"
 0:15.25 DEBUG:
 0:15.25 DEBUG:             int main(int argc, char **argv){
 0:15.25 DEBUG:               return !sqlite3_compileoption_used("SQLITE_SECURE_DELETE");
 0:15.25 DEBUG:             }
 0:15.25 DEBUG: configure: error: System SQLite library is not compiled with SQLITE_SECURE_DELETE.
 0:15.25 ERROR: old-configure failed
 0:15.27 *** Fix above errors and then restart with\
 0:15.27                "./mach build"
 0:15.27 gmake: *** [client.mk:115: configure] Error 1
 * ERROR: www-client/firefox-65.0::gentoo failed (configure phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line 124:  Called src_configure
 *   environment, line 5226:  Called die
 * The specific snippet of code:
 *       SHELL="${SHELL:-${EPREFIX}/bin/bash}" MOZ_NOSPAM=1 ./mach configure || die
 * 
 * If you need support, post the output of `emerge --info '=www-client/firefox-65.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/firefox-65.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/www-client/firefox-65.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/firefox-65.0/temp/environment'.
 * Working directory: '/var/tmp/portage/www-client/firefox-65.0/work/firefox-65.0'
 * S: '/var/tmp/portage/www-client/firefox-65.0/work/firefox-65.0'


However, sqlite is indeed compiled with this flag:

emerge -vp sqlite

These are the packages that would be merged, in order:

Calculating dependencies ... done!                       
[ebuild   R    ] dev-db/sqlite-3.25.3:3::gentoo  USE="icu readline secure-delete -debug -doc -static-libs -tcl -test -tools" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-02-04 08:16:04 UTC
So how do you end up with sqlite without secure delete? It is enforced by the ebuuld: https://gitweb.gentoo.org/repo/gentoo.git/tree/www-client/firefox/firefox-65.0.ebuild?id=404b7b207032587df0da71e5e29cf6e6aa484b3b#n92
Comment 2 Vasilis Lourdas 2019-02-04 14:59:20 UTC
(In reply to Thomas Deutschmann from comment #1)
> So how do you end up with sqlite without secure delete? It is enforced by
> the ebuuld:
> https://gitweb.gentoo.org/repo/gentoo.git/tree/www-client/firefox/firefox-65.
> 0.ebuild?id=404b7b207032587df0da71e5e29cf6e6aa484b3b#n92

But, in my initial message, I wrote that sqlite is already built with the secure-delete flag.
Comment 3 Thomas Deutschmann gentoo-dev Security 2019-02-04 16:36:12 UTC
You haven't attached complete build.log yet so I am guessing and closing as duplicate of bug 672918.

*** This bug has been marked as a duplicate of bug 672918 ***