Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67691 - ERROR: x11-libs/libzvt-2.0.1-r2 failed. Function gnome2_src_compile, Line 40, Exitcode 2
Summary: ERROR: x11-libs/libzvt-2.0.1-r2 failed. Function gnome2_src_compile, Line 4...
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High blocker (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 93229 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-15 11:23 UTC by Luke Schierer
Modified: 2005-05-19 10:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
disable -j (libzvt-parallel.patch,397 bytes, patch)
2005-05-17 08:38 UTC, Rafael Ávila de Espíndola
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Schierer 2004-10-15 11:23:09 UTC
gcc -O2 -march=pentium4 -pipe -fomit-frame-pointer -o gnome-pty-helper gnome-pty-helper.o gnome-login-support.o gnome-utmp.o  -lutil
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/libart-2.0 -DGNOMEZVTLIBDIR=\"/usr/lib\" -DGNOMEZVTDATADIR=\"/usr/share\" -DGNOMEZVTPIXMAPDIR=\"/usr/share/pixmaps\" -DGNOMEZVTBINDIR=\"/usr/bin\" -DGNOMEZVTLOCALSTATEDIR=\"/var/lib\" -DGNOMEZVTLOCALEDIR=\"\" -DGTK_VERSION=\"\" -DG_LOG_DOMAIN=\"ZVT\" -DPTY_HELPER_DIR=\"/usr/libexec/libzvt-2.0\" -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -O2 -march=pentium4 -pipe -fomit-frame-pointer -c lists.c -o lists.o >/dev/null 2>&1
gcc: gnome-login-support.o: No such file or directory
make[2]: *** [gnome-pty-helper] Error 1
make[2]: *** Waiting for unfinished jobs....

...

make[2]: Leaving directory `/var/tmp/portage/libzvt-2.0.1-r2/work/libzvt-2.0.1/libzvt'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libzvt-2.0.1-r2/work/libzvt-2.0.1'
make: *** [all-recursive-am] Error 2

!!! ERROR: x11-libs/libzvt-2.0.1-r2 failed.
!!! Function gnome2_src_compile, Line 40, Exitcode 2
!!! compile failure
!!! If you need support, post the topmost build error, NOT this status message.



Reproducible: Always
Steps to Reproduce:
1. emerge -u world with gnome installed
2. watch that it requires a new package, libzvt
3. watch the compile of libzvt fail as per the above error message

Actual Results:  
compile fails as per details section

Expected Results:  
compile succeeds. 

Portage 2.0.51_rc9 (default-x86-2004.0, gcc-3.4.2, glibc-2.3.4.20041006-r0,
2.6.7-LS1 i686)
=================================================================
System uname: 2.6.7-LS1 i686 Intel(R) Xeon(TM) CPU 2.66GHz
Gentoo Base System version 1.5.3
distcc 2.18 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config
/usr/kde/3.3/share/config:/usr/kde/3.3/env:/usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox"
GENTOO_MIRRORS="http://192.168.23.6/gentoo/
http://ftp-mirror.internap.com/pub/gentoo/
ftp://mirrors.sec.informatik.tu-darmstadt.de/gentoo/
http://gentoo.mirrors.pair.com/ http://gentoo.chem.wisc.edu/gentoo/"
MAKEOPTS="-j24"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://192.168.23.6/gentoo-portage"
USE="X aim alsa apm arts audiofile avi berkdb bitmap-fonts cdr crypt cups djbfft
doc dvd encode esd f77 flac foomaticdb gdbm gif gnome gnutls gpm gtk gtk2 guile
iconv imap imlib jabber java jpeg libg++ libwww mad maildir mikmod mmx motif
mozilla mpeg mpi nas ncurses nls nptl offensive oggvorbis opengl pam pdflib perl
png python quicktime readline ruby samba sdl slang spell sse sse2 ssl svg svga
tcpd truetype unicode x86 xinerama xml2 xmms xprint xv xvid zlib"
Comment 1 foser (RETIRED) gentoo-dev 2004-10-16 04:11:52 UTC
maybe set a more reasonable set of makejobs.
Comment 2 Luke Schierer 2004-10-16 07:56:52 UTC
good catch, thanks. that was a hold over from when I was using distcc across 6 different computers, it wasn't unreasonable then. 
Comment 3 Rafael Ávila de Espíndola 2005-05-11 09:15:50 UTC
Failling with a large -j value is an indication that a dependency is missing from the makefile (i.e a bug). Shouldn't this bug be reopened and marked as upstream?
Comment 4 Rafael Ávila de Espíndola 2005-05-17 08:38:37 UTC
Created attachment 59126 [details, diff]
disable -j
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-05-19 09:47:57 UTC
*** Bug 93229 has been marked as a duplicate of this bug. ***
Comment 6 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2005-05-19 10:16:39 UTC
http://bugs.gnome.org/show_bug.cgi?id=304781
I've filled it upstream, please mark it as such.