Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 676086 - sci-geosciences/viking-1.7 - vikmapslayer.c:2538:14: error: ‘VikMapsLayer’ {aka ‘struct _VikMapsLayer’} has no member named ‘mbtiles’
Summary: sci-geosciences/viking-1.7 - vikmapslayer.c:2538:14: error: ‘VikMapsLayer’ {a...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords:
: 721392 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-23 06:02 UTC by Stefan Strogin
Modified: 2021-03-12 10:31 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,185.69 KB, text/plain)
2019-01-23 06:02 UTC, Stefan Strogin
Details
environment (environment,87.23 KB, text/plain)
2019-01-23 06:03 UTC, Stefan Strogin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Strogin gentoo-dev 2019-01-23 06:02:52 UTC
Created attachment 562562 [details]
build.log

$ emerge -pqv '=sci-geosciences/viking-1.7::gentoo'
[ebuild     U ] sci-geosciences/viking-1.7 [1.6.2-r2] USE="exif magic nls -doc -geoclue% -gps -libexif -mapnik -sqlite"

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DVIKING_DATADIR=\""/usr/share/viking"\" -DVIKING_SYSCONFDIR=\""/etc/viking"\"  -Wall -g -D_GNU_SOURCE -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -march=skylake -O2 -pipe -c -o vikmapslayer.o vikmapslayer.c
vikmapslayer.c: In function ‘maps_layer_add_menu_items’:
vikmapslayer.c:2538:14: error: ‘VikMapsLayer’ {aka ‘struct _VikMapsLayer’} has no member named ‘mbtiles’
     if ( !vml->mbtiles ) {
              ^~
make[3]: *** [Makefile:1081: vikmapslayer.o] Error 1
make[3]: Leaving directory '/var/tmp/portage/sci-geosciences/viking-1.7/work/viking-1.7/src'
make[2]: *** [Makefile:1135: all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/sci-geosciences/viking-1.7/work/viking-1.7/src'
make[1]: *** [Makefile:805: all] Error 2
make[1]: Leaving directory '/var/tmp/portage/sci-geosciences/viking-1.7/work/viking-1.7/src'
make: *** [Makefile:470: all-recursive] Error 1
Comment 1 Stefan Strogin gentoo-dev 2019-01-23 06:03:37 UTC
Created attachment 562564 [details]
environment
Comment 2 Hans de Graaff gentoo-dev 2019-01-23 06:30:10 UTC
This looks like an upstream bug. Can you confirm that this does not happen when the sqlite USE flag is enabled? That should enable the mbtiles option and avoid this compile error.
Comment 3 Ed Santiago 2019-01-23 13:14:09 UTC
(In reply to Hans de Graaff from comment #2)
> This looks like an upstream bug. Can you confirm that this does not happen
> when the sqlite USE flag is enabled? 

Confirmed: compile fails by default on my setup, succeeds with USE=sqlite (modulo tweaking as per #676106)
Comment 4 Stefan Strogin gentoo-dev 2019-01-23 16:14:29 UTC
> Confirmed: compile fails by default on my setup, succeeds with USE=sqlite
+1
Comment 5 Martin Dummer 2020-03-18 22:49:35 UTC
> Confirmed: compile fails by default on my setup, succeeds with USE=sqlite

Here too!
Comment 6 Hans de Graaff gentoo-dev 2020-05-10 05:44:47 UTC
*** Bug 721392 has been marked as a duplicate of this bug. ***
Comment 7 Agostino Sarubbo gentoo-dev 2021-01-06 20:49:10 UTC
Dear treecleaner@:

I'm still able to reproduce this issue right now.

Since it has not been fixed for a long time, I'd suggest to evaluate if it is the case to remove this package from the tree. Thanks
Comment 8 Andreas Mair 2021-01-19 13:13:35 UTC
Upstream knows about this and has fixed the bug, but not yet released an update. See "New Dependencies" at https://sourceforge.net/p/viking/wikiallura/Main_Page/
Comment 9 Hans de Graaff gentoo-dev 2021-03-12 09:32:54 UTC
(In reply to Andreas Mair from comment #8)
> Upstream knows about this and has fixed the bug, but not yet released an
> update. See "New Dependencies" at
> https://sourceforge.net/p/viking/wikiallura/Main_Page/

Yes, this is still broken with viking 1.8 (as documented on that page).
Comment 10 Larry the Git Cow gentoo-dev 2021-03-12 10:31:34 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=24f3f99f93f6ed4313e9aedfcc14c35aaa4215b3

commit 24f3f99f93f6ed4313e9aedfcc14c35aaa4215b3
Author:     Andrey Grozin <grozin@gentoo.org>
AuthorDate: 2021-03-12 10:30:58 +0000
Commit:     Andrey Grozin <grozin@gentoo.org>
CommitDate: 2021-03-12 10:30:58 +0000

    sci-geosciences/viking: depend on sqlite unconditionally
    
    1.8 still does not compile with USE=-sqlite,
    so, make it mandatory
    Closes: https://bugs.gentoo.org/676086
    Package-Manager: Portage-3.0.17, Repoman-3.0.2
    Signed-off-by: Andrey Grozin <grozin@gentoo.org>

 sci-geosciences/viking/viking-1.8-r1.ebuild | 100 ++++++++++++++++++++++++++++
 1 file changed, 100 insertions(+)