Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 675914 - app-admin/conky-1.10.8-r5 - conky: error while loading shared libraries: libtcp-portmon.so: cannot open shared object file: No such file or directory
Summary: app-admin/conky-1.10.8-r5 - conky: error while loading shared libraries: libt...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Daniel Pielmeier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-20 15:15 UTC by jorgicio
Modified: 2019-03-09 16:11 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jorgicio 2019-01-20 15:15:24 UTC
This happens when I try to run conky-1.10.8-r5 after upgrading:

hackenherr:~ jorgicio% conky                                                                                                                                   [12:12:21]
conky: error while loading shared libraries: libtcp-portmon.so: cannot open shared object file: No such file or directory


So it cannot find that library. In the previous version (-r4) this didn't happen.

Thanks!

Reproducible: Always
Comment 1 Wendy 2019-01-21 16:43:33 UTC
Same here (on amd64)
Comment 2 Daniel Pielmeier gentoo-dev 2019-01-21 18:08:29 UTC
@David/Andreas:

Starting with conky-1.10.8-r5 the ebuild uses EAPI 7. This change [1] in cmake-utils.eclass seems to cause the issue.

ldd /usr/bin/conky | grep portmon for conky-1.10.8-r5 returns
libtcp-portmon.so => not found
For conky-1.10.8-r4 this line does not exist.

For testing purposes I reverted the eclass change and the issue is gone.

For a more permanent solution I tried to add
set( BUILD_SHARED_LIBS OFF CACHE BOOL "Build all libraries as shared" )
to CMakeLists.txt as mentioned in the Example referenced from the Changelog but the issue persists. Any clue what I might doing wrong?

[1] https://gitweb.gentoo.org/repo/gentoo.git/commit/eclass/cmake-utils.eclass?id=e4df47d60417b51aaf1cc526c124a21252d4fefe
Comment 3 devsk 2019-01-21 23:03:50 UTC
Can we mask the r5 version until this bug is fixed? We can't break upgrades like this.
Comment 4 max 2019-01-22 09:24:39 UTC
As a workaround, one can emerge conky without the portmon use flag.
Comment 5 Jerome Venturi 2019-01-22 16:19:46 UTC
As a workaround :

emerge =app-admin/conky-1.10.8-r4
echo "=app-admin/conky-1.10.8-r5" >> /etc/portage/package.mask
Comment 6 Daniel Pielmeier gentoo-dev 2019-03-08 22:12:42 UTC
I have added conky-1.10.8-r6 which should fix this issue. Apparently the tcp-portmon library was not installed. This was an issue for building it shared but not when building it static.

Please test and reopen if there are still issues.
Comment 7 jorgicio 2019-03-09 15:23:29 UTC
(In reply to Daniel Pielmeier from comment #6)
> I have added conky-1.10.8-r6 which should fix this issue. Apparently the
> tcp-portmon library was not installed. This was an issue for building it
> shared but not when building it static.
> 
> Please test and reopen if there are still issues.

Tried with 1.10.8-r6 and worked. However, the -r7 version fails again with the same issue mentioned here.
Comment 8 Daniel Pielmeier gentoo-dev 2019-03-09 16:05:37 UTC
(In reply to jorgicio from comment #7)
> (In reply to Daniel Pielmeier from comment #6)
> > I have added conky-1.10.8-r6 which should fix this issue. Apparently the
> > tcp-portmon library was not installed. This was an issue for building it
> > shared but not when building it static.
> > 
> > Please test and reopen if there are still issues.
> 
> Tried with 1.10.8-r6 and worked. However, the -r7 version fails again with
> the same issue mentioned here.

Yeah with r7 I went to far. r6 was installing the shared library but under the fixed path /usr/lib64.

With r7 I used a variable to install under /usr/lib or /usr/lib64 depending on the operating system being 32 or 64 bit. Additionally I placed it under the subdirectory conky like the other libraries it installs. This however made it fail again.

I removed the subdirectory with r8 so it should work again!
Comment 9 jorgicio 2019-03-09 16:11:57 UTC
(In reply to Daniel Pielmeier from comment #8)
> (In reply to jorgicio from comment #7)
> > (In reply to Daniel Pielmeier from comment #6)
> > > I have added conky-1.10.8-r6 which should fix this issue. Apparently the
> > > tcp-portmon library was not installed. This was an issue for building it
> > > shared but not when building it static.
> > > 
> > > Please test and reopen if there are still issues.
> > 
> > Tried with 1.10.8-r6 and worked. However, the -r7 version fails again with
> > the same issue mentioned here.
> 
> Yeah with r7 I went to far. r6 was installing the shared library but under
> the fixed path /usr/lib64.
> 
> With r7 I used a variable to install under /usr/lib or /usr/lib64 depending
> on the operating system being 32 or 64 bit. Additionally I placed it under
> the subdirectory conky like the other libraries it installs. This however
> made it fail again.
> 
> I removed the subdirectory with r8 so it should work again!

Ok, I got it, so I upgraded and now r8 works again.

Thanks!