Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 675564 - media-libs/nv-codec-headers should not depend on >=x11-drivers/nvidia-drivers-390.25
Summary: media-libs/nv-codec-headers should not depend on >=x11-drivers/nvidia-drivers...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-16 07:54 UTC by John Stile
Modified: 2019-12-16 11:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Stile 2019-01-16 07:54:56 UTC
I use:
x11-drivers/nvidia-drivers-340 series driver
x11-base/xorg-drivers-1.20
x11-base/xorg-server-1.20

Trying to update my system, these packages require nv-codec-headers
 media-video/ffmpeg-4.1
 dev-util/electron-2.0.10

This resulted in the following conflict:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-video/ffmpeg-4.1::gentoo[video_cards_nvidia]
# required by dev-util/electron-2.0.10::gentoo[system-ffmpeg]
# required by @selected
# required by @world (argument)
=media-libs/nv-codec-headers-8.1.24.2 ~amd64

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by media-libs/nv-codec-headers-8.1.24.2::gentoo
# required by media-video/ffmpeg-4.1::gentoo[video_cards_nvidia]
# required by dev-util/electron-2.0.10::gentoo[system-ffmpeg]
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
# xorg-1.8 needs newer driver
=x11-drivers/nvidia-drivers-415.25

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-video/ffmpeg-4.1::gentoo[video_cards_nvidia]
# required by dev-util/electron-2.0.10::gentoo[system-ffmpeg]
# required by @selected
# required by @world (argument)
>=media-libs/nv-codec-headers-8.1.24.2 abi_x86_32

I think nv-codec-headers install should be satisfied by the current nvidia drivers (e.g 340.107).

[I] x11-drivers/nvidia-drivers
     Available versions:  [M]304.137(0/304)^md 340.107(0/340)^md [M]375.82(0/375)^md [M]378.13-r1(0/378)^md [M]381.22-r1(0/381)^md [M]384.130(0/384)^md [M]387.34(0/387)^md [m]390.87(0/390)^md [M]396.54(0/396)^md [m]410.78(0/410)^md [m](~)410.93(0/410)^md [m]415.25(0/415)^md {+X acpi compat +driver gtk3 +kms multilib pax_kernel static-libs +tools uvm wayland ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="FreeBSD linux"}
     Installed versions:  340.107(0/340)^md(08:03:41 PM 01/15/2019)(X acpi multilib tools -pax_kernel -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="linux -FreeBSD")
     Homepage:            http://www.nvidia.com/ http://www.nvidia.com/Download/Find.aspx
     Description:         NVIDIA Accelerated Graphics Driver


I was able to get around this by forcing the install of media-libs/nv-codec-headers with --nodeps.
Comment 1 Alexis Ballier gentoo-dev 2019-12-16 11:50:11 UTC
https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git;a=blob;f=README;h=263af2ca70c85b6de5a9b077ff05a39cab5f9818;hb=HEAD

reads:

Minimum required driver versions:
 Linux: 435.21 or newer

so it should actually be higher than that