Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 675080 - sci-geosciences/grass-7.4.1 - Fatal Error: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8), and wxPython used 3.0 (wchar_t,compiler with C++ ...
Summary: sci-geosciences/grass-7.4.1 - Fatal Error: Mismatch between the program and l...
Status: RESOLVED DUPLICATE of bug 639276
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-10 11:36 UTC by Dion Moult
Modified: 2019-02-07 10:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.tar.gz,167.22 KB, application/gzip)
2019-01-11 11:49 UTC, Dion Moult
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dion Moult 2019-01-10 11:36:09 UTC
Upon attempting to emerge grass-7.4.1 I get:

```
[ ... snip ... ]
/usr/lib/portage/python3.6/ebuild-helpers/xattr/install -c  -m 644 INSTALL /var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/INSTALL
/usr/lib/portage/python3.6/ebuild-helpers/xattr/install -c  -m 644 REQUIREMENTS.html /var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/REQUIREMENTS.html
/usr/lib/portage/python3.6/ebuild-helpers/xattr/install -c  -m 644 contributors.csv /var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/contributors.csv
/usr/lib/portage/python3.6/ebuild-helpers/xattr/install -c  -m 644 contributors_extra.csv /var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/contributors_extra.csv
/usr/lib/portage/python3.6/ebuild-helpers/xattr/install -c  -m 644 translators.csv /var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/translators.csv
make[1]: Leaving directory '/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1'
make manifests
make[1]: Entering directory '/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1'
make[1]: Nothing to be done for 'manifests'.
make[1]: Leaving directory '/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1'
GRASS GIS 7.4.1 exported compilation log
--------------------------------------------------
Started compilation: Thu Jan 10 22:20:28 AEDT 2019
--
Errors in:
/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/scripts/d.rast.edit
--
In case of errors please change into the directory with error and run 'make'.
If you get multiple errors, you need to deal with them in the order they
appear in the error log. If you get an error building a library, you will
also get errors from anything which uses the library.
--
Finished compilation: Thu Jan 10 22:23:28 AEDT 2019
make: *** [Makefile:70: default] Error 1
 [31;01m*[0m ERROR: sci-geosciences/grass-7.4.1::gentoo failed (compile phase):
 [31;01m*[0m   emake failed
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the output of `emerge --info '=sci-geosciences/grass-7.4.1::gentoo'`,
 [31;01m*[0m the complete build log and the output of `emerge -pqv '=sci-geosciences/grass-7.4.1::gentoo'`.
 [31;01m*[0m The complete build log is located at '/var/tmp/portage/sci-geosciences/grass-7.4.1/temp/build.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/sci-geosciences/grass-7.4.1/temp/environment'.
 [31;01m*[0m Working directory: '/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1'
 [31;01m*[0m S: '/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1'
```

As per its recommendation I run `make` in that `d.rast.edit` dir and I get:

```
if [ "/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/scripts/d.rast.edit" != "" ] ; then GISRC=/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/demolocation/.grassrc74 GISBASE=/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu PATH="/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/bin:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/bin:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/scripts:$PATH" PYTHONPATH="/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/etc/python:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/gui/wxpython:$PYTHONPATH" LD_LIBRARY_PATH="/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/bin:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/bin:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/scripts:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/lib:/var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/lib:" LC_ALL=C LANG=C LANGUAGE=C /var/tmp/portage/sci-geosciences/grass-7.4.1/work/grass-7.4.1/dist.x86_64-pc-linux-gnu/scripts/d.rast.edit --html-description < /dev/null | grep -v '</body>\|</html>' > d.rast.edit.tmp.html ; fi
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).
make: *** [../../include/Make/Html.make:14: d.rast.edit.tmp.html] Error 1
rm d.rast.edit.tmp.html
```

This suggests it still requires :2.8 slot of wxGTK / wxPython or both. According to bug #562480 it has been lastrited.

Options?

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2019-01-10 18:57:09 UTC
Please attach the entire build log to this bug report.
Comment 2 Dion Moult 2019-01-11 11:49:09 UTC
Created attachment 560674 [details]
Build log

Build log compressed as it is 4MB.
Comment 3 Pacho Ramos gentoo-dev 2019-02-07 10:19:01 UTC

*** This bug has been marked as a duplicate of bug 639276 ***