Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 674468 - net-fs/samba-4.8.x fails to configure: ERROR: System library socket_wrapper of version 1.1.9 not found, and bundling disabled
Summary: net-fs/samba-4.8.x fails to configure: ERROR: System library socket_wrapper o...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
: 671888 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-03 23:34 UTC by Pacho Ramos
Modified: 2020-05-04 20:14 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (samba-4.8.8:20190103-233031.log.gz,14.54 KB, application/gzip)
2019-01-03 23:34 UTC, Pacho Ramos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2019-01-03 23:34:57 UTC
Created attachment 559754 [details]
build.log.gz

I get this with stable 4.8.6-r2 and 4.8.8:
Checking for third party Python module iso8601                                    : system 
Checking for longjmp                                                              : ok 
Checking for siglongjmp                                                           : ok 
Checking for system cmocka (>=1.1.1)                                              : yes 
Checking for system popt                                                          : yes 
Checking for header popt.h                                                        : yes 
Checking for library popt                                                         : yes 
Checking for poptGetContext                                                       : ok 
Checking for system z (>=1.2.3)                                                   : yes 
Checking for library z                                                            : yes 
Checking for zlibVersion                                                          : ok 
Checking for system z (>=1.2.3)                                                   : yes 
Checking for system socket_wrapper (>=1.1.9)                                      : not found 
ERROR: System library socket_wrapper of version 1.1.9 not found, and bundling disabled
 * ERROR: net-fs/samba-4.8.8::gentoo failed (configure phase):
 *   configure failed
 * 
 * Call stack:
 *     ebuild.sh, line  124:  Called src_configure
 *   environment, line 3474:  Called multilib-minimal_src_configure
 *   environment, line 2014:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2229:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1944:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1942:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  485:  Called multilib-minimal_abi_src_configure
 *   environment, line 2008:  Called multilib_src_configure
 *   environment, line 2451:  Called waf-utils_src_configure '--enable-fhs' '--sysconfdir=/etc' '--localstatedir=/var' '--with-modulesdir=/usr/lib64/samba' '--with-piddir=/run/samba' '--bundled-libraries=NONE' '--builtin-libraries=NONE' '--disable-rpath' '--disable-rpath-install' '--nopyc' '--nopyo' '--with-acl-support' '--without-ad-dc' '--without-dnsupdate' '--without-ads' '--disable-cephfs' '--without-cluster-support' '--enable-cups' '--without-dmapi' '--with-fam' '--without-gpgme' '--disable-iprint' '--with-pam' '--with-pammodulesdir=/lib64/security' '--without-quotas' '--without-syslog' '--with-systemd' '--without-winbind' '--enable-avahi' '--enable-selftest' '--with-system-mitkrb5' '--disable-gnutls' '--without-lttng' '--with-ldap' '--with-shared-modules='
 *   environment, line 4425:  Called die
 * The specific snippet of code:
 *       CCFLAGS="${CFLAGS}" LINKFLAGS="${CFLAGS} ${LDFLAGS}" "${WAF_BINARY}" "--prefix=${EPREFIX}/usr" "${libdir[@]}" "${@}" configure || die "configure failed"
 * 
 * If you need support, post the output of `emerge --info '=net-fs/samba-4.8.8::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-fs/samba-4.8.8::gentoo'`.
 * The complete build log is located at '/var/log/portage/build/net-fs/samba-4.8.8:20190103-233031.log.gz'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/net-fs/samba-4.8.8/temp/build.log.gz'.
 * The ebuild environment file is located at '/var/tmp/portage/net-fs/samba-4.8.8/temp/environment'.
 * Working directory: '/var/tmp/portage/net-fs/samba-4.8.8/work/samba-4.8.8-abi_x86_64.amd64'
 * S: '/var/tmp/portage/net-fs/samba-4.8.8/work/samba-4.8.8'

>>> Failed to emerge net-fs/samba-4.8.8, Log file:

Portage 2.3.53 (python 3.7.0-final-0, default/linux/amd64/17.0/desktop/gnome/systemd, gcc-7.3.0, glibc-2.27-r6, 4.14.73-gentoo x86_64)
=================================================================
System uname: Linux-4.14.73-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-gentoo-2.6
KiB Mem:    16132596 total,   7668668 free
KiB Swap:    5240828 total,   3150844 free
Timestamp of repository gentoo: Thu, 03 Jan 2019 11:30:01 +0000
Head commit of repository gentoo: e114185f9b8e1c8a577fa39d1c5106885632616a
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p5) 2.30.0
ccache version 3.3.4 [enabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.5.5-r1::gentoo, 3.6.6::gentoo, 3.7.0::gentoo
dev-util/ccache:          3.3.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.38.3-r1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r4::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: no

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ago
    location: /hdd/portage/local/layman/ago
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -fno-stack-protector"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native -fno-stack-protector"
DISTDIR="/hdd/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --autounmask-write --keep-going"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache cgroup compress-build-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="es_ES.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="es es_ES en en_US fr fr_FR"
MAKEOPTS="-j9"
PKGDIR="/hdd/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 applet avahi avx avx256 bash-completion berkdb bluetooth branding bzip2 cairo ccache cdda cddb cdr chm chromecast cli colord crypt cups cvs cxx dbus djvu dri dts dvd dvdr dvi ebook eds emboss enchant encode evo exif fam fat ffmpeg flac fortran fuse gdbm gif git glamor gnome gnome-keyring gnome-online-accounts google googledrive gphoto2 gpm gromacs gstreamer gtk gtk3 gtkstyle hfs http iconv infinality introspection ios irc jabber jpeg kpathsea latex lcms ldap libass libnotify libsecret libtirpc libvisual lyx mad microdns mms mmx mmxext mng mobi monolithic-build mp3 mp4 mpeg mtp multilib musicbrainz nautilus ncurses network-cron networkmanager nls nptl ntfs ntp numa nvidia offensive ogg opengl openmp optimized-qmake pam pango pch pdf pdfimport png policykit ppds pulseaudio qt5 readline reiserfs scanner sdl seccomp sendto smp sna snmp spell squashfs sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification svg systemd t1lib tcpd test theora threads tiff tracker truetype udev udisks unicode upnp upnp-av upower usb v4l vaapi vala vcd vdpau vlc vorbis wifi wxwidgets x264 x265 xattr xcb xfs xml xmpp xv xvid youtube zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="es es-ES en en-US fr fr-FR" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 python3_7" RUBY_TARGETS="ruby23 ruby24" USERLAND="GNU" VIDEO_CARDS="fbdev vesa intel i965 nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Pacho Ramos gentoo-dev 2019-01-03 23:36:11 UTC
I guess it needs a newer net-libs/socket_wrapper version?
Comment 2 Pacho Ramos gentoo-dev 2019-01-04 00:11:40 UTC
if you install it, it fails because it also needs a newer uid_wrapper:
Checking for system uid_wrapper (>=1.2.4)                                         : not found 
ERROR: System library uid_wrapper of version 1.2.4 not found, and bundling disabled
Comment 3 Pacho Ramos gentoo-dev 2019-01-04 00:15:14 UTC
and:
Checking for system pam_wrapper (>=1.0.4)                                         : not found 
ERROR: System library pam_wrapper of version 1.0.4 not found, and bundling disabled

But that I cannot fix it because it seems to not be packaged :/
Comment 4 Pacho Ramos gentoo-dev 2019-01-04 00:32:36 UTC
disabling USE test allows the build to succeed, maybe the USE should be masked (and tests restricted)
Comment 5 Larry the Git Cow gentoo-dev 2019-01-28 11:26:52 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4ec8f4c6bfa4ea6c0dbab74c05610658f7b15d7e

commit 4ec8f4c6bfa4ea6c0dbab74c05610658f7b15d7e
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2019-01-28 11:26:26 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2019-01-28 11:26:45 +0000

    net-fs/samba: Fixed dependency on net-libs/socket_wrapper
    
    Bug: https://bugs.gentoo.org/674468
    Package-Manager: Portage-2.3.58, Repoman-2.3.12
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 net-fs/samba/samba-4.10.0_rc1-r1.ebuild | 2 +-
 net-fs/samba/samba-4.8.6-r3.ebuild      | 2 +-
 net-fs/samba/samba-4.8.8-r1.ebuild      | 2 +-
 net-fs/samba/samba-4.9.4-r1.ebuild      | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)
Comment 6 Ben Kohler gentoo-dev 2020-01-07 22:35:14 UTC
Just need stabilization now
Comment 7 Ben Kohler gentoo-dev 2020-01-07 22:35:37 UTC
*** Bug 671888 has been marked as a duplicate of this bug. ***
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2020-04-29 10:40:41 UTC
(In reply to Pacho Ramos from comment #3)
> and:
> Checking for system pam_wrapper (>=1.0.4)                                   
> : not found 
> ERROR: System library pam_wrapper of version 1.0.4 not found, and bundling
> disabled
> 
> But that I cannot fix it because it seems to not be packaged :/

(In reply to Ben Kohler from comment #6)
> Just need stabilization now

What happened to fix the missing pam_wrapper?

Checking for system pam_wrapper (>=1.0.7)                                         : not found
ERROR: System library pam_wrapper of version 1.0.7 not found, and bundling disabled
 * ERROR: net-fs/samba-4.12.2::gentoo failed (configure phase):
Comment 9 Ben Kohler gentoo-dev 2020-04-29 12:10:36 UTC
I'm now able to trigger a check/error on pam_wrapper.  I also see some other dep problems, the following USE combo fails due to missing {nss,resolv,socket,uid}_wrapper:

[ebuild     U  ] net-fs/samba-4.12.2::gentoo [4.12.1::gentoo] USE="acl client pam python system-mitkrb5 systemd test* -addc -addns -ads -ceph -cluster -cups -debug (-dmapi) (-fam) -gpg -iprint -json -ldap -profiling-data -quota (-selinux) -syslog (-system-heimdal) -winbind -zeroconf" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_7 -python3_6 -python3_8" 0 KiB

Those 4 deps are behind +test & !system-mitkrb5 but they appear to still be required with +test & +system-mitkrb5.

I believe we need to package pam_wrapper and have all 5 deps enabled for USE=test, whether system-mitkrb5 is enabled or not.  At least with our ebuild's current logic.
Comment 10 Larry the Git Cow gentoo-dev 2020-04-29 12:39:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8866dc38ace4c36115fd0e49418bbc0ea4822e69

commit 8866dc38ace4c36115fd0e49418bbc0ea4822e69
Author:     Ben Kohler <bkohler@gentoo.org>
AuthorDate: 2020-04-29 12:36:53 +0000
Commit:     Ben Kohler <bkohler@gentoo.org>
CommitDate: 2020-04-29 12:38:59 +0000

    package.use.mask: mask test on samba
    
    We are missing deps for USE=test and tests are already RESTRICTed
    
    Closes: https://bugs.gentoo.org/674468
    
    Signed-off-by: Ben Kohler <bkohler@gentoo.org>

 profiles/base/package.use.mask | 4 ++++
 1 file changed, 4 insertions(+)
Comment 11 Sam James archtester gentoo-dev Security 2020-05-04 20:14:20 UTC
Is there a bug for getting the tests unrestricted (by packaging the necessary deps), by the way?