Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 674330 - app-eselect/eselect-postgresql-2.4 stabilization
Summary: app-eselect/eselect-postgresql-2.4 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PgSQL Bugs
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 662810
  Show dependency tree
 
Reported: 2019-01-02 13:07 UTC by Aaron W. Swenson
Modified: 2019-02-15 16:23 UTC (History)
1 user (show)

See Also:
Package list:
app-eselect/eselect-postgresql-2.4
Runtime testing required: No
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron W. Swenson gentoo-dev 2019-01-02 13:07:56 UTC
Please stabilize:
=app-eselect/eselect-postgresql-2.4 ~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86

Runtime testing is appreciated, but not required.

Things that should work:
* With no existing installation of dev-db/postgresql, upon installation of any slot of dev-db/postgresql the eselect module will automatically set that as the default slot. (emerge dev-db/postgresql:9.6)

* Emerging a higher or lower slot will not automatically cause a switch to that higher slot (emerge dev-db/postgresql:{9.5,10}). `postgresql-config show` will still display 9.6, and `man psql` will show the man page for psql in the 9.6 slot. `man psql10` will show the man page for psql in the 10 slot.

* Unmerging a previously set slot will automatically switch to the highest available (emerge -C dev-db/postgresql:9.6). postgresql-config will switch to 10.

At any point, `psql -V` should display the version of the currently selected slot.
Comment 1 Thomas Deutschmann gentoo-dev Security 2019-01-02 19:02:15 UTC
x86 stable
Comment 2 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-01-03 09:43:15 UTC
amd64 stable
Comment 3 Sergei Trofimovich gentoo-dev 2019-01-03 18:55:38 UTC
ppc64 stable
Comment 4 Sergei Trofimovich gentoo-dev 2019-01-03 18:56:18 UTC
ppc stable
Comment 5 Sergei Trofimovich gentoo-dev 2019-01-03 18:57:52 UTC
ia64 stable
Comment 6 Larry the Git Cow gentoo-dev 2019-01-31 08:49:06 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7db111f04a958d4ed1ce6e5c87b938917e3a002f

commit 7db111f04a958d4ed1ce6e5c87b938917e3a002f
Author:     Tobias Klausmann <klausman@gentoo.org>
AuthorDate: 2019-01-31 08:48:33 +0000
Commit:     Tobias Klausmann <klausman@gentoo.org>
CommitDate: 2019-01-31 08:48:33 +0000

    app-eselect/eselect-postgresql-2.4-r0: alpha stable
    
    Bug: http://bugs.gentoo.org/674330
    Signed-off-by: Tobias Klausmann <klausman@gentoo.org>

 app-eselect/eselect-postgresql/eselect-postgresql-2.4.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-02-10 17:54:10 UTC
arm stable
Comment 8 Markus Meier gentoo-dev 2019-02-12 06:05:33 UTC
arm stable, all arches done.
Comment 9 Aaron W. Swenson gentoo-dev 2019-02-13 22:56:42 UTC
Reopening for Sparc.
Comment 10 Rolf Eike Beer 2019-02-15 16:23:25 UTC
sparc done, bug done