Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 673400 - sys-apps/portage - '--va' is not a valid package atom.
Summary: sys-apps/portage - '--va' is not a valid package atom.
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 697734
  Show dependency tree
 
Reported: 2018-12-18 18:30 UTC by Hans Fernhout
Modified: 2020-01-19 04:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Fernhout 2018-12-18 18:30:15 UTC
Giving emerge wrong a action to process leads to a wrong error message.

Observed behavior:
# emerge --va gcc
!!! '--va' is not a valid package atom.
!!! Please check ebuild(5) for full details.

Expected behavior:
# emerge --va gcc
!!! '--va' is not a valid emerge action.
!!! Please check emerge(1) for full details.
Comment 2 Larry the Git Cow gentoo-dev 2019-10-27 19:33:51 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/portage.git/commit/?id=6d519a589a9656a511b369c223e27e2f8d8437de

commit 6d519a589a9656a511b369c223e27e2f8d8437de
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2019-10-27 18:58:37 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2019-10-27 19:11:40 +0000

    emerge: fix error message for unknown options (bug 673400)
    
    Do not use parse_known_args to parse positional arguments, since that
    causes unknown options to be handled like unknown positional arguments.
    
    Bug: https://bugs.gentoo.org/673400
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 lib/_emerge/main.py | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
Comment 3 Larry the Git Cow gentoo-dev 2019-11-09 05:22:45 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a95264dd3d846c10045644d5385d96826fbbae78

commit a95264dd3d846c10045644d5385d96826fbbae78
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2019-11-09 05:16:02 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2019-11-09 05:22:38 +0000

    sys-apps/portage: Bump to version 2.3.79
    
     #673400 emerge: fix error message for unknown options
     #699392 emirrordist: _recycle_copier_exit UnboundLocalError
     #699400 emirrordist: clean up FileCopier exception logging
     #699548 install.py: ignore -Z / --context
    
    Bug: https://bugs.gentoo.org/697734
    Bug: https://bugs.gentoo.org/673400
    Bug: https://bugs.gentoo.org/699392
    Bug: https://bugs.gentoo.org/699400
    Bug: https://bugs.gentoo.org/699548
    Package-Manager: Portage-2.3.78, Repoman-2.3.17
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 sys-apps/portage/Manifest              |   1 +
 sys-apps/portage/portage-2.3.79.ebuild | 261 +++++++++++++++++++++++++++++++++
 2 files changed, 262 insertions(+)
Comment 4 Zac Medico gentoo-dev 2019-11-30 18:35:58 UTC
(In reply to Larry the Git Cow from comment #2)
> The bug has been referenced in the following commit(s):
> 
> https://gitweb.gentoo.org/proj/portage.git/commit/
> ?id=6d519a589a9656a511b369c223e27e2f8d8437de
> 
> commit 6d519a589a9656a511b369c223e27e2f8d8437de
> Author:     Zac Medico <zmedico@gentoo.org>
> AuthorDate: 2019-10-27 18:58:37 +0000
> Commit:     Zac Medico <zmedico@gentoo.org>
> CommitDate: 2019-10-27 19:11:40 +0000
> 
>     emerge: fix error message for unknown options (bug 673400)
>     
>     Do not use parse_known_args to parse positional arguments, since that
>     causes unknown options to be handled like unknown positional arguments.
>     
>     Bug: https://bugs.gentoo.org/673400
>     Signed-off-by: Zac Medico <zmedico@gentoo.org>
> 
>  lib/_emerge/main.py | 9 ++++-----
>  1 file changed, 4 insertions(+), 5 deletions(-)

A side-effect of this change is that positional arguments are now required to come after all optional arguments.
Comment 5 Larry the Git Cow gentoo-dev 2020-01-19 04:39:00 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6cfec967ac5ad3894f6ce0e6c7289406bd10d480

commit 6cfec967ac5ad3894f6ce0e6c7289406bd10d480
Author:     Zac Medico <zmedico@gentoo.org>
AuthorDate: 2020-01-19 04:26:54 +0000
Commit:     Zac Medico <zmedico@gentoo.org>
CommitDate: 2020-01-19 04:38:13 +0000

    scripts/bootstrap.sh: fix emerge --resume args
    
    Since the emerge argument parser change from bug 673400, positional
    arguments must come after all optional arguments.
    
    Reviewed-by: Michael Everitt <m.j.everitt@iee.org>
    Bug: https://bugs.gentoo.org/673400
    Signed-off-by: Zac Medico <zmedico@gentoo.org>

 scripts/bootstrap.sh | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)