Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 672910 (CVE-2018-19931, CVE-2018-19932) - <sys-devel/binutils-2.31.1-r5: multiple vulnerabilities
Summary: <sys-devel/binutils-2.31.1-r5: multiple vulnerabilities
Status: RESOLVED FIXED
Alias: CVE-2018-19931, CVE-2018-19932
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://sourceware.org/bugzilla/show_...
Whiteboard: A3 [glsa+ cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-11 00:14 UTC by D'juan McDonald (domhnall)
Modified: 2019-08-03 11:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D'juan McDonald (domhnall) 2018-12-11 00:14:40 UTC
GNU Binutils is prone to following security vulnerabilities:

1. A heap-based overflow vulnerability (CVE-2018-19931)
patch: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=5f60af5d24d181371d67534fa273dd221df20c07


2. An integer-overflow vulnerability (CVE-2018-19932)
patch: https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=beab453223769279cc1cef68a1622ab8978641f7

An attacker can exploit this issue to cause a denial-of-service condition. Due to the nature of this issue, code execution may be possible but this has not been confirmed.


@maintainer(s): patches available. 


Gentoo Security Padawan
(domhnall)
Comment 1 Andreas K. Hüttel gentoo-dev 2019-03-24 21:22:03 UTC
will be in 2.31.1 patchlevel 6
Comment 2 Andreas K. Hüttel gentoo-dev 2019-06-06 14:30:17 UTC
All affected versions are gone or masked. @security please proceed.
Comment 3 GLSAMaker/CVETool Bot gentoo-dev 2019-08-03 11:23:44 UTC
This issue was resolved and addressed in
 GLSA 201908-01 at https://security.gentoo.org/glsa/201908-01
by GLSA coordinator Aaron Bauman (b-man).