Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 672840 - media-libs/opencv-2.4.13-r3 USE=ffmpeg - .../work/opencv-2.4.13/modules/highgui/src/cap_ffmpeg_impl.hpp:1482:21: error: ‘CODEC_FLAG_GLOBAL_HEADER’ was not declared in this scope
Summary: media-libs/opencv-2.4.13-r3 USE=ffmpeg - .../work/opencv-2.4.13/modules/highg...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Amy Liffey
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-09 20:02 UTC by PusRob
Modified: 2019-11-28 13:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,258.75 KB, text/plain)
2018-12-09 20:02 UTC, PusRob
Details
emerge --info output (eminfo,6.78 KB, text/plain)
2018-12-09 20:03 UTC, PusRob
Details
emerge -pqv output (empqv,257 bytes, text/plain)
2018-12-09 20:04 UTC, PusRob
Details
environment (environment,223.32 KB, text/plain)
2018-12-09 20:07 UTC, PusRob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PusRob 2018-12-09 20:02:36 UTC
Created attachment 557470 [details]
build.log

I tried to build opencv-2.4.13-r3 with the ffmpeg USE flag turned on, and got a compile error. The cause seems to be the usage of outdated names in the source, which means it would be high time for a version bump, especially considering that  OpenCV-2.x can now be regarded as ancient due to 4.0 being released recently. Please upgrade the version in the stable branch to make it usable again. Thanks.
Comment 1 PusRob 2018-12-09 20:03:33 UTC
Created attachment 557472 [details]
emerge --info output
Comment 2 PusRob 2018-12-09 20:04:42 UTC
Created attachment 557474 [details]
emerge -pqv output
Comment 3 PusRob 2018-12-09 20:07:30 UTC
Created attachment 557476 [details]
environment
Comment 4 Jérôme Borme 2019-02-24 18:22:43 UTC
See bug #654172, similar issue with gegl due to the use of old macro CODEC_FLAG_GLOBAL_HEADER not present in recent versions of ffmpeg. You could try to emerge more recent version of opencv.