Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 672710 - =app-backup/duplicity-0.7.19 version bump
Summary: =app-backup/duplicity-0.7.19 version bump
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tim Harder
Depends on:
Reported: 2018-12-07 18:00 UTC by Horst Prote
Modified: 2019-09-30 17:21 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Horst Prote 2018-12-07 18:00:13 UTC
Please bump duplicity to version 0.7.18:

Plain renaming of 0.7.17 ebuild worked for me.
Comment 1 Horst Prote 2018-12-10 20:01:54 UTC
(In reply to Horst Prote from comment #0)
> Plain renaming of 0.7.17 ebuild worked for me.
No, it only builds without error but does not work:
duplicity full --encrypt-key <key-id> --sign-key <key-id> /tmp/backupTest sftp://<user>@<host>/<somedir>/
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: none
GnuPG passphrase for signing key: *********
Traceback (innermost last):
  File "/usr/bin/duplicity", line 1567, in <module>
  File "/usr/bin/duplicity", line 1553, in with_tempdir
  File "/usr/bin/duplicity", line 1405, in main
  File "/usr/bin/duplicity", line 1523, in do_backup
  File "/usr/bin/duplicity", line 584, in full_backup
  File "/usr/bin/duplicity", line 466, in write_multivol
    (tdp, dest_filename, vol_num)))
  File "/usr/lib64/python2.7/site-packages/duplicity/", line 146, in schedule_task
    return self.__run_synchronously(fn, params)
  File "/usr/lib64/python2.7/site-packages/duplicity/", line 172, in __run_synchronously
    ret = fn(*params)
  File "/usr/bin/duplicity", line 465, in <lambda>
    vol_num: put(tdp, dest_filename, vol_num),
  File "/usr/bin/duplicity", line 355, in put
    validate_block(putsize, dest_filename)
  File "/usr/bin/duplicity", line 337, in validate_block
    util.escape(dest_filename), orig_size))
 TypeError: %d format: a number is required, not NoneType

On the target in <somedir> only one file
was created.
The same command with version 0.7.17 works.
Comment 2 Horst Prote 2019-09-30 16:20:16 UTC
In the meantime version 0.7.19 is out and this version works (plain renaming of 0.7.17 ebuild).
Comment 3 Larry the Git Cow gentoo-dev 2019-09-30 17:21:38 UTC
The bug has been closed via the following commit(s):

commit b5f7a2545ddee66cac3394e7b4bc1e3ae3f3aa55
Author:     Richard Freeman <>
AuthorDate: 2019-09-30 17:21:13 +0000
Commit:     Richard Freeman <>
CommitDate: 2019-09-30 17:21:13 +0000

    app-backup/duplicity: bump, EAPI 7 port
    Package-Manager: Portage-2.3.76, Repoman-2.3.16
    Signed-off-by: Richard Freeman <>

 app-backup/duplicity/Manifest                |  1 +
 app-backup/duplicity/duplicity-0.7.19.ebuild | 52 ++++++++++++++++++++++++++++
 2 files changed, 53 insertions(+)