Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 671796 - dev-python/matplotlib-3.0.2 version bump
Summary: dev-python/matplotlib-3.0.2 version bump
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-24 06:33 UTC by lumbrius
Modified: 2019-07-26 09:39 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild (matplotlib-3.0.2.ebuild,5.72 KB, text/plain)
2018-11-26 09:09 UTC, lumbrius
Details
Using a fake USE python2 with a fakeVoid dependency (matplotlib-3.0.3.ebuild,5.81 KB, text/plain)
2019-05-03 12:40 UTC, Ulenrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lumbrius 2018-11-24 06:33:51 UTC
3.0.2 stable https://matplotlib.org/
Comment 1 lumbrius 2018-11-26 09:09:42 UTC
Created attachment 556278 [details]
ebuild

this ebuild works for my local overlay
Comment 2 lumbrius 2018-12-10 12:55:09 UTC
Any news on update?
Comment 3 lumbrius 2018-12-26 11:34:23 UTC
...
Comment 4 Attila Tóth 2019-01-10 06:42:17 UTC
(In reply to lumbrius from comment #1)
> Created attachment 556278 [details]
> ebuild
> 
> this ebuild works for my local overlay

Works for me, thanks!
Comment 5 lumbrius 2019-03-13 03:35:13 UTC
I DONT UNDERSTAND WHY IT TAKES MORE THAN HALF A YEAR TO PUSH WORKING EBUILD INTO TREE IS GENTOO DEAD?????
Comment 6 François Bissey 2019-03-13 04:38:45 UTC
To be honest in that particular case there may be another hold up. If I am not mistaken matplotlib-3+ is python3 only and we don't have stuff to have different versions of a python package depending on the version of python used.
Could be added package masked though, it is done for other packages.
Comment 7 edes 2019-04-30 14:27:42 UTC
by now, 3.0.3 is stable... https://matplotlib.org/

--
Comment 8 Ulenrich 2019-05-03 11:23:26 UTC
(In reply to François Bissey from comment #6)
> To be honest in that particular case there may be another hold up. If I am
> not mistaken matplotlib-3+ is python3 only and we don't have stuff to have
> different versions of a python package depending on the version of python
> used.
> Could be added package masked though, it is done for other packages.

Why doesn't it work using -python_targets_python2_7 like in ipython-7.5.0 ?
---
# grep matplot ipython-7.5.0.ebuild 
IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
	matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP},-python_targets_python2_7] )
Comment 9 Virgil Dupras gentoo-dev 2019-05-03 11:36:07 UTC
Because apparently, this approach is problematic :) See bug 684962.

I'm still working out the kinks, but if ipython 7.5 goes through unscathed, we can apply the same recipe for matplotlib.

But circular dependencies and dropping py2 doesn't mix happily. It's ugly.
Comment 10 Ulenrich 2019-05-03 12:40:49 UTC
Created attachment 575002 [details]
Using a fake USE python2 with a fakeVoid dependency

This my ebuild uses
---
# emerge -1 =dev-python/matplotlib-3.0.3::pmaci; emerge  =dev-python/ipython-7.5.0::gentoo

These are the packages that would be merged, in order:

Calculating dependencies  . ...... done!

emerge: there are no ebuilds to satisfy "dev-python/pythonThreeOnly-fakeVoid".
(dependency required by "dev-python/matplotlib-3.0.3::pmaci[python_targets_python2_7]" [ebuild])
(dependency required by "=dev-python/matplotlib-3.0.3::pmaci" [argument])

These are the packages that would be merged, in order:

Calculating dependencies  ... done!

emerge: there are no ebuilds built with USE flags to satisfy "dev-python/matplotlib[python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_targets_python2_7]".
!!! One of the following packages is required to complete your request:
- dev-python/matplotlib-3.0.3::pmaci (Change USE: -python_targets_python2_7)
(dependency required by "dev-python/ipython-7.5.0::gentoo" [ebuild])
(dependency required by "=dev-python/ipython-7.5.0::gentoo" [argument])
 maci /common/pmaci/dev-python/matplotlib #
---

but when correctly written in /etc/portage/package.use:
dev-python/matplotlib -python_targets_python2_7

then this output:
---
# emerge  =dev-python/ipython-7.5.0::gentoo

These are the packages that would be merged, in order:

Calculating dependencies  ........ done!
[ebuild  N     ] dev-python/matplotlib-3.0.3::pmaci  USE="cairo -doc -examples -excel -gtk2 gtk3 -latex qt5 -test -tk -wxwidgets" PYTHON_TARGETS="-pypy3 -python2_7 -python3_5 python3_6 -python3_7" 0 KiB
[ebuild   R   #] dev-python/ipython-7.5.0::gentoo  USE="-doc examples matplotlib* -nbconvert -notebook qt5 smp -test" PYTHON_TARGETS="-python3_5 python3_6 -python3_7" 0 KiB

Total: 2 packages (1 new, 1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] 
---
Comment 11 Ulenrich 2019-05-03 13:06:03 UTC
I have just tested and successfully merged my ebuild.
If using it, there must be inserted a new profile package.use.mask
=dev-python/matplotlib-3.0.3 -python_targets_python2_7
with a warning in the comment that there may never be introduce an ebuild
dev-python/pythonThreeOnly-fakeVoid

This way per package.use.mask is lesser intrusive than a package.mask

The output of my merge:
---
 maci /common/pmaci/dev-python/matplotlib # emerge  =dev-python/ipython-7.5.0

These are the packages that would be merged, in order:

Calculating dependencies  . . ....... done!
[ebuild  N     ] dev-python/matplotlib-3.0.3::pmaci  USE="cairo -doc -examples -excel -gtk2 gtk3 -latex qt5 -test -tk -wxwidgets" PYTHON_TARGETS="-pypy3 -python2_7 -python3_5 python3_6 -python3_7" 0 KiB
[ebuild   R   #] dev-python/ipython-7.5.0::gentoo  USE="-doc examples matplotlib* -nbconvert -notebook qt5 smp -test" PYTHON_TARGETS="-python3_5 python3_6 -python3_7" 0 KiB

Total: 2 packages (1 new, 1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild manifests
>>> Emerging (1 of 2) dev-python/matplotlib-3.0.3::pmaci
>>> Installing (1 of 2) dev-python/matplotlib-3.0.3::pmaci
>>> Emerging (2 of 2) dev-python/ipython-7.5.0::gentoo
>>> Installing (2 of 2) dev-python/ipython-7.5.0::gentoo
>>> Recording dev-python/ipython in "world" favorites file...
>>> Jobs: 2 of 2 complete                           Load avg: 2.17, 2.02, 2.16

 * Messages for package dev-python/ipython-7.5.0:
 * Log file: /var/log/portage/build/dev-python/ipython-7.5.0:20190503-125722.log

 *   dev-python/sympy for sympyprinting
 *   dev-python/line_profiler for %lprun magic command
 *   dev-python/memory_profiler for %mprun magic command
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
Comment 12 Ulenrich 2019-05-04 19:25:28 UTC
(In reply to Virgil Dupras from comment https://bugs.gentoo.org/684962#7)
> I will solve this by dropping py2 on the whole jupyter stack. See bug 685040
Yeah,
though I felt happy to find this "special" portage circumventing of above,
I later thought of the many portage healthiness tools, these might not feel happy.
Comment 13 lumbrius 2019-07-26 09:39:12 UTC
After using USE=eselect-ldso as described in https://wiki.gentoo.org/wiki/Blas-lapack-switch arpack compiles, so I'd like to close this as invalid.
Thanks all for help!
Comment 14 lumbrius 2019-07-26 09:39:55 UTC
Terribly sorry I just posted in wrong window =/