Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 670170 - dev-qt/qtnetork compatibility with LibreSSL 2.8.X patch
Summary: dev-qt/qtnetork compatibility with LibreSSL 2.8.X patch
Status: RESOLVED DUPLICATE of bug 668218
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: libressl-support
  Show dependency tree
 
Reported: 2018-11-02 18:49 UTC by pagorman
Modified: 2018-11-08 00:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
realigned "const" descriptors for the BIO_METHOD function calls as necessary. (qtnetwork-libre28x-compat.patch,1.61 KB, patch)
2018-11-02 18:49 UTC, pagorman
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description pagorman 2018-11-02 18:49:49 UTC
Created attachment 553898 [details, diff]
realigned "const" descriptors for the BIO_METHOD function calls as necessary.

compiled with gcc-8.2.0 on the amd64 hardened profile, dev-libs/libressl-2.8.2

package would not compile. This patch, in addition to the normal qtnetwork-5.11.1-libressl.patch included in portage allows the package to compile.

Requires testing.
Comment 1 Stefan Strogin gentoo-dev 2018-11-02 21:36:26 UTC
Seems like duplicate of https://bugs.gentoo.org/562050
Comment 2 pagorman 2018-11-03 13:54:13 UTC

*** This bug has been marked as a duplicate of bug 668218 ***
Comment 3 Quentin R. 2018-11-03 15:03:35 UTC
Are you ok I submit a pull request on libressl overlay with your patch?
Comment 4 pagorman 2018-11-03 15:05:44 UTC
(In reply to Quentin R. from comment #3)
> Are you ok I submit a pull request on libressl overlay with your patch?

Go for it! I'm just learning how to play nice and cooperate. If you've got the way to get it done, go for it!
Comment 5 Quentin R. 2018-11-07 18:44:31 UTC
I finally sent that pull request
https://github.com/gentoo/libressl/pull/254
Comment 6 Quentin R. 2018-11-08 00:46:55 UTC
Good news, pull request has been merged and the patch is now in the official libressl overlay.