Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 670084 - gnome-extra/cinnamon-control-center-3.8.0 - cc-datetime-panel.c:28:10: fatal error: cc-csddtm-proxy.h: No such file or directory
Summary: gnome-extra/cinnamon-control-center-3.8.0 - cc-datetime-panel.c:28:10: fatal ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthew Turnbull
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-01 13:42 UTC by Samuel Bernardo
Modified: 2020-09-19 00:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,164.79 KB, text/plain)
2018-11-01 13:42 UTC, Samuel Bernardo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Bernardo 2018-11-01 13:42:20 UTC
Created attachment 553812 [details]
build.log

Missing header file causes compile error:

cc-datetime-panel.c:28:10: fatal error: cc-csddtm-proxy.h: No such file or directory
 #include "cc-csddtm-proxy.h"
          ^~~~~~~~~~~~~~~~~~~
compilation terminated.
make[4]: *** [Makefile:789: cc-datetime-panel.lo] Error 1

I searched for it but I could find what package is responsible to install it.
Comment 1 Samuel Bernardo 2018-11-01 13:43:25 UTC
(In reply to Samuel Bernardo from comment #0)
> Created attachment 553812 [details]
> build log
> 
> Missing header file causes compile error:
> 
> cc-datetime-panel.c:28:10: fatal error: cc-csddtm-proxy.h: No such file or
> directory
>  #include "cc-csddtm-proxy.h"
>           ^~~~~~~~~~~~~~~~~~~
> compilation terminated.
> make[4]: *** [Makefile:789: cc-datetime-panel.lo] Error 1
> 
> I searched for it but I could find what package is responsible to install it.

I searched for it but I couldn't find what package is responsible to install cc-csddtm-proxy.h.
Comment 2 Samuel Bernardo 2018-11-01 15:15:35 UTC
I just found that missing header file should be generated by the Makefile:
https://github.com/linuxmint/cinnamon-control-center/blob/429b9025ac0be8efcc36276666fcc0f17419ef17/panels/datetime/Makefile.am

Since I'm running make with multiple jobs, maybe I'm catching a dependency problem in the Makefile?

I'll try to build it with -j1.
Comment 3 Samuel Bernardo 2018-11-01 15:22:52 UTC
Ok, it compilled and installed correctly with -j1. So it's a makefile depedency problem.
Comment 4 Matthew Turnbull 2020-09-16 21:29:43 UTC
Is this still reproducible with 4.4 or 4.6?
Comment 5 Samuel Bernardo 2020-09-19 00:00:48 UTC
(In reply to Matthew Turnbull from comment #4)
> Is this still reproducible with 4.4 or 4.6?

Seems to be solved in version 4.6 (just compiled and installed it with my profile configurations).
Thanks