Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 670024 - Gnome maintained packages stabilization for October 2018
Summary: Gnome maintained packages stabilization for October 2018
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 670002 (view as bug list)
Depends on: 658646 670090 670184 674228
Blocks: 670000 672696
  Show dependency tree
 
Reported: 2018-10-31 12:39 UTC by Mart Raudsepp
Modified: 2019-01-21 20:25 UTC (History)
2 users (show)

See Also:
Package list:
dev-libs/appstream-glib-0.7.9 arm64 s390 media-fonts/cantarell-0.101 arm64 s390
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mart Raudsepp gentoo-dev 2018-10-31 12:39:38 UTC
Another round of assorted stabilizations, including glib-2.56, gtk+-3.24, networkmanager-1.14.x and co, and some newer GNOME bits that are standalone enough and have just bug fixes/translation updates mostly (though most is extra packages).
Comment 1 Mart Raudsepp gentoo-dev 2018-10-31 12:44:56 UTC
Adding mate-themes that doesn't block the newer gtk+ in the list for upgrade/downgrade cycles or blockers.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-10-31 12:47:27 UTC
*** Bug 670002 has been marked as a duplicate of this bug. ***
Comment 3 Mart Raudsepp gentoo-dev 2018-11-01 09:22:05 UTC
Adding paprefs that works with gsettings pulseaudio module, instead of gconf PA module that is removed in the to-be-stabled PA 12.
Comment 4 Mart Raudsepp gentoo-dev 2018-11-01 09:24:31 UTC
arches, please do.
s390: I included you in CC as you have a few of these packages stable at older version, but my scripts don't consider it as an always exp arch (guess I should add you to my arch list), so the package list doesn't include s390 - feel free to sort out what you need here.
Comment 5 Stabilization helper bot gentoo-dev 2018-11-01 10:38:08 UTC
An automated check of this bug failed - repoman reported dependency errors (239 lines truncated): 

> dependency.bad media-fonts/cantarell/cantarell-0.101.ebuild: DEPEND: ia64(default/linux/ia64/17.0) ['dev-libs/appstream-glib']
> dependency.bad media-fonts/cantarell/cantarell-0.101.ebuild: DEPEND: ia64(default/linux/ia64/17.0/desktop) ['dev-libs/appstream-glib']
> dependency.bad media-fonts/cantarell/cantarell-0.101.ebuild: DEPEND: ia64(default/linux/ia64/17.0/desktop/gnome) ['dev-libs/appstream-glib']
> dependency.bad net-misc/modemmanager/modemmanager-1.8.2.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/libmbim-1.16.0', '>=net-libs/libqmi-1.20.0:=']
> dependency.bad net-misc/modemmanager/modemmanager-1.8.2.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/libmbim-1.16.0', '>=net-libs/libqmi-1.20.0:=']
> dependency.bad net-misc/modemmanager/modemmanager-1.8.2.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=net-libs/libmbim-1.16.0', '>=net-libs/libqmi-1.20.0:=']
> dependency.bad net-misc/networkmanager/networkmanager-1.14.4.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['net-wireless/iwd']
> dependency.bad net-misc/networkmanager/networkmanager-1.14.4.ebuild: RDEPEND: amd64(default/linux/amd64/17.0/desktop) ['net-wireless/iwd']
> dependency.bad net-misc/networkmanager/networkmanager-1.14.4.ebuild: RDEPEND: amd64(default/linux/amd64/17.0/desktop/gnome) ['net-wireless/iwd']
Comment 6 Stabilization helper bot gentoo-dev 2018-11-01 14:51:55 UTC
An automated check of this bug failed - repoman reported dependency errors (239 lines truncated): 

> dependency.bad media-fonts/cantarell/cantarell-0.101.ebuild: DEPEND: ia64(default/linux/ia64/17.0) ['dev-libs/appstream-glib']
> dependency.bad media-fonts/cantarell/cantarell-0.101.ebuild: DEPEND: ia64(default/linux/ia64/17.0/desktop) ['dev-libs/appstream-glib']
> dependency.bad media-fonts/cantarell/cantarell-0.101.ebuild: DEPEND: ia64(default/linux/ia64/17.0/desktop/gnome) ['dev-libs/appstream-glib']
> dependency.bad net-misc/modemmanager/modemmanager-1.8.2.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/libmbim-1.16.0', '>=net-libs/libqmi-1.20.0:=']
> dependency.bad net-misc/modemmanager/modemmanager-1.8.2.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['>=net-libs/libmbim-1.16.0', '>=net-libs/libqmi-1.20.0:=']
> dependency.bad net-misc/modemmanager/modemmanager-1.8.2.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['>=net-libs/libmbim-1.16.0', '>=net-libs/libqmi-1.20.0:=']
> dependency.bad net-misc/networkmanager/networkmanager-1.14.4.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['net-wireless/iwd']
> dependency.bad net-misc/networkmanager/networkmanager-1.14.4.ebuild: RDEPEND: amd64(default/linux/amd64/17.0/desktop) ['net-wireless/iwd']
> dependency.bad net-misc/networkmanager/networkmanager-1.14.4.ebuild: RDEPEND: amd64(default/linux/amd64/17.0/desktop/gnome) ['net-wireless/iwd']
Comment 7 Stabilization helper bot gentoo-dev 2018-11-01 15:38:08 UTC
An automated check of this bug failed - repoman reported dependency errors (9 lines truncated): 

> dependency.bad dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild: DEPEND: ia64(default/linux/ia64/17.0) ['app-arch/gcab', 'dev-libs/snowball-stemmer']
> dependency.bad dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild: RDEPEND: ia64(default/linux/ia64/17.0) ['app-arch/gcab', 'dev-libs/snowball-stemmer']
> dependency.bad dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild: DEPEND: ia64(default/linux/ia64/17.0/desktop) ['app-arch/gcab', 'dev-libs/snowball-stemmer']
Comment 8 Mart Raudsepp gentoo-dev 2018-11-01 17:01:26 UTC
ia64: adding gcab and snowball-stemmer as appstream-glib deps. snowball-stemmer you could skip, if you package.use.stable.mask USE=stemmer on appstream-glib.
Comment 9 Mart Raudsepp gentoo-dev 2018-11-02 13:27:51 UTC
Upgrading system-config-printer stable candidate to new revision with fixed deps
Comment 10 Stabilization helper bot gentoo-dev 2018-11-02 14:37:51 UTC
An automated check of this bug failed - repoman reported dependency errors (15 lines truncated): 

> dependency.bad app-admin/system-config-printer/system-config-printer-1.5.11-r1.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['net-print/cups-pk-helper']
> dependency.bad app-admin/system-config-printer/system-config-printer-1.5.11-r1.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/17.0/desktop) ['net-print/cups-pk-helper']
> dependency.bad app-admin/system-config-printer/system-config-printer-1.5.11-r1.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/17.0/desktop/gnome) ['net-print/cups-pk-helper']
Comment 11 Mart Raudsepp gentoo-dev 2018-11-29 20:19:42 UTC
Updating list for selective stuff done by sparc
Comment 12 Sergei Trofimovich gentoo-dev 2018-12-01 21:03:42 UTC
ia64 stable
Comment 13 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-12-02 10:14:04 UTC
amd64 stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-12-02 14:30:06 UTC
x86 stable
Comment 15 Mart Raudsepp gentoo-dev 2018-12-02 17:35:17 UTC
Updating list to what's left to do.

Re-adding ia64, because due to a mistake of mine, there were two appstream-glib lines as reaction to stable-bot checks, which lead to ia64 being asked to stabilize older appstream-glib to satisfy the checks. Please stabilize the newer one too, which was asked from other arches on this bug.
Comment 16 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-12-04 16:28:33 UTC
arm stable
Comment 17 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-12-05 07:09:03 UTC
ppc64 stable
Comment 18 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-12-05 07:35:04 UTC
ppc stable
Comment 19 Mart Raudsepp gentoo-dev 2018-12-05 15:35:11 UTC
Everything but cantarell stable on arm64. Cantarell is delayed on a appstream-glib -> gtk+:3 dep stabling rabbit hole.
Updating list to remove what's done for ppc/ppc64/arm64.
Comment 20 Rolf Eike Beer 2018-12-07 21:31:47 UTC
sparc stable
Comment 21 Sergei Trofimovich gentoo-dev 2018-12-08 10:03:43 UTC
ia64 stable
Comment 22 Mart Raudsepp gentoo-dev 2018-12-19 22:14:09 UTC
Updating list for going straight for glib and co security bump
Comment 23 Matt Turner gentoo-dev 2018-12-28 03:47:06 UTC
alpha stable
Comment 24 Mart Raudsepp gentoo-dev 2018-12-28 07:49:54 UTC
Updatind list with what's left (hello hppa..); removed libwnck for hppa, as they haven't had that slot in stable and was a script error to be included (it considered the old SLOT being stable)
Comment 25 Rolf Eike Beer 2019-01-08 18:49:41 UTC
hppa stable
Comment 26 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-01-18 07:59:18 UTC
s390 stable
Comment 27 Mart Raudsepp gentoo-dev 2019-01-21 20:25:05 UTC
arm64 stable, closing