Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 669712 - media-radio/cqrlog fails with mysql-connector-c
Summary: media-radio/cqrlog fails with mysql-connector-c
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Richard Freeman
URL: https://www.cqrlog.com/node/2142
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-26 21:58 UTC by Richard Freeman
Modified: 2018-10-28 13:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cqrlog-2.3.0-adjust-libmysql-limitation.patch (cqrlog-2.3.0-adjust-libmysql-limitation.patch,564 bytes, patch)
2018-10-27 13:54 UTC, Thomas Deutschmann
Details | Diff
cqrlog-2.3.0-adjust-libmysql-limitation.patch (cqrlog-2.3.0-adjust-libmysql-limitation.patch,5.11 KB, patch)
2018-10-27 15:24 UTC, Thomas Deutschmann
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Freeman gentoo-dev 2018-10-26 21:58:11 UTC
See previous report at:
https://www.cqrlog.com/node/2142

Failure does not occur with current dev-db/mysql[client-libs].
Comment 1 Richard Freeman gentoo-dev 2018-10-27 11:49:23 UTC
Archive snapshot of upstream report:

Since the last upgrade on my Gentoo system I can't use cqrlog anymore. I get the following output at the command line:

Cqrlog Ver:2.3.0 (001) Date:2018-06-17
**** DEBUG LEVEL 1 ****

SSL libraries:
/usr/lib64/libssl.so.1.0.0
/usr/lib64/libcrypto.so.1.0.0
Loading libmysqlclient: /usr/lib64/libmysqlclient.so
**************************
MySQL version: 6.1
**************************
**********************************
MySQL version assigned: 6.1
**********************************
Loaded 121329 LoTW users
Loaded 117362 eQSL users
Loaded 39622 SCP calls
*
User home directory: /home/tom/
Program home directory: /home/tom/.config/cqrlog/
Data directory: /home/tom/.config/cqrlog/database/
Memebers directory: /home/tom/.config/cqrlog/members/
ZIP code directory: /usr/share/cqrlog/zipcodes/
Binary dir: /usr/bin/
Share dir: /usr/share/cqrlog/
TConnection to MySQL: 6.1
*
56 us states loaded
/usr/sbin/mysqld --defaults-file=/home/tom/.config/cqrlog/database/mysql.cnf --datadir=/home/tom/.config/cqrlog/database/ --socket=/home/tom/.config/cqrlog/database/sock --port=64000
Trying to connect to database
2018-10-03 19:24:32 139832652863296 [Note] /usr/sbin/mysqld (mysqld 10.2.17-MariaDB) starting as process 1891 ...
TMySQL57Connection can not work with the installed MySQL client version: Expected (5.7), got (6.1.11).

I had it working during the last month with mariadb-10.1.31-r1, but this version was now removed and it is also not possible to use the "client-libs" useflag anymore. The problem seems to be related to the way how Lazarus/FPC checks for the mysqlconnector version (here: mysql-connector-c-6.1.11, which is the latest version available).
Any idea how to fix this?
Comment 2 Thomas Deutschmann gentoo-dev Security 2018-10-27 13:54:00 UTC
Created attachment 553350 [details, diff]
cqrlog-2.3.0-adjust-libmysql-limitation.patch

Please try the following patch.

Idea is to remove that silly limitation because I don't expect that cqrlog is using any special libmysql feature. So in theory, even 5.1 class will work with latest MySQL 8 server.

The patch tries to force 5.7 class (this is the latest available component) for any unknown version.

Maybe this isn't enough and we have to set "SkipLibraryVersionCheck=true". But please try this patch first.
Comment 3 Thomas Deutschmann gentoo-dev Security 2018-10-27 15:24:46 UTC
Created attachment 553362 [details, diff]
cqrlog-2.3.0-adjust-libmysql-limitation.patch

I updated patch to use SkipLibraryVersionCheck.
Comment 4 Larry the Git Cow gentoo-dev 2018-10-27 22:45:42 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=efbe52e8fcf98fc032df92e96e8f7d4c7c2f8a5e

commit efbe52e8fcf98fc032df92e96e8f7d4c7c2f8a5e
Author:     Richard Freeman <rich0@gentoo.org>
AuthorDate: 2018-10-27 22:44:56 +0000
Commit:     Richard Freeman <rich0@gentoo.org>
CommitDate: 2018-10-27 22:45:10 +0000

    media-radio/cqrlog: backport libmysqlclient version check fix
    
    Closes: https://bugs.gentoo.org/669712
    Signed-off-by: Richard Freeman <rich0@gentoo.org>
    Package-Manager: Portage-2.3.49, Repoman-2.3.11

 media-radio/cqrlog/cqrlog-2.3.0-r1.ebuild          |  41 +++++
 .../2.3.0-database-connection-refactoring.patch    | 197 +++++++++++++++++++++
 2 files changed, 238 insertions(+)
Comment 5 Thomas Kluge 2018-10-28 13:15:06 UTC
Many thanks for the fast fix!
I can confirm that the patch fixes the issue, cqrlog works now also with the actual stable mariadb-10.1.34... Nice job!