Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 669330 - dev-lang/icon-9.5.1-r1 : fpoll.c:67:9: error: FILE {aka struct _IO_FILE } has no member named _bufp
Summary: dev-lang/icon-9.5.1-r1 : fpoll.c:67:9: error: FILE {aka struct _IO_FILE } has...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Cheyenne Wills
URL:
Whiteboard:
Keywords: PullRequest
: 685060 (view as bug list)
Depends on:
Blocks: glibc-2.28
  Show dependency tree
 
Reported: 2018-10-22 17:41 UTC by Toralf Förster
Modified: 2019-05-07 03:25 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.22 KB, text/plain)
2018-10-22 17:41 UTC, Toralf Förster
Details
dev-lang:icon-9.5.1-r1:20181021-233920.log (dev-lang:icon-9.5.1-r1:20181021-233920.log,18.77 KB, text/plain)
2018-10-22 17:41 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,91.57 KB, text/plain)
2018-10-22 17:41 UTC, Toralf Förster
Details
environment (environment,87.85 KB, text/plain)
2018-10-22 17:41 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.58 KB, application/x-bzip)
2018-10-22 17:41 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,23.52 KB, application/x-bzip)
2018-10-22 17:41 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-10-22 17:41:11 UTC
x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -fno-strict-aliasing -fwrapv -fPIC -c fpoll.c
fpoll.c: In function ‘fpoll’:
fpoll.c:67:9: error: ‘FILE’ {aka ‘struct _IO_FILE’} has no member named ‘__bufp’
    if (f->__bufp < f->__get_limit)
         ^~
fpoll.c:67:21: error: ‘FILE’ {aka ‘struct _IO_FILE’} has no member named ‘__get_limit’

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-systemd_abi32+64_20181020-092847

  -------------------------------------------------------------------

  Please see the tracker bug for details.

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *



emerge -qpvO dev-lang/icon
[ebuild  N    ] dev-lang/icon-9.5.1-r1  USE="-X -iplsrc"
Comment 1 Toralf Förster gentoo-dev 2018-10-22 17:41:14 UTC
Created attachment 552278 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-10-22 17:41:17 UTC
Created attachment 552280 [details]
dev-lang:icon-9.5.1-r1:20181021-233920.log
Comment 3 Toralf Förster gentoo-dev 2018-10-22 17:41:20 UTC
Created attachment 552282 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-10-22 17:41:23 UTC
Created attachment 552284 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-10-22 17:41:26 UTC
Created attachment 552286 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-10-22 17:41:29 UTC
Created attachment 552288 [details]
temp.tbz2
Comment 7 Cheyenne Wills 2018-10-25 06:29:16 UTC
It appears that in the glibc-2.28 level the _STDIO_USES_IOSTREAM has been removed or relocated.  The commit for glibc is -> 

a4fea3f2c3253b9ae6ffacd3747034ccbe56bc60 ( https://sourceware.org/git/?p=glibc.git;a=commit;h=a4fea3f2c3253b9ae6ffacd3747034ccbe56bc60 )


Not sure if this is a glibc backward compatibility error, or if they are still working on changing the code around..

I'll report this to upstream Icon and see what they say..

======
#if defined(__GLIBC__) && defined(_STDIO_USES_IOSTREAM)	/* new GCC library */
   if (f->_IO_read_ptr < f->_IO_read_end)  ** << should be here >> **
      RetArg(1);
#elif defined(__GLIBC__)				/* old GCC library */
   if (f->__bufp < f->__get_limit)  ** << error is here >> **
      RetArg(1);
#elif defined(_FSTDIO)					/* new BSD library */
   if (f->_r > 0)
      RetArg(1);
#else							/* old AT&T library */
   if (f->_cnt > 0)
      RetArg(1);
#endif

====
Comment 8 Cheyenne Wills 2018-11-05 16:02:07 UTC
Upstream has taken my patch and incorporated it into their master.  May take a while before upstream creates a new "level" for distribution, but the change is there.

https://github.com/gtownsend/icon/commit/bfc4a6004d0d3984c8066289b8d8e563640c4ddd
Comment 9 Larry the Git Cow gentoo-dev 2018-12-02 20:35:55 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e6208724793683c9c07dd2741483d39797dca1a2

commit e6208724793683c9c07dd2741483d39797dca1a2
Author:     Cheyenne Wills <cwills@witznd.net>
AuthorDate: 2018-10-29 01:10:29 +0000
Commit:     Georgy Yakovlev <gyakovlev@gentoo.org>
CommitDate: 2018-12-02 20:32:47 +0000

    dev-lang/icon: Fixes compile error with glibc 2.28
    
    Added patch pending upstream patch approval
    
    Bug: https://bugs.gentoo.org/669330
    Closes: https://github.com/gentoo/gentoo/pull/10288
    Package-Manager: Portage-2.3.49, Repoman-2.3.11
    Signed-off-by: Cheyenne Wills <cwills@witznd.net>
    Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>

 dev-lang/icon/files/icon-9.5.1-fpoll.patch |  27 +++++++
 dev-lang/icon/icon-9.5.1-r2.ebuild         | 114 +++++++++++++++++++++++++++++
 2 files changed, 141 insertions(+)
Comment 10 Cheyenne Wills 2018-12-02 21:19:44 UTC
Can be closed
Comment 11 Cheyenne Wills 2019-05-07 03:25:30 UTC
*** Bug 685060 has been marked as a duplicate of this bug. ***