Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 667408 - gnome-base/gconf-3.2.6-r4 : gconf/gconfmarshal.list: Permission denied
Summary: gnome-base/gconf-3.2.6-r4 : gconf/gconfmarshal.list: Permission denied
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-30 19:28 UTC by Toralf Förster
Modified: 2020-08-20 22:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.11 KB, text/plain)
2018-09-30 19:28 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,177.55 KB, text/plain)
2018-09-30 19:28 UTC, Toralf Förster
Details
environment (environment,160.92 KB, text/plain)
2018-09-30 19:28 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,26.76 KB, application/x-bzip)
2018-09-30 19:29 UTC, Toralf Förster
Details
gnome-base:gconf-3.2.6-r4:20180930-192337.log (gnome-base:gconf-3.2.6-r4:20180930-192337.log,12.83 KB, text/plain)
2018-09-30 19:29 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,11.78 KB, application/x-bzip)
2018-09-30 19:29 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,37.49 KB, application/x-bzip)
2018-09-30 19:29 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-09-30 19:28:49 UTC
checking for GSETTINGS... yes
checking for gio-querymodules... /usr/bin/gio-querymodules
Package ORBit-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `ORBit-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'ORBit-2.0' found

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-no-multilib-hardened_20180926-050400

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.2.0 *

Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.6
  [3]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems)
  [2]   ruby25 (with Rubygems) *



emerge -qpv gnome-base/gconf
[ebuild  N    ] gnome-base/gconf-3.2.6-r4  USE="introspection -debug -ldap -policykit" PYTHON_TARGETS="python2_7"
Comment 1 Toralf Förster gentoo-dev 2018-09-30 19:28:53 UTC
Created attachment 548526 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-09-30 19:28:56 UTC
Created attachment 548528 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-09-30 19:28:59 UTC
Created attachment 548530 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-09-30 19:29:01 UTC
Created attachment 548532 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-09-30 19:29:04 UTC
Created attachment 548534 [details]
gnome-base:gconf-3.2.6-r4:20180930-192337.log
Comment 6 Toralf Förster gentoo-dev 2018-09-30 19:29:07 UTC
Created attachment 548536 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2018-09-30 19:29:10 UTC
Created attachment 548538 [details]
temp.tbz2
Comment 8 James Le Cuirot gentoo-dev 2020-08-20 22:21:21 UTC
The error reported here isn't the one that caused the build to fail. It's this:

>>> Compiling source in /var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6 ...
 * abi_x86_64.amd64: running multilib-minimal_abi_src_compile
make -j1 
make  all-recursive
make[1]: Entering directory '/var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6-abi_x86_64.amd64'
Making all in gconf
make[2]: Entering directory '/var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6-abi_x86_64.amd64/gconf'
/var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6/gconf/gconfmarshal.list --header --prefix=gconf_marshal > gconfmarshal.h
/bin/sh: /var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6/gconf/gconfmarshal.list: Permission denied
make[2]: *** [Makefile:1150: gconfmarshal.h] Error 126
make[2]: Leaving directory '/var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6-abi_x86_64.amd64/gconf'
make[1]: *** [Makefile:539: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/gnome-base/gconf-3.2.6-r4/work/GConf-3.2.6-abi_x86_64.amd64'
make: *** [Makefile:422: all] Error 2

I wasn't able to reproduce it though, whether building as root or non-root. No one else has reported it in the years since either. Closing.