Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 667104 - =sys-devel/gcc-8.2.0-r3 CFLAGS=-Wstack-protector - .../work/gcc-8.2.0/libgomp/task.c:288:1: error: stack protector not protecting local variables: variable length buffer [-Werror=stack-protector]
Summary: =sys-devel/gcc-8.2.0-r3 CFLAGS=-Wstack-protector - .../work/gcc-8.2.0/libgomp...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: werror
  Show dependency tree
 
Reported: 2018-09-26 07:10 UTC by Jeroen Roovers (RETIRED)
Modified: 2018-10-27 19:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-devel:gcc-8.2.0-r3:20180926-012703.log.xz (sys-devel:gcc-8.2.0-r3:20180926-012703.log.xz,76.59 KB, application/x-xz)
2018-09-26 07:10 UTC, Jeroen Roovers (RETIRED)
Details
gcc-8.2.0-no-werror.patch (gcc-8.2.0-no-werror.patch,1.27 KB, patch)
2018-09-26 23:22 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2018-09-26 07:10:22 UTC
Created attachment 547950 [details]
sys-devel:gcc-8.2.0-r3:20180926-012703.log.xz

libtool: compile:  /home/portage/sys-devel/gcc-8.2.0-r3/work/build/./gcc/xgcc -B/home/portage/sys-devel/gcc-8.2.0-r3/work/build/./gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -B/usr/x86_64-pc-linux-gnu/lib/ -isystem /usr/x86_64-pc-linux-gnu/include -isystem /usr/x86_64-pc-linux-gnu/sys-include -DHAVE_CONFIG_H -I. -I/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp -I/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/config/linux/x86 -I/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/config/linux -I/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/config/posix -I/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp -I/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/../include -Wall -Werror -pthread -ftls-model=initial-exec -g -pipe -O2 -Wall -Wformat=2 -Wstack-protector -march=amdfam10 -mtune=amdfam10 -Wno-comment -MT task.lo -MD -MP -MF .deps/task.Tpo -c /home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/task.c  -fPIC -DPIC -o .libs/task.o
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/task.c: In function ‘GOMP_task’:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/task.c:288:1: error: stack protector not protecting local variables: variable length buffer [-Werror=stack-protector]
 GOMP_task (void (*fn) (void *), void *data, void (*cpyfn) (void *, void *),
 ^~~~~~~~~
In file included from /home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/task.c:470:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/taskloop.c: In function ‘GOMP_taskloop’:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/taskloop.c:34:1: error: stack protector not protecting local variables: variable length buffer [-Werror=stack-protector]
 GOMP_taskloop (void (*fn) (void *), void *data, void (*cpyfn) (void *, void *),
 ^~~~~~~~~~~~~
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/taskloop.c: In function ‘GOMP_taskloop_ull’:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/task.c:477:23: error: stack protector not protecting local variables: variable length buffer [-Werror=stack-protector]
 #define GOMP_taskloop GOMP_taskloop_ull
                       ^~~~~~~~~~~~~~~~~
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libgomp/taskloop.c:34:1: note: in expansion of macro ‘GOMP_taskloop’
 GOMP_taskloop (void (*fn) (void *), void *data, void (*cpyfn) (void *, void *),
 ^~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[5]: *** [Makefile:659: task.lo] Error 1
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2018-09-26 07:11:13 UTC
Wed 26 Sep 09:10:39 CEST 2018
emerge --info =sys-devel/gcc-8.2.0*
Portage 2.3.50 (python 2.7.15-final-0, default/linux/amd64/17.0, gcc-7.3.0, glibc-2.27-r6, 4.18.9-gentoo-JeR x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.18.9-gentoo-JeR-x86_64-AMD_Athlon-tm-_II_X3_455_Processor-with-gentoo-2.4.1
KiB Mem:    16426880 total,    380716 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of repository gentoo: Wed, 26 Sep 2018 02:15:01 +0000
Head commit of repository gentoo: aee5ad6e38a815ea093f1636c935deaa7fd8b1eb
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p2) 2.30.0
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.5.5-r1::gentoo, 3.6.5::gentoo, 3.7.0::gentoo
dev-util/ccache:          3.3.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.38.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.23.2::gentoo, 2.26.1::gentoo, 2.28.1::gentoo, 2.29.1-r1::gentoo, 2.30-r2::gentoo
sys-devel/gcc:            4.7.3-r1::gentoo, 4.9.4::gentoo, 5.4.0-r4::gentoo, 6.4.0-r1::gentoo, 7.3.0-r2::gentoo, 8.1.0-r3::gentoo, 8.2.0-r2::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /aches/gentoo/portage
    sync-type: rsync
    sync-uri: rsync://rsync.nl.gentoo.org/gentoo-portage
    priority: 0
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

qt
    location: /aches/gentoo/layman/qt
    masters: gentoo
    priority: 50

steam-overlay
    location: /aches/gentoo/layman/steam
    masters: gentoo
    priority: 50

JeR
    location: /aches/gentoo/local
    masters: gentoo
    priority: 10000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-frecord-gcc-switches -g -pipe -O2 -Wall -Wformat=2 -Wstack-protector -march=amdfam10 -mtune=amdfam10 -Wno-comment"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/ccache/bin /usr/lib/distcc/bin /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-frecord-gcc-switches -g -pipe -O2 -Wall -Wformat=2 -Wstack-protector -march=amdfam10 -mtune=amdfam10"
DISTDIR="/aches/gentoo/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg cgroup compressdebug config-protect-if-modified distlocks fakeroot fixlafiles merge-sync metadata-transfer multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms sign splitdebug strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" http://mirror.netcologne.de/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.leaseweb.com/gentoo/ "
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="en_GB en nl"
MAKEOPTS="-j1"
PKGDIR="/aches/gentoo/packages/wim"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/home"
USE="256-color X a52 aac acl acpi alsa amd64 apng bash-completion berkdb bluetooth bzip2 cairo cli consolekit cracklib crypt cups cxx dbus distinct-l dri drm egl ffmpeg flac fortran gdbm gif glamor graphite gtk gudev hwdb i3 iconv idn introspection ipv6 ithreads jack jpeg kmod lame libtirpc lzma minizip mmx mmxext mng modules mtp multilib multislot multitarget musepack ncat ncurses netlink nfs nls nonblockdialogs nptl offensive ogg opencv opengl openmp openrc opus pam pcre perl plasma png policykit python qml qt3support qt5 quesoglc readline savedconfig sbc seccomp sensord sloppy smp socks5 sse sse2 sse3 sse4 sse4_1 ssl system-libCg tcpd theora threads tiff tinfo truetype tty-helpers unicode unwind upower uvm vdpau vim-syntax vorbis wavpack wayland webkit2 x264 xa xattr xcb xft xinerama zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="rrdtool rrdcached" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext popcnt sse sse2 sse3 sse4a" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="aivdm nmea nmea2000 nmea0183" INPUT_DEVICES="evdev libinput" KERNEL="linux" L10N="en-GB en nl" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86 NVPTX" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-devel/gcc-8.2.0-r2::gentoo was built with the following:
USE="cxx fortran graphite (multilib) nls nptl openmp pch (pie) sanitize ssp vtv (-altivec) -debug -doc (-fixed-point) -go (-hardened) (-jit) (-libssp) -mpx -objc -objc++ -objc-gc -pgo -regression-test -systemtap -vanilla" ABI_X86="(64)"
CFLAGS="-g -pipe -O2 -Wall -Wformat=2 -march=amdfam10 -mtune=amdfam10 -Wno-comment"
CXXFLAGS="-g -pipe -O2 -Wall -Wformat=2 -march=amdfam10 -mtune=amdfam10"
Comment 2 Sergei Trofimovich gentoo-dev 2018-09-26 22:51:30 UTC
I think it's now caused by the fact that we pass CXXFLAGS through after bug #581406 and now checking -Werror abainst user's flags. Let'ss how easy it is to drop -Werror.

I saw similar error when cross-building gcc (when host's gcc version was used for most builds).
Comment 3 Sergei Trofimovich gentoo-dev 2018-09-26 23:07:57 UTC
There are 3 unconditional -Werror injections we should remove or put under --disable-werror:

$ git grep -B2 -E 'XCFLAGS=.*Werror' | cat
libatomic/configure-# Add -Wall -Werror if we are using GCC.
libatomic/configure-if test "x$GCC" = "xyes"; then
libatomic/configure:  XCFLAGS="$XCFLAGS -Wall -Werror"
--
libatomic/configure.ac-# Add -Wall -Werror if we are using GCC.
libatomic/configure.ac-if test "x$GCC" = "xyes"; then
libatomic/configure.ac:  XCFLAGS="$XCFLAGS -Wall -Werror"
--
libgomp/configure-# Add -Wall -Werror if we are using GCC.
libgomp/configure-if test "x$GCC" = "xyes"; then
libgomp/configure:  XCFLAGS="$XCFLAGS -Wall -Werror"
--
libgomp/configure.ac-# Add -Wall -Werror if we are using GCC.
libgomp/configure.ac-if test "x$GCC" = "xyes"; then
libgomp/configure.ac:  XCFLAGS="$XCFLAGS -Wall -Werror"
--
libitm/configure-# Add -Wall -Werror if we are using GCC.
libitm/configure-if test "x$GCC" = "xyes"; then
libitm/configure:  XCFLAGS="$XCFLAGS -Wall -Werror"
--
libitm/configure.ac-# Add -Wall -Werror if we are using GCC.
libitm/configure.ac-if test "x$GCC" = "xyes"; then
libitm/configure.ac:  XCFLAGS="$XCFLAGS -Wall -Werror"
Comment 4 Sergei Trofimovich gentoo-dev 2018-09-26 23:22:20 UTC
Created attachment 548010 [details, diff]
gcc-8.2.0-no-werror.patch

Please check if gcc-8.2.0-no-werror.patch works for you.

I'll also check it locally and apply on affected gcc versions.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2018-09-27 21:39:09 UTC
(In reply to Sergei Trofimovich from comment #4)
> Created attachment 548010 [details, diff] [details, diff]
> gcc-8.2.0-no-werror.patch
> 
> Please check if gcc-8.2.0-no-werror.patch works for you.
> 
> I'll also check it locally and apply on affected gcc versions.

In file included from ../config.h:158,
                 from /home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/../../libiberty/cp-demangle.c:106:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/../../libiberty/cp-demangle.c: In function ‘__asan_cplus_demangle_print_callback’:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/backtrace-rename.h:28:39: error: stack protector not protecting local variables:
variable length buffer [-Werror=stack-protector]
 #define cplus_demangle_print_callback __asan_cplus_demangle_print_callback
                                       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/backtrace-rename.h:28:39: note: in definition of macro ‘cplus_demangle_print_callback’
 #define cplus_demangle_print_callback __asan_cplus_demangle_print_callback
                                       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/../../libiberty/cp-demangle.c: In function ‘d_demangle_callback’:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/../../libiberty/cp-demangle.c:6199:1: error: stack protector not protecting local variables: variable length buffer [-Werror=stack-protector]
 d_demangle_callback (const char *mangled, int options,
 ^~~~~~~~~~~~~~~~~~~
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/../../libiberty/cp-demangle.c: In function ‘is_ctor_or_dtor’:
/home/portage/sys-devel/gcc-8.2.0-r3/work/gcc-8.2.0/libsanitizer/libbacktrace/../../libiberty/cp-demangle.c:6498:1: error: stack protector not protecting local variables: variable length buffer [-Werror=stack-protector]
 is_ctor_or_dtor (const char *mangled,
 ^~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[4]: *** [Makefile:474: cp-demangle.lo] Error 1

Maybe you missed a few instances.

grep -r -- -Werror
Comment 6 Larry the Git Cow gentoo-dev 2018-09-30 22:08:56 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=a7acee064e82c1de695f2303b705fd69884d9e99

commit a7acee064e82c1de695f2303b705fd69884d9e99
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-09-30 22:05:19 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-09-30 22:05:19 +0000

    8.2.0: restore -Werror patches
    
    Five new patches that drop -Werror:
    + 105_all_libgfortran-Werror.patch
    + 106_all_libgomp-Werror.patch
    + 107_all_libitm-Werror.patch
    + 108_all_libatomic-Werror.patch
    + 109_all_libbacktrace-Werror.patch
    
    The patches are no really new: last time Gentoo applied
    them on gcc-4.9.x branch but after 5.x they were lost.
    
    Need for them resurfaces after series of fixes that allowed
    user to tweak CXXFLAGS (bug #581406)
    
    Reported-by: Jeroen Roovers
    Bug: https://bugs.gentoo.org/667104
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 8.2.0/gentoo/105_all_libgfortran-Werror.patch  | 13 +++++++++++++
 8.2.0/gentoo/106_all_libgomp-Werror.patch      | 20 ++++++++++++++++++++
 8.2.0/gentoo/107_all_libitm-Werror.patch       | 19 +++++++++++++++++++
 8.2.0/gentoo/108_all_libatomic-Werror.patch    | 19 +++++++++++++++++++
 8.2.0/gentoo/109_all_libbacktrace-Werror.patch | 17 +++++++++++++++++
 8.2.0/gentoo/README.history                    | 10 ++++++++++
 6 files changed, 98 insertions(+)
Comment 7 Larry the Git Cow gentoo-dev 2018-10-01 06:41:44 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/gcc-patches.git/commit/?id=47a9739ebedfacef2c4b9b154e6a4017a9e6ff77

commit 47a9739ebedfacef2c4b9b154e6a4017a9e6ff77
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-01 06:40:50 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-01 06:40:50 +0000

    8.2.0: drop -Werror on 110_all_libsanitizer
    
    Reported-by: Jeroen Roovers
    Bug: https://bugs.gentoo.org/667104
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 8.2.0/gentoo/110_all_libsanitizer-Werror.patch | 17 +++++++++++++++++
 8.2.0/gentoo/README.history                    |  1 +
 2 files changed, 18 insertions(+)
Comment 8 Larry the Git Cow gentoo-dev 2018-10-01 07:03:01 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=48f852bbfa2e4caf69904711135d13ee8537e5ae

commit 48f852bbfa2e4caf69904711135d13ee8537e5ae
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-01 07:02:44 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-01 07:02:54 +0000

    sys-devel/gcc: cut 1.4 patchset for 8.2.0
    
    Six new patches. All disable -Werror:
    + 105_all_libgfortran-Werror.patch
    + 106_all_libgomp-Werror.patch
    + 107_all_libitm-Werror.patch
    + 108_all_libatomic-Werror.patch
    + 109_all_libbacktrace-Werror.patch
    + 110_all_libsanitizer-Werror.patch
    
    105..109 are picked from 4.9.x patchset. 110 is new.
    
    Reported-by: Jeroen Roovers
    Bug: https://bugs.gentoo.org/667104
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.50, Repoman-2.3.11

 sys-devel/gcc/Manifest            | 2 +-
 sys-devel/gcc/gcc-8.2.0-r3.ebuild | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
Comment 9 Larry the Git Cow gentoo-dev 2018-10-27 11:46:27 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd

commit 7f16eb5b72bb49fa1dbdedd08ee85b95eaf67cdd
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 09:23:45 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 11:46:08 +0000

    sys-devel/gcc: cut 1.8 patchset for 6.4.0
    
    Eight new patches:
    + 103_all_remove-lieee.patch:
      drop assumed -lieee from -mieee-fp
    + 104_all_libgfortran-Werror.patch:
    + 105_all_libgomp-Werror.patch
    + 106_all_libitm-Werror.patch
    + 107_all_libatomic-Werror.patch
    + 108_all_libbacktrace-Werror.patch
    + 109_all_libsanitizer-libbacktrace-Werror.patch:
      pull in all -Werror patches from 8.2.0
    + 110_all_libstdcxx-no-vtv.patch:
      drop libvtv RPATH from libstdc++
    
    Bug: https://bugs.gentoo.org/667104
    Bug: https://bugs.gentoo.org/475350
    Bug: https://bugs.gentoo.org/229059
    Bug: http://gcc.gnu.org/PR38436
    Bug: https://bugs.gentoo.org/433435
    Bug: http://gcc.gnu.org/PR54724
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-6.4.0-r5.ebuild | 24 ++++++++++++++++++++++++
 2 files changed, 25 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2277fa55f1dd056891a5c7037741ee753df8f819

commit 2277fa55f1dd056891a5c7037741ee753df8f819
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 09:15:23 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 11:46:08 +0000

    sys-devel/gcc: cut 1.8 patchset for 7.3.0
    
    Five new patches:
    + 101_all_remove-lieee.patch:
      drop assumed -lieee from -mieee-fp
    + 102_all_libgfortran-Werror.patch:
    + 103_all_libgomp-Werror.patch
    + 104_all_libitm-Werror.patch
    + 105_all_libatomic-Werror.patch
    + 106_all_libbacktrace-Werror.patch
    + 107_all_libsanitizer-libbacktrace-Werror.patch:
      pull in all -Werror patches from 8.2.0
    + 108_all_libstdcxx-no-vtv.patch:
      drop libvtv RPATH from libstdc++
    
    Bug: https://bugs.gentoo.org/667104
    Bug: https://bugs.gentoo.org/475350
    Bug: https://bugs.gentoo.org/229059
    Bug: http://gcc.gnu.org/PR38436
    Bug: https://bugs.gentoo.org/433435
    Bug: http://gcc.gnu.org/PR54724
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-7.3.0-r6.ebuild | 24 ++++++++++++++++++++++++
 2 files changed, 25 insertions(+)
Comment 10 Sergei Trofimovich gentoo-dev 2018-10-27 16:30:41 UTC
gcc-8.2.0-r4, gcc-7.3.0-r6, gcc-6.5.0, gcc-6.4.0-r5 should be fixed now. I'll pull all patches to older gcc version over time as well.
Comment 11 Larry the Git Cow gentoo-dev 2018-10-27 19:22:07 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c84f250076a6a6f33202c022a256b34284d91111

commit c84f250076a6a6f33202c022a256b34284d91111
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-10-27 19:17:52 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-10-27 19:21:54 +0000

    sys-devel/gcc: cut 1.11 patchset for 5.4.0
    
    Eight new patches:
    + 99_all_remove-lieee.patch:
      drop assumed -lieee from -mieee-fp
    + 100_all_libgfortran-Werror.patch:
    + 101_all_libgomp-Werror.patch
    + 102_all_libitm-Werror.patch
    + 103_all_libatomic-Werror.patch
    + 104_all_libbacktrace-Werror.patch
    + 105_all_libsanitizer-libbacktrace-Werror.patch:
      pull in all -Werror patches from 8.2.0
    + 106_all_libstdcxx-no-vtv.patch:
      drop libvtv RPATH from libstdc++
    
    Bug: https://bugs.gentoo.org/667104
    Bug: https://bugs.gentoo.org/475350
    Bug: https://bugs.gentoo.org/229059
    Bug: http://gcc.gnu.org/PR38436
    Bug: https://bugs.gentoo.org/433435
    Bug: http://gcc.gnu.org/PR54724
    Bug: https://bugs.gentoo.org/582524
    Bug: https://gcc.gnu.org/PR85884
    Closes: https://bugs.gentoo.org/621178
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 sys-devel/gcc/Manifest            |  1 +
 sys-devel/gcc/gcc-5.4.0-r6.ebuild | 44 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 45 insertions(+)