Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 666892 - sys-fs/eudev-3.2.6: likely quoting failure in /lib/udev/rules.d/64-btrfs.rules
Summary: sys-fs/eudev-3.2.6: likely quoting failure in /lib/udev/rules.d/64-btrfs.rules
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: eudev team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-23 17:14 UTC by Tobias Klausmann
Modified: 2018-12-02 12:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann gentoo-dev 2018-09-23 17:14:50 UTC
/lib/udev/rules.d/64-btrfs.rules likely has a quoting/variable expansion mismatch. In dmesg i see:

[    7.734849] udevd[1119]: failed to execute '/lib/udev/@rootbindir@/udevadm' '@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory
[    7.805730] udevd[1121]: failed to execute '/lib/udev/@rootbindir@/udevadm' '@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory
[    7.809417] udevd[1122]: failed to execute '/lib/udev/@rootbindir@/udevadm' '@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory
[    7.852026] udevd[1124]: failed to execute '/lib/udev/@rootbindir@/udevadm' '@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory
[    7.937961] udevd[1157]: failed to execute '/lib/udev/@rootbindir@/udevadm' '@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory
[    7.945812] udevd[1162]: failed to execute '/lib/udev/@rootbindir@/udevadm' '@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory

and the file mentioned contains:


# reconsider pending devices in case when multidevice volume awaits
ENV{ID_BTRFS_READY}=="1", RUN+="@rootbindir@/udevadm trigger -s block -p ID_BTRFS_READY=0"


My suspicion is that @rootbindir@ is supposed to be replaced/expanded at compile or install time, but something is going wrong.

As far as I can tell, the error message is the only sideffect, but it might be that module loading is busted (I have btrfs support compiled in since my rootfs ins btrfs).
Comment 1 Anthony Basile gentoo-dev 2018-09-24 01:05:30 UTC
Thanks for catching this.  This is address in

https://github.com/gentoo/eudev/commit/96c5552c52fc9b5b5f25e8ff7d5fb3e6e518474d

and will be out in the next release.
Comment 2 Tobias Klausmann gentoo-dev 2018-09-24 13:12:59 UTC
I spotted another dmesg entry just now:

[    2.205352] systemd-udevd[328]: ignoring invalid mode '@DEV_KVM_MODE@'

different machine:

[    7.565111] udevd[1051]: ignoring invalid mode '@DEV_KVM_MODE@'
Comment 3 Anthony Basile gentoo-dev 2018-09-24 22:18:44 UTC
(In reply to Tobias Klausmann from comment #2)
> I spotted another dmesg entry just now:
> 
> [    2.205352] systemd-udevd[328]: ignoring invalid mode '@DEV_KVM_MODE@'
> 
> different machine:
> 
> [    7.565111] udevd[1051]: ignoring invalid mode '@DEV_KVM_MODE@'

that's already fixed with 

https://github.com/gentoo/eudev/commit/a8ffcd1b985fb4b3e2c3a1cb9051bed86f69d3f3
Comment 4 Attila Tóth 2018-09-25 22:19:31 UTC
Let me have another one.
How about this:
[   12.541954] udevd[1096]: specified group 'render' unknown
[   12.592199] udevd[1097]: starting eudev-3.2.6
[   12.791496] udevd[1097]: specified group 'render' unknown
Thx: Dw.
Comment 5 Attila Tóth 2018-09-25 22:36:20 UTC
(In reply to Attila Tóth from comment #4)
> Let me have another one.
> How about this:
> [   12.541954] udevd[1096]: specified group 'render' unknown
> [   12.592199] udevd[1097]: starting eudev-3.2.6
> [   12.791496] udevd[1097]: specified group 'render' unknown
> Thx: Dw.

Answering my own question: systemd ebuild adds that group.
I added the missing group manually to resolve the log entry.
Comment 6 Daniel Kenzelmann 2018-10-14 10:06:47 UTC
Don't want to bring up too much different stuff here but I see that it has alredy been mentioned:
the only thing left now regarding the udev rules is the render group.

udevd[784]: ignoring invalid mode '@GROUP_RENDER_MODE@'

Considering the outcome of the upstream issue https://github.com/gentoo/eudev/issues/160

"okay i think i'm going to leave things as is. if various distros need to change things, they can patch the rules locally."

, thus this should be addressed in gentoo to either add the render group in eudev or patch the rules to use the video group.
Comment 7 Daniel Kenzelmann 2018-10-14 10:08:54 UTC
Gah ,ignore my comment, I see that has also been addressed ... (my coffee is empty....)

sorry for the noise..
Comment 8 Matt Turner gentoo-dev 2018-10-17 22:13:26 UTC
I've package.masked =sys-fs/eudev-3.2.6.
Comment 9 Anthony Basile gentoo-dev 2018-10-26 13:58:24 UTC
(In reply to Matt Turner from comment #8)
> I've package.masked =sys-fs/eudev-3.2.6.

okay this bug is taken care of with 3.2.7 which is in the tree.
Comment 10 Tobias Klausmann gentoo-dev 2018-11-05 10:24:53 UTC
This is still happening (slightly differently) with 3.2.7:

[    8.218033] udevd[1205]: failed to execute '/lib/udev/${exec_prefix}/bin/udevadm' '${exec_prefix}/bin/udevadm trigger -s block -p ID_BTRFS_READY=0': No such file or directory

$ equery l eudev
 * Searching for eudev ...
[IP-] [  ] sys-fs/eudev-3.2.7:0
Comment 11 Anthony Basile gentoo-dev 2018-12-01 21:16:27 UTC
(In reply to Tobias Klausmann from comment #10)
> This is still happening (slightly differently) with 3.2.7:
> 
> [    8.218033] udevd[1205]: failed to execute
> '/lib/udev/${exec_prefix}/bin/udevadm' '${exec_prefix}/bin/udevadm trigger
> -s block -p ID_BTRFS_READY=0': No such file or directory
> 
> $ equery l eudev
>  * Searching for eudev ...
> [IP-] [  ] sys-fs/eudev-3.2.7:0

Thanks for reopening.  I was able to reproduce this so it needs fixing.
Comment 12 Anthony Basile gentoo-dev 2018-12-01 22:16:59 UTC
(In reply to Tobias Klausmann from comment #10)
> This is still happening (slightly differently) with 3.2.7:
> 
> [    8.218033] udevd[1205]: failed to execute
> '/lib/udev/${exec_prefix}/bin/udevadm' '${exec_prefix}/bin/udevadm trigger
> -s block -p ID_BTRFS_READY=0': No such file or directory
> 
> $ equery l eudev
>  * Searching for eudev ...
> [IP-] [  ] sys-fs/eudev-3.2.7:0

Okay this should be fixed with 3.2.7-r1 which I just added.  I tested and it fixed it for me.  Can you please confirm.  Thanks!
Comment 13 Tobias Klausmann gentoo-dev 2018-12-02 12:41:14 UTC
(In reply to Anthony Basile from comment #12)
> Okay this should be fixed with 3.2.7-r1 which I just added.  I tested and it
> fixed it for me.  Can you please confirm.  Thanks!

Yep, 3.2.7-r1 fixes this for me, thanks!