Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 66672 - [EBUILD] Machinations-0.35
Summary: [EBUILD] Machinations-0.35
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Games
Keywords: EBUILD
Depends on: 66532
  Show dependency tree
Reported: 2004-10-07 11:11 UTC by Christoph Brill (egore) (RESIGNED)
Modified: 2006-04-12 13:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

games-strategy/machinations-0.35.ebuild (machinations-0.35.ebuild,1.04 KB, text/plain)
2004-10-07 11:13 UTC, Christoph Brill (egore) (RESIGNED)
machinations-0.35.patch (machinations-0.35.patch,948 bytes, patch)
2004-10-07 11:15 UTC, Christoph Brill (egore) (RESIGNED)
Details | Diff
games-strategy/machinations-0.35.ebuild (machinations-0.35.ebuild,1.06 KB, text/plain)
2004-10-08 14:43 UTC, Christoph Brill (egore) (RESIGNED)
machinations-0.35.ebuild (machinations-0.35.ebuild,1.05 KB, text/plain)
2005-06-23 23:52 UTC, Mr. Bones. (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Brill (egore) (RESIGNED) 2004-10-07 11:11:14 UTC
I made an ebuild for machinations. Currently it fails since there are some bugs in the code. Maybe someone will take a look at it since the game looks really nice.

Reproducible: Always
Steps to Reproduce:
Comment 1 Christoph Brill (egore) (RESIGNED) 2004-10-07 11:13:31 UTC
Created attachment 41306 [details]

the ebuild
Comment 2 Christoph Brill (egore) (RESIGNED) 2004-10-07 11:15:13 UTC
Created attachment 41307 [details, diff]

the patch to get it compile a bit further
Comment 3 Christoph Brill (egore) (RESIGNED) 2004-10-07 11:18:29 UTC
Some information on why it fails:

terrain2.cpp texture.cpp: does not find one DevIL function (ilutGL...)

in terrain2.cpp is fails because of some file reading function :/

both issues are unable to be fixed by me (I tried everything that I could think of)
Comment 4 Christoph Brill (egore) (RESIGNED) 2004-10-08 14:43:12 UTC
Created attachment 41393 [details]

just realized that I forgot the most important dependecy :D
Comment 5 Mr. Bones. (RETIRED) gentoo-dev 2005-06-23 23:52:01 UTC
Created attachment 61829 [details]

Here's the ebuild I tried and it totally failed to compile.  I probably messed
something up.
Comment 6 Tupone Alfredo gentoo-dev 2006-04-12 13:22:30 UTC
There are problems compiling this program.
Upstream had no activity since 2 years.
Maybe opening again when a new version is out ?