Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 666418 - media-libs/fontconfig-2.13.1 incompletely ported to EAPI="7" and with upstream regression, resulting in sandbox violations for fonts cache
Summary: media-libs/fontconfig-2.13.1 incompletely ported to EAPI="7" and with upstrea...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal with 1 vote (vote)
Assignee: Gentoo Fonts Team
URL:
Whiteboard:
Keywords: PMASKED
: 666430 666446 666454 666484 666540 666603 668516 672384 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-17 16:59 UTC by Mark Nowiasz
Modified: 2019-01-12 10:52 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,32.83 KB, text/x-log)
2018-09-17 16:59 UTC, Mark Nowiasz
Details
Patch (fontconfig.patch,3.92 KB, patch)
2018-09-18 04:17 UTC, Arfrever Frehtes Taifersar Arahesis
Details | Diff
fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch (fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch,1005 bytes, patch)
2018-09-18 23:07 UTC, Arfrever Frehtes Taifersar Arahesis
Details | Diff
Patch (fontconfig.patch,2.90 KB, patch)
2018-09-18 23:45 UTC, Arfrever Frehtes Taifersar Arahesis
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Nowiasz 2018-09-17 16:59:48 UTC
Created attachment 547090 [details]
build.log

When trying to update libreoffice fails with sandbox violations:

------------------------------------------------------------------
checking for fc-match... /usr/bin/fc-match
checking font mapping for 'Calibri'...  * ACCESS DENIED:  unlink:       /usr/share/fonts/util/.uuid
 * ACCESS DENIED:  unlink:       /usr/share/fonts/encodings/large/.uuid
configure: WARNING: unknown (LiberationSans-Regular.ttf)
checking font mapping for 'DejaVuSans'...  * ACCESS DENIED:  unlink:       /usr/share/fonts/util/.uuid
 * ACCESS DENIED:  unlink:       /usr/share/fonts/encodings/large/.uuid
ok
-----------------------------------------------------------------------

 * --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 * LOG FILE: "/var/log/sandbox/sandbox-28036.log"
 * 
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: unlink
S: deny
P: /usr/share/fonts/util/.uuid
A: /usr/share/fonts/util/.uuid
R: /usr/share/fonts/util/.uuid
C: /usr/bin/fc-match -f %{file} Calibri 

F: unlink
S: deny
P: /usr/share/fonts/encodings/large/.uuid
A: /usr/share/fonts/encodings/large/.uuid
R: /usr/share/fonts/encodings/large/.uuid
C: /usr/bin/fc-match -f %{file} Calibri 

F: unlink
S: deny
P: /usr/share/fonts/util/.uuid
A: /usr/share/fonts/util/.uuid
R: /usr/share/fonts/util/.uuid
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: unlink
S: deny
P: /usr/share/fonts/encodings/large/.uuid
A: /usr/share/fonts/encodings/large/.uuid
R: /usr/share/fonts/encodings/large/.uuid
C: /usr/bin/fc-match -f %{file} DejaVuSans 
 * --------------------------------------------------------------------------------
Comment 1 Mark Nowiasz 2018-09-17 17:00:46 UTC
emerge --info =libreoffice-6.1.1.2
Portage 2.3.49 (python 3.7.0-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-8.2.0, glibc-2.27-r6, 4.18.8-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.18.8-gentoo-x86_64-Intel-R-_Core-TM-_i5-8250U_CPU_@_1.60GHz-with-gentoo-2.6
KiB Mem:    20428720 total,   4744440 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Mon, 17 Sep 2018 13:30:01 +0000
Head commit of repository gentoo: c5d93bc749c06b4c437851c1f8e0ffa58c7ea530
sh bash 4.4_p23
ld GNU ld (Gentoo 2.31.1 p1) 2.31.1
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.6::gentoo, 3.7.0::gentoo
dev-util/cmake:           3.12.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1::gentoo
sys-devel/gcc:            8.2.0-r2::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ rsync://mirror.eu.oneandone.net/gentoo/ http://mirror.netcologne.de/gentoo/ rsync://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp.halifax.rwth-aachen.de/gentoo/ rsync://ftp.halifax.rwth-aachen.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cryptsetup cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg flac fortran gdbm gif gimp git glamor gles gles2 gpm gtk iconv ipv6 jpeg kde kipi kwallet latex lcms ldap libnotify libtirpc mad matroska mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf pentax phonon pim plasma png policykit ppds pulseaudio python qml qt5 readline scanner sdl seccomp semantic-desktop smartcard smp spell sse sse2 sse3 ssl startup-notification subversion svg systemd tcpd tiff touchpad truetype udev udisks unicode upower usb vaapi vim-syntax vorbis wayland widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 python3_7" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Mark Nowiasz 2018-09-17 17:01:22 UTC
GENTOO_VM=oracle-jdk-bin-1.8  CLASSPATH="" JAVA_HOME="/opt/oracle-jdk-bin-1.8.0.181"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""
Comment 3 Juergen Rose 2018-09-17 18:52:28 UTC
I have the same issue.
Comment 4 MZ 2018-09-17 21:13:45 UTC
same problem.
Comment 5 Ulrich Müller gentoo-dev 2018-09-17 21:49:11 UTC
Apparently this is caused by media-libs/fontconfig-2.13.1. Downgrading to 2.13.0-r4 fixes the problem here.
Comment 6 Ulrich Müller gentoo-dev 2018-09-17 21:58:47 UTC
<QA>
I have package.masked =media-libs/fontconfig-2.13.1 for now.
</QA>
Comment 7 Arfrever Frehtes Taifersar Arahesis 2018-09-17 22:06:03 UTC
media-libs/fontconfig-2.13.1 was incompletely ported to EAPI="7".
There are 7 uses of ${ED}, 1 use of ${ROOT} and 1 use of ${EROOT} relying on them always ending with "/" (which was correct in older EAPIs, but not in EAPI="7"):

->      if [[ -e ${ED}usr/share/doc/fontconfig/ ]];  then
->              mv "${ED}"usr/share/doc/fontconfig/* "${ED}"/usr/share/doc/${P} || die
->              rm -rf "${ED}"usr/share/doc/fontconfig
        fi
...
        ebegin "Syncing fontconfig configuration to system"
        if [[ -e ${EROOT}/etc/fonts/conf.d ]]; then
                for file in "${EROOT}"/etc/fonts/conf.avail/*; do
                        f=${file##*/}
                        if [[ -L ${EROOT}/etc/fonts/conf.d/${f} ]]; then
->                              [[ -f ${ED}etc/fonts/conf.avail/${f} ]] \
->                                      && ln -sf ../conf.avail/"${f}" "${ED}"etc/fonts/conf.d/ &>/dev/null
                        else
->                              [[ -f ${ED}etc/fonts/conf.avail/${f} ]] \
->                                      && rm "${ED}"etc/fonts/conf.d/"${f}" &>/dev/null
                        fi
                done
        fi
...
pkg_postinst() {
        einfo "Cleaning broken symlinks in ${EROOT%/}/etc/fonts/conf.d/"
->      find -L "${EROOT}"etc/fonts/conf.d/ -type l -delete

        readme.gentoo_print_elog

->      if [[ ${ROOT} = / ]]; then
                multilib_pkg_postinst() {
                        ebegin "Creating global font cache for ${ABI}"
                        "${EPREFIX}"/usr/bin/${CHOST}-fc-cache -srf
Comment 8 Arfrever Frehtes Taifersar Arahesis 2018-09-18 04:12:50 UTC
For more completeness, some CBUILD-side tools could be moved from DEPEND to BDEPEND.
Comment 9 Arfrever Frehtes Taifersar Arahesis 2018-09-18 04:17:04 UTC
Created attachment 547138 [details, diff]
Patch
Comment 10 Arfrever Frehtes Taifersar Arahesis 2018-09-18 04:22:27 UTC
*** Bug 666446 has been marked as a duplicate of this bug. ***
Comment 11 Arfrever Frehtes Taifersar Arahesis 2018-09-18 04:24:15 UTC
*** Bug 666430 has been marked as a duplicate of this bug. ***
Comment 12 Andreas Sturmlechner gentoo-dev 2018-09-18 06:54:15 UTC
*** Bug 666454 has been marked as a duplicate of this bug. ***
Comment 13 Larry the Git Cow gentoo-dev 2018-09-18 07:16:07 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c99288edb7c658dafa1cd8056ab44f4569ad5075

commit c99288edb7c658dafa1cd8056ab44f4569ad5075
Author:     Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
AuthorDate: 2018-09-18 04:13:11 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2018-09-18 07:15:53 +0000

    media-libs/fontconfig: Various fixes mostly related to EAPI="7".
    
    Move CBUILD-side tools from DEPEND to BDEPEND.
    Add [${MULTILIB_USEDEP}] to dependency on virtual/pkgconfig.
    Fix usage of ${ED}, ${ROOT}, ${EROOT}.
    
    Closes: https://bugs.gentoo.org/666418

 media-libs/fontconfig/fontconfig-2.13.1.ebuild | 36 ++++++++++++++------------
 1 file changed, 19 insertions(+), 17 deletions(-)
Comment 14 Andreas Sturmlechner gentoo-dev 2018-09-18 16:20:23 UTC
*** Bug 666484 has been marked as a duplicate of this bug. ***
Comment 15 Matt McAdoo 2018-09-18 19:55:52 UTC
This is still present for me:


*************************************
* WARNING : OpenSSL has been disabled. No code compiled by LibO will make use of it but system librares may create indirect dependencies
* WARNING : unknown (DejaVuSans.ttf)
* WARNING : Unknown font mappings - unit tests disabled.
 * --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 * LOG FILE: "/tmp/sandbox-5920.log"
 * 
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkostemp
S: deny
P: /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
A: /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
R: /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} Calibri 

F: unlink
S: deny
P: /usr/share/fonts/Speedo/.uuid
A: /usr/share/fonts/Speedo/.uuid
R: /usr/share/fonts/Speedo/.uuid
C: /usr/bin/fc-match -f %{file} Calibri 

F: mkostemp
S: deny
P: /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
A: /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
R: /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} Calibri 

F: unlink
S: deny
P: /usr/share/fonts/cyrillic/.uuid
A: /usr/share/fonts/cyrillic/.uuid
R: /usr/share/fonts/cyrillic/.uuid
C: /usr/bin/fc-match -f %{file} Calibri 

F: mkostemp
S: deny
P: /usr/share/fonts/util/.uuid.TMP-XXXXXX
A: /usr/share/fonts/util/.uuid.TMP-XXXXXX
R: /usr/share/fonts/util/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} Calibri 

F: unlink
S: deny
P: /usr/share/fonts/util/.uuid
A: /usr/share/fonts/util/.uuid
R: /usr/share/fonts/util/.uuid
C: /usr/bin/fc-match -f %{file} Calibri 

F: mkostemp
S: deny
P: /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
A: /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
R: /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} Calibri 

F: unlink
S: deny
P: /usr/share/fonts/encodings/large/.uuid
A: /usr/share/fonts/encodings/large/.uuid
R: /usr/share/fonts/encodings/large/.uuid
C: /usr/bin/fc-match -f %{file} Calibri 

F: mkostemp
S: deny
P: /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
A: /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
R: /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: unlink
S: deny
P: /usr/share/fonts/Speedo/.uuid
A: /usr/share/fonts/Speedo/.uuid
R: /usr/share/fonts/Speedo/.uuid
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: mkostemp
S: deny
P: /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
A: /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
R: /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: unlink
S: deny
P: /usr/share/fonts/cyrillic/.uuid
A: /usr/share/fonts/cyrillic/.uuid
R: /usr/share/fonts/cyrillic/.uuid
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: mkostemp
S: deny
P: /usr/share/fonts/util/.uuid.TMP-XXXXXX
A: /usr/share/fonts/util/.uuid.TMP-XXXXXX
R: /usr/share/fonts/util/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: unlink
S: deny
P: /usr/share/fonts/util/.uuid
A: /usr/share/fonts/util/.uuid
R: /usr/share/fonts/util/.uuid
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: mkostemp
S: deny
P: /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
A: /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
R: /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
C: /usr/bin/fc-match -f %{file} DejaVuSans 

F: unlink
S: deny
P: /usr/share/fonts/encodings/large/.uuid
A: /usr/share/fonts/encodings/large/.uuid
R: /usr/share/fonts/encodings/large/.uuid
C: /usr/bin/fc-match -f %{file} DejaVuSans 
 * --------------------------------------------------------------------------------
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea-8  CLASSPATH="" JAVA_HOME="/usr/lib64/icedtea8"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""
and of course, the output of emerge --info =libreoffice-6.1.1.2
Comment 16 Matt McAdoo 2018-09-18 19:57:28 UTC
 #  emerge --info =media-libs/fontconfig-2.13.1-r1
Portage 2.3.49 (python 3.6.6-final-0, default/linux/amd64/17.0/desktop/gnome/systemd, gcc-8.2.0, glibc-2.27-r6, 4.18.6-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.18.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-4800MQ_CPU_@_2.70GHz-with-gentoo-2.6
KiB Mem:    32577560 total,  16650080 free
KiB Swap:    3999740 total,   3999740 free
Timestamp of repository gentoo: Tue, 18 Sep 2018 13:30:01 +0000
Head commit of repository gentoo: 281f0ff7c13d8e0c6800747a4d1719099dc99908
Head commit of repository brother-overlay: c057d3b0fb8e6afe53b4c9f354d68a43c9f33032

sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p3) 2.30.0
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.4.8-r1::gentoo, 3.5.5-r1::gentoo, 3.6.6::gentoo, 3.7.0::gentoo
dev-util/cmake:           3.12.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.38.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.10.3-r3::gentoo, 1.11.6-r3::gentoo, 1.12.6-r2::gentoo, 1.13.4-r2::gentoo, 1.14.1-r2::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r3::gentoo, 2.31.1::gentoo
sys-devel/gcc:            6.4.0-r3::gentoo, 7.3.0-r4::gentoo, 8.2.0-r2::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

Local-Grotto
    location: /usr/local/portage
    masters: gentoo
    priority: 0

cg
    location: /var/lib/layman/cg
    masters: gentoo
    priority: 50

freeswitch
    location: /var/lib/layman/freeswitch
    masters: gentoo
    priority: 50

games-overlay
    location: /var/lib/layman/games-overlay
    masters: gentoo
    priority: 50

sirjaren
    location: /var/lib/layman/sirjaren
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

torbrowser
    location: /var/lib/layman/torbrowser
    masters: gentoo
    priority: 50

wine
    location: /var/lib/layman/wine
    masters: gentoo
    priority: 50

zugaina
    location: /var/lib/layman/zugaina
    masters: gentoo
    priority: 50

brother-overlay
    location: /usr/local/portage/brother-overlay
    sync-type: git
    sync-uri: https://github.com/stefan-langenmaier/brother-overlay.git
    masters: gentoo
    priority: 9999

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 ao apache2 appindicator archive atasmart awt berkdb bluetooth boto branding bzip2 cairo calendar caps cdda cddb cdr cli cluster colord context crypt cups curl cxx d3d9 dbus development device-mapper dhclient dia down-root dri dts dvd dvdr eds elfutils emboss encode epspdf evo exif extensions extra extraengine fam ffmpge flac fortran fpm freerdp games gcj gd gdata gdbm gif git glamor gles gles1 gltf gnome gnome-keyring gnome-online-accounts google gpm graph graphics gstreamer gtk gtk3 hddtemp highlight http humanities iconv introspection iproute2 ipv6 javascript jemalloc jpeg jpeg2k json lcms ldap libkms libnotify libsecret libtirpc lm_sensors login lua lxc lzma mad matroska mms mmx mmxext mng mod modplug modules mp3 mp4 mpeg mtp multilib music mysql mysqli mysqlnd nautilus ncat ncurses ndiff network networkmanager nfs nfsv4 nfsv41 nls nping nptl odf offensive ogg omega opengl openmp opus osmesa pam pango pcre pda pdf pdfannotextractor pdo pgo php png policykit postgres postproc ppds printsupport profiling pstricks publishers pulseaudio qt5 raw readline redis rrdcgi s3tc samba science sdl seccomp sendto sensord slib soap sockets speex spell spice sqlite sse sse2 sse3 sse4.1 sse4.2 ssh ssl ssse3 staging startup-notification svc svg syntax-check systemd systemtap sysv-utils sysvipc tcpd telepathy terminal tex4ht texi2html theora threads thunar tiff tokudb tools tor-hardening truetype udev udisks unicode update_drivedb upower usb user-session v4l vaapi vdpau vim vim-syntax virtualbox visio vlc vnc vorbis vpx vte vulkan wayland webp widevine winbind wireshark-plugins wxwidgets x264 x265 xa xattr xcb xcomposite xetex xface xinerama xml xmlwriter xrandr xsl xslt xv xvfb xvid xvmc zenmap zip zlib zsh-completions" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_file authz_core authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation proxy proxy_balancer proxy_connect proxy_fdpass proxy_fcgi proxy_http proxy_scgi proxy_wstunnel ratelimit rewrite setenvif slotmem_shm socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="event" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 sse3 sse4_1 ssse3 mmxext" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="mouse keyboard evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher" NETBEANS_MODULES="apisupport java javafx mobility php profiler websvccommon" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi gunzip gzip_static metrics mp4 naxsi security realip stub_status pcre-jit" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_5 python3_6 python3_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="intel nouveau i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-libs/fontconfig-2.13.1-r1::gentoo was built with the following:
USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
Comment 17 Arfrever Frehtes Taifersar Arahesis 2018-09-18 20:59:59 UTC
I had seen "failed to write cache" errors, but I am not sure if it is related to potential remaining problem with sandbox violations.
Upstream bug: https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/107


Please test if reverting of this commit works around problem:
https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/f5dd8512bdf9fd8e01c30ae36f593758b29385cf
https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/f5dd8512bdf9fd8e01c30ae36f593758b29385cf.diff
Comment 18 Arfrever Frehtes Taifersar Arahesis 2018-09-18 22:03:53 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #17)
> I had seen "failed to write cache" errors, but I am not sure if it is
> related to potential remaining problem with sandbox violations.
> Upstream bug: https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/107
> 
> 
> Please test if reverting of this commit works around problem:
> https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/
> f5dd8512bdf9fd8e01c30ae36f593758b29385cf
> https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/
> f5dd8512bdf9fd8e01c30ae36f593758b29385cf.diff

This reversed patch does not apply cleanly. I will attach updated patch.
Comment 19 Arfrever Frehtes Taifersar Arahesis 2018-09-18 23:07:21 UTC
Created attachment 547262 [details, diff]
fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch
Comment 20 Arfrever Frehtes Taifersar Arahesis 2018-09-18 23:45:31 UTC
Created attachment 547264 [details, diff]
Patch
Comment 21 Nathan Zachary gentoo-dev 2018-09-19 02:59:08 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #19)
> Created attachment 547262 [details, diff] [details, diff]
> fontconfig-2.13.1-revert_delete_.uuid_for_empty_directory.patch

Applied this patch:

>>>>>
# cat /etc/portage/patches/media-libs/fontconfig-2.13.1-r1/font_cache_violation_reversal.patch 
https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/107

Reversion of part of:
https://gitlab.freedesktop.org/fontconfig/fontconfig/commit/f5dd8512bdf9fd8e01c30ae36f593758b29385cf

--- /src/fcdir.c
+++ /src/fcdir.c
@@ -421,13 +421,6 @@
     /* Not using existing cache file, construct new cache */
     if (!cache)
 	cache = FcDirCacheScan (dir, config);
-    if (cache)
-    {
-	FcFontSet *fs = FcCacheSet (cache);
-
-	if (cache->dirs_count == 0 && (!fs || fs->nfont == 0))
-	    FcDirCacheDeleteUUID (dir, config);
-    }
 
     return cache;
 }
--- /test/run-test.sh
+++ /test/run-test.sh
@@ -239,19 +239,4 @@
 
 rm -rf $MyPWD/sysroot
 
-dotest "deleting .uuid file on empty dir"
-prep
-cp $FONT1 $FONT2 $FONTDIR
-$FCCACHE $FONTDIR
-sleep 1
-rm -f $FONTDIR/*pcf
-$FCCACHE $FONTDIR
-rmdir $FONTDIR > /dev/null 2>&1
-if [ $? != 0 ]; then
-  echo "*** Test failed: $TEST"
-  echo "$FONTDIR isn't empty"
-  ls -al $FONTDIR
-  exit 1
-fi
-
 rm -rf $FONTDIR $CACHEFILE $CACHEDIR $FONTCONFIG_FILE out
>>>>>

The sandbox violations are no longer there, and LibreOffice is compiling now.

Looks like the patch fixes the problem for me.

Thank you!

Cheers,
Nathan Zachary
Comment 22 Larry the Git Cow gentoo-dev 2018-09-19 08:06:20 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2e23da62f35f8c716af5e6342ac9cdbb96898c14

commit 2e23da62f35f8c716af5e6342ac9cdbb96898c14
Author:     Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
AuthorDate: 2018-09-18 23:41:07 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2018-09-19 08:06:12 +0000

    media-libs/fontconfig: Revert part of upstream commit which causes sandbox violations for fonts cache.
    
    Closes: https://bugs.gentoo.org/666418

 ...1-revert_delete_.uuid_for_empty_directory.patch | 43 ++++++++++++++++++++++
 ....13.1-r1.ebuild => fontconfig-2.13.1-r2.ebuild} |  1 +
 2 files changed, 44 insertions(+)
Comment 23 Andreas Sturmlechner gentoo-dev 2018-09-19 08:50:24 UTC
*** Bug 666540 has been marked as a duplicate of this bug. ***
Comment 24 Arfrever Frehtes Taifersar Arahesis 2018-09-20 07:56:37 UTC
*** Bug 666603 has been marked as a duplicate of this bug. ***
Comment 25 Arfrever Frehtes Taifersar Arahesis 2018-10-10 07:02:31 UTC
Upstream fixes for https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/107 were not helpful for avoiding sandbox violations.

I reported https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/123 with proper patch.
Comment 26 Andreas Sturmlechner gentoo-dev 2018-10-13 16:08:56 UTC
*** Bug 668516 has been marked as a duplicate of this bug. ***
Comment 27 Pacho Ramos gentoo-dev 2019-01-12 10:52:50 UTC
*** Bug 672384 has been marked as a duplicate of this bug. ***