Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 666012 - net-voip/yate: Validate DEPEND on virtual/mysql
Summary: net-voip/yate: Validate DEPEND on virtual/mysql
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Radio project
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks: 763480
  Show dependency tree
 
Reported: 2018-09-12 17:34 UTC by Brian Evans
Modified: 2021-01-04 16:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Evans Gentoo Infrastructure gentoo-dev 2018-09-12 17:34:56 UTC
THIS IS A MASS FILING TO ALL PACKAGE WITH A DEPEND ON virtual/mysql

As was announced on the gentoo-dev-announce mailing list[1],
virtual/mysql is no longer viable to depend on providing the client libraries
or the mysql_config tool.

Most uses of DEPEND="virtual/mysql" (or conditionals based upon it) will not
work in the future.

If this package (optionally) depends on libmysqlclient.so* or mysql_config for
building, you will need to have dev-db/mysql-connector-c as the DEPEND/RDEPEND.

If this package (optionally) depends on libmariadb.so* or mariadb_config for
building, you will need to have dev-db/mariadb-connector-c as the
DEPEND/RDEPEND.

If this package requires the server running locally, virtual/mysql is
acceptible for RDEPEND and only in DEPEND when tests demand it.

The rare exception when server only files are required at build time should you
keep a compatible server listed.

After 60 days, roughly mid-October 2018, remaining packages will be forcefully
changed to mysql-connector-c with little or no testing. The server packages
will drop their compatibility DEPEND shortly after.

[1] https://archives.gentoo.org/gentoo-dev-announce/message/618f39bce863911d8955ee9f83636ca4
Comment 1 Larry the Git Cow gentoo-dev 2021-01-04 16:59:47 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2d666342dbf4ed53ff1dd77946722dd91918bf96

commit 2d666342dbf4ed53ff1dd77946722dd91918bf96
Author:     Jaco Kroon <jaco@uls.co.za>
AuthorDate: 2020-12-29 13:57:09 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-01-04 16:32:48 +0000

    net-voip/yate: bring -9999 in line with 6.2.0.
    
    This basically brings in the known required patches, and removes
    duplicate -9999 patch from files/.
    
    Signed-off-by: Jaco Kroon <jaco@uls.co.za>
    Closes: https://bugs.gentoo.org/666012
    Signed-off-by: Sam James <sam@gentoo.org>

 net-voip/yate/files/yate-9999-dont-mess-with-cflags.patch | 14 --------------
 net-voip/yate/yate-9999.ebuild                            |  9 ++++++---
 2 files changed, 6 insertions(+), 17 deletions(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=29491675582613ff3ffb5d0021ff1db0c147f49f

commit 29491675582613ff3ffb5d0021ff1db0c147f49f
Author:     Jaco Kroon <jaco@uls.co.za>
AuthorDate: 2020-12-29 13:50:49 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-01-04 16:32:48 +0000

    net-voip/yate: version bump to 6.2.0
    
    Includes fixups for USE=mysql.
    
    DISCLAIMER: I have no interest in yate itself.  However, change is
    requird for ILBC cleanup.
    
    Given the state of the open bugs, I'd
    actually recommend last-riting yate and yatebts.
    
    Signed-off-by: Jaco Kroon <jaco@uls.co.za>
    Closes: https://bugs.gentoo.org/666012
    Signed-off-by: Sam James <sam@gentoo.org>

 net-voip/yate/Manifest                       |  1 +
 net-voip/yate/files/yate-6.2.0-my_bool.patch | 21 +++++++
 net-voip/yate/yate-6.2.0.ebuild              | 93 ++++++++++++++++++++++++++++
 3 files changed, 115 insertions(+)