Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 66594 - emerging app-sci/celestia-1.3.0 fails and says libjpeg is missing
Summary: emerging app-sci/celestia-1.3.0 fails and says libjpeg is missing
Status: RESOLVED DUPLICATE of bug 70947
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on: 70947
Blocks:
  Show dependency tree
 
Reported: 2004-10-06 19:29 UTC by gygas2000
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gygas2000 2004-10-06 19:29:14 UTC
"emerge celestia" with version 1.3.0 fails with this error:

checking X11/SM/SMlib.h usability... yes
checking X11/SM/SMlib.h presence... yes
checking for X11/SM/SMlib.h... yes
checking for XpmFreeXpmImage in -lXpm... yes
checking for jpeg_start_decompress in -ljpeg... no
configure: error: jpeg library not found

!!! ERROR: app-sci/celestia-1.3.0 failed.
!!! Function src_compile, Line 64, Exitcode 1
!!! (no error message)

emerge info yeilds this:
bash-2.05b# emerge info
Portage 2.0.50-r11 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.8.1)
=================================================================
System uname: 2.6.8.1 i686 AMD Athlon(tm) XP 2700+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://mirror.tucdemonic.org/gentoo/ http://gentoo.ccccom.com http://mirrors.tds.net/gentoo http://open-systems.ufl.edu/mirrors/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib alsa apm arts avi berkdb bitmap-fonts bonobo cdr crypt cups directfb encode esd foomaticdb gdbm gif gnome gpm gtk gtk2 gtkhtml imlib java jpeg kde ldap libg++ libwww mad mikmod motif mozilla mpeg nas ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell ssl svga tcltk tcpd truetype x86 xml2 xmms xprint xv zlib"

this is reproducible every time. I'm using xorg-x11 with the official nvidia graphics drivers. "opengl-update xorg-x11" still yeilds same error upon emerge.

this has not been reproduced on other machines.
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2004-10-07 12:34:03 UTC
Which version of media-libs/jpeg do you have installed?
Comment 2 gygas2000 2004-10-11 18:15:43 UTC
*  media-libs/jpeg
      Latest version available: 6b-r3
      Latest version installed: 6b-r3
      Size of downloaded files: 598 kB
      Homepage:    http://www.ijg.org/
      Description: Library to load, handle and manipulate images in the JPEG format
      License:     as-is
Comment 3 Jonathan Fors 2004-11-17 23:51:40 UTC
This bug is related to http://bugs.gentoo.org/show_bug.cgi?id=70947, and the problem comes from there.
Comment 4 Patrick Kursawe (RETIRED) gentoo-dev 2004-11-30 06:55:48 UTC
Looks likely.

*** This bug has been marked as a duplicate of 70947 ***