Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 665888 - dev-perl/DBD-mysql: Validate DEPEND on virtual/mysql
Summary: dev-perl/DBD-mysql: Validate DEPEND on virtual/mysql
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 763480
  Show dependency tree
 
Reported: 2018-09-12 17:30 UTC by Brian Evans
Modified: 2021-01-04 02:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Evans Gentoo Infrastructure gentoo-dev 2018-09-12 17:30:13 UTC
THIS IS A MASS FILING TO ALL PACKAGE WITH A DEPEND ON virtual/mysql

As was announced on the gentoo-dev-announce mailing list[1],
virtual/mysql is no longer viable to depend on providing the client libraries
or the mysql_config tool.

Most uses of DEPEND="virtual/mysql" (or conditionals based upon it) will not
work in the future.

If this package (optionally) depends on libmysqlclient.so* or mysql_config for
building, you will need to have dev-db/mysql-connector-c as the DEPEND/RDEPEND.

If this package (optionally) depends on libmariadb.so* or mariadb_config for
building, you will need to have dev-db/mariadb-connector-c as the
DEPEND/RDEPEND.

If this package requires the server running locally, virtual/mysql is
acceptible for RDEPEND and only in DEPEND when tests demand it.

The rare exception when server only files are required at build time should you
keep a compatible server listed.

After 60 days, roughly mid-October 2018, remaining packages will be forcefully
changed to mysql-connector-c with little or no testing. The server packages
will drop their compatibility DEPEND shortly after.

[1] https://archives.gentoo.org/gentoo-dev-announce/message/618f39bce863911d8955ee9f83636ca4
Comment 1 Vincent de Phily 2019-08-27 09:01:48 UTC
While DEPEND has been fixed in dev-perl/DBD-mysql-4.44.0 (and the older versions masked), for some reason portage doesn't detect the need for a rebuild:

# emerge -uDN world
The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-perl/DBD-mysql-4.44.0::gentoo
# required by dev-db/mariadb-10.2.22-r1::gentoo[perl]
# required by virtual/mysql-5.6-r12::gentoo
# required by kde-apps/akonadi-19.08.0::gentoo[mysql]
# required by kde-apps/akonadiconsole-19.08.0::gentoo
# required by kde-apps/kdepim-meta-19.08.0::gentoo
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Brian Evans <grknight@gentoo.org> (2019-08-26)
# Deprecated virtual as it cannot solve the issue of ABI incompatibility
# and rebuild consumers when provider changes
# No revdeps. Removal in 30 days.
=virtual/libmysqlclient-18-r1

A manual rebuild (emerge -1 dev-perl/DBD-mysql) fixes the issue, but a revbump to "-r1" would probably ease the transistion. See also bug #661480 which has been asking for a version bump for over a year.
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2019-08-27 13:14:54 UTC
(In reply to Vincent de Phily from comment #1)
> While DEPEND has been fixed in dev-perl/DBD-mysql-4.44.0 (and the older
> versions masked), for some reason portage doesn't detect the need for a
> rebuild:
> 
> # emerge -uDN world
> The following mask changes are necessary to proceed:
>  (see "package.unmask" in the portage(5) man page for more details)
> # required by dev-perl/DBD-mysql-4.44.0::gentoo
> # required by dev-db/mariadb-10.2.22-r1::gentoo[perl]
> # required by virtual/mysql-5.6-r12::gentoo
> # required by kde-apps/akonadi-19.08.0::gentoo[mysql]
> # required by kde-apps/akonadiconsole-19.08.0::gentoo
> # required by kde-apps/kdepim-meta-19.08.0::gentoo
> # required by @selected
> # required by @world (argument)
> # /usr/portage/profiles/package.mask:
> # Brian Evans <grknight@gentoo.org> (2019-08-26)
> # Deprecated virtual as it cannot solve the issue of ABI incompatibility
> # and rebuild consumers when provider changes
> # No revdeps. Removal in 30 days.
> =virtual/libmysqlclient-18-r1
> 
> A manual rebuild (emerge -1 dev-perl/DBD-mysql) fixes the issue, but a
> revbump to "-r1" would probably ease the transistion. See also bug #661480
> which has been asking for a version bump for over a year.

Your issue is really bug 692938 not related to what is discussed here.
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2019-10-16 11:55:09 UTC
All done here