Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 665738 - dev-lang/php-7.1.8: mod_php depends on libnsl, but dev-lang/php-7.1.8 has no (indirect) RDEPEND to it
Summary: dev-lang/php-7.1.8: mod_php depends on libnsl, but dev-lang/php-7.1.8 has no ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-11 20:46 UTC by dkjii
Modified: 2020-01-23 16:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info php apache, lddtree mod_php and equery d libnsl (phpproblem.3,8.60 KB, text/plain)
2018-09-11 20:46 UTC, dkjii
Details
build.log for dev-lang/php-7.1.8 (php.build,191.89 KB, text/plain)
2018-09-11 20:46 UTC, dkjii
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dkjii 2018-09-11 20:46:30 UTC
Created attachment 546678 [details]
emerge --info php apache, lddtree mod_php and equery d libnsl

/usr/lib/apache2/modules/mod_php.so depends on libnsl.so.2, as seen in the attached file, but neither dev-lang/php-7.1.8 nor www-servers/apache-2.4.34-r2 have it in the dependency graph
Comment 1 dkjii 2018-09-11 20:46:58 UTC
Created attachment 546680 [details]
build.log for dev-lang/php-7.1.8
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2020-01-23 16:33:49 UTC
Does this still happen on 7.2 and higher?