Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 664742 - app-text/master-pdf-editor (4.3.82|5.0.36|5.1.00) fetch failed
Summary: app-text/master-pdf-editor (4.3.82|5.0.36|5.1.00) fetch failed
Status: RESOLVED DUPLICATE of bug 662342
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: João Santos
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-28 12:18 UTC by samurai.no.dojo
Modified: 2019-08-12 05:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description samurai.no.dojo 2018-08-28 12:18:36 UTC
No ebuild for app-text/master-pdf-editor has distfile available for download.
Applies to:
app-text/master-pdf-editor-4.3.82
app-text/master-pdf-editor-5.0.36
app-text/master-pdf-editor-5.1.00



Resulting error for 5.1.00

>>> Downloading 'http://code-industry.net/public/master-pdf-editor-5.1.00_qt5.amd64.tar.gz'
--2018-08-28 14:01:27--  http://code-industry.net/public/master-pdf-editor-5.1.00_qt5.amd64.tar.gz
Connecting to 10.222.222.242:3142... connected.
Proxy request sent, awaiting response... 404 Not Found
2018-08-28 14:01:27 ERROR 404: Not Found.

!!! Couldn't download 'master-pdf-editor-5.1.00_qt5.amd64.tar.gz'. Aborting.
 * Fetch failed for 'app-text/master-pdf-editor-5.1.00', Log file:
 *  '/var/log/portage/build/app-text/master-pdf-editor-5.1.00:20180828-120127.log.gz'

There is 
master-pdf-editor-5.1.36_qt5.amd64.tar.gz
SHA1=ada2769164a7294540b37ade01caf235abbb4ae1
(https://code-industry.net/public/master-pdf-editor-5.1.36_qt5.amd64.tar.gz)
Comment 1 Jonas Stein gentoo-dev 2018-08-29 12:08:04 UTC
It seems this is a frequent problem with this package.
They forbid us to mirror the tar ball. And remove the tar balls quickly.
They break our packages by that. I think it would be the best, to convince upstream to leave the tar ball a bit longer on the server and/or to allow mirroring.
Comment 2 João Santos 2018-09-07 09:21:16 UTC
(In reply to Jonas Stein from comment #1)
> It seems this is a frequent problem with this package.
> They forbid us to mirror the tar ball. And remove the tar balls quickly.
> They break our packages by that. I think it would be the best, to convince
> upstream to leave the tar ball a bit longer on the server and/or to allow
> mirroring.

I am painfully aware of this... as I have been waiting for weeks for my pull requests to be accepted.

How should one proceed to "convince upstream to leave the tar ball a bit longer on the server and/or to allow mirroring"?

Thanks!
Comment 3 Jeroen Roovers gentoo-dev 2019-08-12 05:38:54 UTC

*** This bug has been marked as a duplicate of bug 662342 ***