Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 664590 - sys-firmware/intel-microcode-20180807_p20180808-r2 and r3 have wrong licence intel-ucode-20180807
Summary: sys-firmware/intel-microcode-20180807_p20180808-r2 and r3 have wrong licence ...
Status: RESOLVED DUPLICATE of bug 664134
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-25 15:53 UTC by Stephan Karacson
Modified: 2018-08-26 06:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Karacson 2018-08-25 15:53:08 UTC
sys-firmware/intel-microcode-20180807_p20180808-r2 and -r3 forces the user to accept the licence file /usr/portage/licenses/intel-ucode-20180807 that was included in microcode-20180807.tgz from intel which is very large and restrictive.

According to an article from heise.de this could have been an mistake (with some NDA thing).
https://www.heise.de/newsticker/meldung/Aerger-ueber-Intels-Lizenzbedingungen-fuer-Sicherheits-Updates-4144515.html
(German)

They also point out that intel has released a new licence and a new set: microcode-20180807a.tgz which is much shorter and easier to handle.
https://01.org/mcu-path-license-2018
https://downloadcenter.intel.com/download/28087/Linux-Processor-Microcode-Data-File

Just wanted to get you knowing.
Comment 1 Thomas Deutschmann gentoo-dev 2018-08-26 06:30:03 UTC

*** This bug has been marked as a duplicate of bug 664134 ***