Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 664566 (qt-5.11.1-stable) - Qt 5.11.1 stabilisation
Summary: Qt 5.11.1 stabilisation
Status: RESOLVED FIXED
Alias: qt-5.11.1-stable
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: STABLEREQ
: 652046 (view as bug list)
Depends on: qt-5.11 663130 663134 664550 664552 664554 664556 664560 664562 664564 lxqt-0.13.0-stable 664572 665382 668946 670344
Blocks: 652046 kde-plasma-5.13.5-stable
  Show dependency tree
 
Reported: 2018-08-25 11:57 UTC by Andreas Sturmlechner
Modified: 2018-12-01 14:00 UTC (History)
3 users (show)

See Also:
Package list:
dev-qt/assistant-5.11.1 amd64 ppc64 x86 dev-qt/designer-5.11.1 amd64 ppc ppc64 x86 dev-qt/linguist-5.11.1 amd64 ppc64 x86 dev-qt/linguist-tools-5.11.1 amd64 ppc ppc64 x86 dev-qt/pixeltool-5.11.1 amd64 ppc64 x86 dev-qt/qdbus-5.11.1 amd64 ppc ppc64 x86 dev-qt/qdbusviewer-5.11.1 amd64 ppc64 x86 dev-qt/qdoc-5.11.1 amd64 x86 dev-qt/qt3d-5.11.1 amd64 x86 dev-qt/qtbluetooth-5.11.1 amd64 x86 dev-qt/qtconcurrent-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtcore-5.11.1-r1 amd64 ppc ppc64 x86 dev-qt/qtdbus-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtdeclarative-5.11.1 amd64 ppc ppc64 x86 dev-qt/qt-docs-5.11.1_p201806180847 amd64 x86 dev-qt/qtgraphicaleffects-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtgui-5.11.1 amd64 ppc ppc64 x86 dev-qt/qthelp-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtimageformats-5.11.1 amd64 ppc64 x86 dev-qt/qtlocation-5.11.1 amd64 x86 dev-qt/qtmultimedia-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtnetwork-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtopengl-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtpaths-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtpositioning-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtprintsupport-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtquickcontrols2-5.11.1 amd64 x86 dev-qt/qtquickcontrols-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtscript-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtscxml-5.11.1 amd64 x86 dev-qt/qtsensors-5.11.1 amd64 ppc64 x86 dev-qt/qtserialport-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtspeech-5.11.1 amd64 x86 dev-qt/qtsql-5.11.1-r1 amd64 ppc ppc64 x86 dev-qt/qtsvg-5.11.1 amd64 ppc ppc64 x86 dev-qt/qttest-5.11.1 amd64 ppc ppc64 x86 dev-qt/qttranslations-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtvirtualkeyboard-5.11.1 amd64 x86 dev-qt/qtwayland-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtwebchannel-5.11.1 amd64 ppc64 x86 dev-qt/qtwebengine-5.11.1 amd64 x86 dev-qt/qtwebsockets-5.11.1 amd64 ppc64 x86 dev-qt/qtwidgets-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtx11extras-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtxml-5.11.1 amd64 ppc ppc64 x86 dev-qt/qtxmlpatterns-5.11.1 amd64 ppc ppc64 x86
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
tatt-tests (useflags + rdeps, ppc) (designer-664566.report,17.16 KB, text/plain)
2018-11-07 16:43 UTC, ernsteiswuerfel
no flags Details
tatt-tests (useflags + rdeps, ppc64) (assistant-664566.report,18.75 KB, text/plain)
2018-11-17 14:02 UTC, ernsteiswuerfel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2018-08-25 11:57:29 UTC
This is the tracker for Qt 5.11 stabilisation, whatever target that will be. Do NOT report bugs here.

- Use this tracker for packages that need a newer (existing) version stabilised for Qt 5.11.
- For build failures against Qt 5.11, use the tracker bug 653646 instead.
- Create a NEW bug assigned to the maintainer of the package in question (ie. NOT qt@gentoo.org)
- Please keep this tracker free of comments. Discussion should take place
on the relevant bugs.

Will be required by KDE Plasma 5.13.5, scheduled by mid of September. In preparation.
Comment 1 Andreas Sturmlechner gentoo-dev 2018-10-04 23:54:55 UTC
Targeting 5.11.1.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-10-05 21:53:21 UTC
*** Bug 652046 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Sturmlechner gentoo-dev 2018-10-05 21:54:42 UTC
Also contains dev-qt/qtpositioning stable bump (started with bug 667172).
Comment 4 Andreas Sturmlechner gentoo-dev 2018-10-16 11:07:07 UTC
Arches, please stabilise.
Comment 5 Stabilization helper bot gentoo-dev 2018-10-16 12:14:39 UTC
An automated check of this bug failed - repoman reported dependency errors (57 lines truncated): 

> dependency.bad dev-qt/qdoc/qdoc-5.11.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['sys-devel/clang:=']
> dependency.bad dev-qt/qdoc/qdoc-5.11.1.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['sys-devel/clang:=']
> dependency.bad dev-qt/qdoc/qdoc-5.11.1.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/17.0) ['sys-devel/clang:=']
Comment 6 Andreas Sturmlechner gentoo-dev 2018-10-16 12:25:00 UTC
Dropped ppc/ppc64 from dev-qt/qdbus for now.
Comment 7 Andreas Sturmlechner gentoo-dev 2018-10-16 12:25:34 UTC
Sorry, of course I meant dev-qt/qdoc.
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-10-16 16:54:53 UTC
amd64 stable
Comment 9 Thomas Deutschmann gentoo-dev Security 2018-10-17 22:22:46 UTC
x86 stable
Comment 10 ernsteiswuerfel 2018-11-07 16:43:23 UTC
Created attachment 554434 [details]
tatt-tests (useflags + rdeps, ppc)

Looking good on ppc.

The useflags-test pulled =dev-qt/qtwebkit-5.212.0_pre20180120 in (see bug #670446). The rdeps-test pulled following additional packages in, not keyworded ~ppc yet:
=dev-qt/linguist-5.11.1 **
=dev-qt/qdbusviewer-5.11.1 **
=dev-qt/assistant-5.11.1 **

For ease of testing I added them to /etc/portage/package.keywords which went fine. Only tests left failing were due to unkeyworded dev-qt/qdoc-5.11.1 and incompatible USE-flag combinations tat pulled in.
Comment 11 ernsteiswuerfel 2018-11-17 14:02:29 UTC
Created attachment 555462 [details]
tatt-tests (useflags + rdeps, ppc64)

Looking good on ppc64.

qtwayland fails due to bug #670444, rdep qtcurve fails due to bug #645470.
Comment 12 Sergei Trofimovich gentoo-dev 2018-11-24 13:34:03 UTC
ppc/ppc64 stable thanks to ernsteiswuerfel!
Comment 13 Fabio Rossi 2018-12-01 13:55:28 UTC
why 5.11.2 disappeared both from portage and from the qt overlay?
Comment 14 Andreas Sturmlechner gentoo-dev 2018-12-01 14:00:19 UTC
It didn't.

(In reply to Andreas Sturmlechner from comment #0)
> - Please keep this tracker free of comments. Discussion should take place
> on the relevant bugs.