Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 662476 - media-gfx/engauge-10.6 : src/.../LoadImageFromUrl.cpp:61:21: error: variable QTextStream str has initializer but incomplete type
Summary: media-gfx/engauge-10.6 : src/.../LoadImageFromUrl.cpp:61:21: error: variable ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Denis Dupeyron
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-07-30 16:21 UTC by Toralf Förster
Modified: 2018-10-11 13:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.17 KB, text/plain)
2018-07-30 16:21 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,85.96 KB, text/plain)
2018-07-30 16:21 UTC, Toralf Förster
Details
environment (environment,92.73 KB, text/plain)
2018-07-30 16:21 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.63 KB, application/x-bzip)
2018-07-30 16:21 UTC, Toralf Förster
Details
media-gfx:engauge-10.6:20180730-083759.log (media-gfx:engauge-10.6:20180730-083759.log,463.90 KB, text/plain)
2018-07-30 16:21 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,27.23 KB, application/x-bzip)
2018-07-30 16:21 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.57 KB, text/plain)
2018-08-18 08:43 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,63.11 KB, text/plain)
2018-08-18 08:43 UTC, Toralf Förster
Details
environment (environment,92.23 KB, text/plain)
2018-08-18 08:43 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.96 KB, application/x-bzip)
2018-08-18 08:43 UTC, Toralf Förster
Details
media-gfx:engauge-10.6:20180818-080157.log (media-gfx:engauge-10.6:20180818-080157.log,463.90 KB, text/plain)
2018-08-18 08:43 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,27.17 KB, application/x-bzip)
2018-08-18 08:43 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.61 KB, text/plain)
2018-08-18 13:38 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,28.48 KB, text/plain)
2018-08-18 13:38 UTC, Toralf Förster
Details
environment (environment,92.19 KB, text/plain)
2018-08-18 13:38 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.51 KB, application/x-bzip)
2018-08-18 13:38 UTC, Toralf Förster
Details
media-gfx:engauge-10.6:20180818-115308.log (media-gfx:engauge-10.6:20180818-115308.log,463.89 KB, text/plain)
2018-08-18 13:38 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,27.13 KB, application/x-bzip)
2018-08-18 13:39 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-07-30 16:21:27 UTC
src/Load/LoadImageFromUrl.cpp: In member function ‘void LoadImageFromUrl::slotFinished()’:
src/Load/LoadImageFromUrl.cpp:61:21: error: variable ‘QTextStream str’ has initializer but incomplete type
     QTextStream str (&message);
                     ^
src/Load/LoadImageFromUrl.cpp: In member function ‘void LoadImageFromUrl::startLoadImage(const QUrl&)’:

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop_libressl-test_20180728-001933

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.8.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv media-gfx/engauge
[ebuild  N    ] media-gfx/engauge-10.6  USE="pdf -doc -examples -jpeg2k"
Comment 1 Toralf Förster gentoo-dev 2018-07-30 16:21:30 UTC
Created attachment 541756 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-07-30 16:21:33 UTC
Created attachment 541758 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-07-30 16:21:36 UTC
Created attachment 541760 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-07-30 16:21:39 UTC
Created attachment 541762 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-07-30 16:21:42 UTC
Created attachment 541764 [details]
media-gfx:engauge-10.6:20180730-083759.log
Comment 6 Toralf Förster gentoo-dev 2018-07-30 16:21:45 UTC
Created attachment 541766 [details]
temp.tbz2
Comment 7 Denis Dupeyron gentoo-dev 2018-07-30 18:41:22 UTC
Sorry, I can't reproduce.

Also, it very much looks like this is an upstream bug. Can you please file a bug upstream?
Comment 8 Toralf Förster gentoo-dev 2018-07-30 19:52:23 UTC
(In reply to Denis Dupeyron from comment #7)
it can be reproduced here at the tinderox - and its marked a s ablocker for QT 5.11
Comment 9 Andreas Sturmlechner gentoo-dev 2018-08-17 21:37:39 UTC
This is a typical bug caused by Qt 5.11, description is in the tracker, just needs a missing header added.
Comment 10 Andreas Sturmlechner gentoo-dev 2018-08-17 22:16:14 UTC
...or not? I was also not able to reproduce this issue on my system.
Comment 11 Toralf Förster gentoo-dev 2018-08-18 08:43:19 UTC
got at the unstable amd64 chroot image 17.0-developer_libressl_20180816-174630 too
Comment 12 Toralf Förster gentoo-dev 2018-08-18 08:43:21 UTC
Created attachment 543914 [details]
emerge-info.txt
Comment 13 Toralf Förster gentoo-dev 2018-08-18 08:43:24 UTC
Created attachment 543916 [details]
emerge-history.txt
Comment 14 Toralf Förster gentoo-dev 2018-08-18 08:43:27 UTC
Created attachment 543918 [details]
environment
Comment 15 Toralf Förster gentoo-dev 2018-08-18 08:43:30 UTC
Created attachment 543920 [details]
etc.portage.tbz2
Comment 16 Toralf Förster gentoo-dev 2018-08-18 08:43:33 UTC
Created attachment 543922 [details]
media-gfx:engauge-10.6:20180818-080157.log
Comment 17 Toralf Förster gentoo-dev 2018-08-18 08:43:36 UTC
Created attachment 543924 [details]
temp.tbz2
Comment 18 Toralf Förster gentoo-dev 2018-08-18 13:38:44 UTC
got at the unstable amd64 chroot image 17.0-desktop-gnome-systemd_libressl_20180817-190408  -  maybe this 3rd example helps to find the error pattern
Comment 19 Toralf Förster gentoo-dev 2018-08-18 13:38:47 UTC
Created attachment 543930 [details]
emerge-info.txt
Comment 20 Toralf Förster gentoo-dev 2018-08-18 13:38:49 UTC
Created attachment 543932 [details]
emerge-history.txt
Comment 21 Toralf Förster gentoo-dev 2018-08-18 13:38:52 UTC
Created attachment 543934 [details]
environment
Comment 22 Toralf Förster gentoo-dev 2018-08-18 13:38:55 UTC
Created attachment 543936 [details]
etc.portage.tbz2
Comment 23 Toralf Förster gentoo-dev 2018-08-18 13:38:58 UTC
Created attachment 543938 [details]
media-gfx:engauge-10.6:20180818-115308.log
Comment 24 Toralf Förster gentoo-dev 2018-08-18 13:39:01 UTC
Created attachment 543940 [details]
temp.tbz2
Comment 25 Larry the Git Cow gentoo-dev 2018-10-11 13:01:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=eee92fc66783faa17112955812d026d205310001

commit eee92fc66783faa17112955812d026d205310001
Author:     Michael Palimaka <kensington@gentoo.org>
AuthorDate: 2018-10-11 13:00:34 +0000
Commit:     Michael Palimaka <kensington@gentoo.org>
CommitDate: 2018-10-11 13:00:49 +0000

    media-gfx/engauge: fix build with Qt 5.11
    
    Closes: https://bugs.gentoo.org/662476
    Signed-off-by: Michael Palimaka <kensington@gentoo.org>
    Package-Manager: Portage-2.3.49, Repoman-2.3.11

 media-gfx/engauge/engauge-10.6.ebuild              |  4 +++-
 media-gfx/engauge/files/engauge-10.6-qt-5.11.patch | 26 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 1 deletion(-)