Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 662344 - media-video/vlc-2.2.8-r1: doesn't build with dev-qt/qtgui.5.11.1
Summary: media-video/vlc-2.2.8-r1: doesn't build with dev-qt/qtgui.5.11.1
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-07-28 15:46 UTC by Holger Hoffstätte
Modified: 2018-08-07 18:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to include missing headers (vlc-2.2.8-qt-5.11.patch,623 bytes, patch)
2018-07-28 15:47 UTC, Holger Hoffstätte
Details | Diff
Patch for ebuild to include additional patch (vlc-2.2.8-r1.ebuild.patch,358 bytes, patch)
2018-07-28 15:47 UTC, Holger Hoffstätte
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Hoffstätte 2018-07-28 15:46:22 UTC
Rebuilding vlc-2.2.8 with qtgui-5.11.1 results in the same errors due
to missing headers as already reported for other packages using QT, cf.
#653646.

Reproducible: Always

Steps to Reproduce:
1. install qtgui-5.11.1
2. rebuild vlc-2.2.8
3. build error!
Actual Results:  
Compile errors due to missing includes <QAction> / <QButtonGroup>


Expected Results:  
Successful build.
Comment 1 Holger Hoffstätte 2018-07-28 15:47:13 UTC
Created attachment 541514 [details, diff]
Patch to include missing headers
Comment 2 Holger Hoffstätte 2018-07-28 15:47:53 UTC
Created attachment 541516 [details, diff]
Patch for ebuild to include additional patch
Comment 3 Andreas Sturmlechner gentoo-dev 2018-07-29 07:18:29 UTC
Vlc-3 is already stable, though.
Comment 4 Holger Hoffstätte 2018-07-29 07:50:37 UTC
(In reply to Andreas Sturmlechner from comment #3)
> Vlc-3 is already stable, though.

I know, but for some reason 3.x has never worked properly for me.
I just tried again (3.0.3-r1) and it just goes crazy on startup with
a flickering window, whereas 2.2.8 works perfectly fine.
Besides I only wanted to change a USE flag. :(
If it's in the tree it should build. The fix does no harm harm (AFAIK)
since those headers also exist with older qt versions; it just succeeded
by accident.
Comment 5 Holger Hoffstätte 2018-07-29 08:11:23 UTC
(In reply to Holger Hoffstätte from comment #4)
> I know, but for some reason 3.x has never worked properly for me.

Turns out that after deleting the configurations in ~/.config/vlc
and starting fresh, 3.0.3-r1 actually starts & works fine after all.
Nevertheless I don't think 2.2.8 being stable is an excuse not to build..
Comment 6 Andreas Sturmlechner gentoo-dev 2018-08-04 23:28:59 UTC
Qt 5.11 is not stable though, so this is a result of mixing keywords.
Comment 7 Holger Hoffstätte 2018-08-05 19:13:04 UTC
Never mind then.
Comment 8 Andreas Sturmlechner gentoo-dev 2018-08-07 18:06:12 UTC
Sorry, I didn't want to come across as brusquely above, and certainly every contribution is valuable.

What usually happens with such broad breakage is bugs are filed against the latest available ~arch version, this is being fixed/bumped, and the ~arch dependee is being stabilised in time before the library can do the same. The fact that 'old' is broken can be assumed a given. This happened here and the time of 2.2.8 is very limited now (only one arch is missing 3.0.3 stable keyword). The stable promise only lasts so long and at the end of its time, 2.2.x was not in a particularly good shape anyway. Relentlessly patching up old packages is a pastime for binary distros, however they also don't typically go through the trouble of a major Qt upgrade within one release either.