Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 66141 - Porting: azureus
Summary: Porting: azureus
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High enhancement (vote)
Assignee: PPC Porters
Depends on:
Reported: 2004-10-02 10:47 UTC by Fernando Usero
Modified: 2005-11-19 18:54 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Fernando Usero 2004-10-02 10:47:51 UTC
I'm a Gentoo PPC user and wanted to use Azureus. It was masked to my arch, but I gave it a chance. It merged but didn't launch because of a SWT related problem. Talking with Azureus developers, I replaced some files from azureus' swt distribution with the same ones from eclipse-sdk' swt, which was already installed on my system (the eclipse-sdk ebuild built swt for ppc in my case). The files were:

replacing this files made azureus work for gentoo PPC. I was wondering if it could be possible something like including the swt related code of eclipse-sdk ebuild within the azureus ebuild. I've been looking at the eclipse-sdk ebuild but can't understand some things....

Reproducible: Always
Steps to Reproduce:
Comment 1 David Holm (RETIRED) gentoo-dev 2004-10-04 05:50:58 UTC
I'm adding sejo to the CC-list as Java + PowerPC is his domain.
Comment 2 Jochen Maes (RETIRED) gentoo-dev 2004-10-04 05:54:25 UTC
hi there, 

This implements that we should make the eclipse as a dependency of azureus. And i don't think that is wise.
The only thing i can do is to change the ebuild of azureus to also compile the swt itself for ppc. 

I'll look into that one.
Comment 3 Fernando Usero 2004-10-04 07:38:06 UTC
I completely agree with the second approach, that's what I intened to mean, but didn't explain well.
Comment 4 Thomas Matthijs (RETIRED) gentoo-dev 2004-10-04 21:57:01 UTC
there is a swt ebuild so this shouldn't too hard
Comment 5 Lars Weiler (RETIRED) gentoo-dev 2004-10-31 15:40:24 UTC
Any progress on this bug?
Comment 6 Jochen Maes (RETIRED) gentoo-dev 2004-11-01 06:23:44 UTC
i'm creating the source ebuild... will be in the tree within this week
Comment 7 Jochen Maes (RETIRED) gentoo-dev 2004-11-15 02:49:22 UTC
build in tree, 
arches please test

now ~ppc
would be nice to get
~x86 ~ppc ~sparc ~ia64 ~amd64 ~hppa ~mips 
Comment 8 Hardave Riar (RETIRED) gentoo-dev 2004-11-15 08:42:20 UTC
Mips does not have a working JVM.
Comment 9 Fernando Usero 2004-11-15 15:48:27 UTC
i'm the original reporter. I have merged and tested azureus on a PPC machine. It works. Great, great work Sejo!

Downloading 2004.3....
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2004-11-16 19:08:12 UTC
i think it might be too late, but i have a page up documenting how to build azureus.jar from source.  maybe it can provide some insights.  i run x86 but have not tested this ebuild.
Comment 11 Oliver Schoett 2004-12-01 13:07:43 UTC
To build and run the package on x86, I had to do the following:

(1) Add swt-3 to the system classpath (to make it build)

(2) Perform the linking step described in Bug 71277, Comment #1 (to make it run)

When started, it complains "azupdater plugin: initialization error" in an undecorated window at the bottom right with a "Details" and a "Hide" button.  When pressing "Details", another undecorated window appears with a call stack that I seem not to be able to copy with the mouse.  The top line of the call stack reads /usr/lib/azureus/plugins/azupdater/ (No such file or directory)

My window manager is fvwm 2.5.10-r3
My user jvm is sun-jdk-1.5.0
Comment 12 Lars Weiler (RETIRED) gentoo-dev 2005-04-02 05:51:24 UTC
Current status:  azureus-  ~x86 ~ppc

We didn't got that far with TEST-REQUEST.  SeJo, could you track it further?
Comment 13 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-04-02 06:43:25 UTC
I've submitted a bug (bug #74575) with a version bump and a cleanup of the ebuild.
Worked fine on ~x86, but doesn't work on ~amd64 (Out of Memory Error with javac, tested with blackdown-jdk 1.4 and sun-jdk 1.5).
Comment 14 Lars Weiler (RETIRED) gentoo-dev 2005-05-07 16:18:27 UTC
If there is a new version, please tell what we should do with this bug.  Probably you want to build a new (working) ebuild and ask for testing in a future bug?
Comment 15 Joe Jezak (RETIRED) gentoo-dev 2005-11-19 18:54:30 UTC
Azureus works fine on ppc now aside from an error message about
upgrading to java-1.5 which isn't yet available for ppc. Closing this bug.