Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 660798 - sci-visualization/paraview-5.5.2 : /.../pqChangeInputDialog.cxx:81:45: error: invalid use of incomplete type class QHeaderView
Summary: sci-visualization/paraview-5.5.2 : /.../pqChangeInputDialog.cxx:81:45: error:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthias Maier
URL:
Whiteboard:
Keywords: PATCH
: 661212 (view as bug list)
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-07-09 15:26 UTC by Toralf Förster
Modified: 2018-07-16 21:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.55 KB, text/plain)
2018-07-09 15:26 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,90.45 KB, text/plain)
2018-07-09 15:26 UTC, Toralf Förster
Details
environment (environment,172.26 KB, text/plain)
2018-07-09 15:26 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.19 KB, application/x-bzip)
2018-07-09 15:26 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,17.42 KB, application/x-bzip)
2018-07-09 15:26 UTC, Toralf Förster
Details
sci-visualization:paraview-5.5.2:20180709-114148.log.bz2 (sci-visualization:paraview-5.5.2:20180709-114148.log.bz2,340.87 KB, application/x-bzip)
2018-07-09 15:26 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,376.98 KB, application/x-bzip)
2018-07-09 15:26 UTC, Toralf Förster
Details
Upstream patch (paraview-qt-5.11.patch,5.89 KB, patch)
2018-07-09 16:57 UTC, Jouni Kosonen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-07-09 15:26:24 UTC
/var/tmp/portage/sci-visualization/paraview-5.5.2/work/ParaView-v5.5.2/Qt/Components/pqChangeInputDialog.cxx: In constructor ‘pqChangeInputDialog::pqChangeInputDialog(vtkSMProxy*, QWidget*)’:
/var/tmp/portage/sci-visualization/paraview-5.5.2/work/ParaView-v5.5.2/Qt/Components/pqChangeInputDialog.cxx:81:45: error: invalid use of incomplete type ‘class QHeaderView’
   this->Internals->pipelineView->getHeader()->hide();
                                             ^~
In file included from /var/tmp/portage/sci-visualization/paraview-5.5.2/work/paraview-5.5.2_build/Qt/Components/ui_pqChangeInputDialog.h:20:0,

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma_20180706-210011

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
  [3]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.8.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv sci-visualization/paraview
[ebuild  N    ] sci-visualization/paraview-5.5.2  USE="openmp qt5 -boost -cg -coprocessing -development -doc -examples -ffmpeg -mpi -mysql -nvcontrol -plugins -python -sqlite -tcl {-test} -tk" PYTHON_TARGETS="python2_7"
Comment 1 Toralf Förster gentoo-dev 2018-07-09 15:26:27 UTC
Created attachment 538960 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-07-09 15:26:30 UTC
Created attachment 538962 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-07-09 15:26:33 UTC
Created attachment 538964 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-07-09 15:26:36 UTC
Created attachment 538966 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-07-09 15:26:39 UTC
Created attachment 538968 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-07-09 15:26:42 UTC
Created attachment 538970 [details]
sci-visualization:paraview-5.5.2:20180709-114148.log.bz2
Comment 7 Toralf Förster gentoo-dev 2018-07-09 15:26:45 UTC
Created attachment 538972 [details]
temp.tbz2
Comment 8 Jouni Kosonen 2018-07-09 16:55:54 UTC
Upstream has since merged some added include statements to compile agaist Qt 5.11:
https://gitlab.kitware.com/paraview/paraview/merge_requests/2474
Comment 9 Jouni Kosonen 2018-07-09 16:57:41 UTC
Created attachment 538998 [details, diff]
Upstream patch
Comment 10 Andreas Sturmlechner gentoo-dev 2018-07-15 08:02:00 UTC
*** Bug 661212 has been marked as a duplicate of this bug. ***
Comment 11 Larry the Git Cow gentoo-dev 2018-07-15 16:09:10 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cd51ce629612c468a58d64303e6ec94d6e9c0e56

commit cd51ce629612c468a58d64303e6ec94d6e9c0e56
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-07-15 08:54:42 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-07-15 16:08:54 +0000

    sci-visualization/paraview: Fix build with Qt 5.11
    
    Closes: https://bugs.gentoo.org/660798
    Package-Manager: Portage-2.3.41, Repoman-2.3.9

 .../paraview/files/paraview-5.5.2-qt-5.11.patch    | 142 +++++++++++++++++++++
 sci-visualization/paraview/paraview-5.5.2.ebuild   |   1 +
 2 files changed, 143 insertions(+)
Comment 12 Juergen Rose 2018-07-16 21:46:46 UTC
It still fails here.