Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 660350 - media-video/obs-studio-21.0.2: error: invalid use of incomplete type ‘class QAction’
Summary: media-video/obs-studio-21.0.2: error: invalid use of incomplete type ‘class Q...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chiitoo
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-07-04 13:56 UTC by Hector Martin
Modified: 2018-07-13 09:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector Martin 2018-07-04 13:56:11 UTC
This is a missing include that breaks using newer Qt versions. Upstream fix:

https://github.com/obsproject/obs-studio/commit/4fd06b9825465ae5eb2a9b862cdb89098f655f14.patch

I've checked using epatch_user and confirmed that adding the above patch fixes the build.

Log:

/var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.cpp: In function ‘void InitScripts()’:
/var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.cpp:551:8: error: invalid use of incomplete type ‘class QAction’
  action->connect(action, &QAction::triggered, cb);
        ^~
In file included from /usr/include/qt5/QtWidgets/QWidget:1:0,
                 from /var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.hpp:1,
                 from /var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.cpp:1:
/usr/include/qt5/QtWidgets/qwidget.h:68:7: note: forward declaration of ‘class QAction’
 class QAction;
       ^~~~~~~
/var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.cpp:551:10: error: invalid use of incomplete type ‘class QAction’
  action->connect(action, &QAction::triggered, cb);
          ^~~~~~~
In file included from /usr/include/qt5/QtWidgets/QWidget:1:0,
                 from /var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.hpp:1,
                 from /var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.cpp:1:
/usr/include/qt5/QtWidgets/qwidget.h:68:7: note: forward declaration of ‘class QAction’
 class QAction;
       ^~~~~~~
/var/tmp/portage/media-video/obs-studio-21.0.2/work/obs-studio-21.0.2/UI/frontend-plugins/frontend-tools/scripts.cpp:551:36: error: incomplete type ‘QAction’ used in nested name specifier
  action->connect(action, &QAction::triggered, cb);
                                    ^~~~~~~~~
make[2]: *** [UI/frontend-plugins/frontend-tools/CMakeFiles/frontend-tools.dir/build.make:153: UI/frontend-plugins/frontend-tools/CMakeFiles/frontend-tools.dir/scripts.cpp.o] Error 1
Comment 1 Chiitoo gentoo-dev 2018-07-04 19:12:57 UTC
Thanks for the report!

I probably should have done something about this before, since I was aware of it for a time (as you might guess from the upstream patch :]).  However, there's been a bunch of things going on, and I simply didn't get to it yet.

Will fix.
Comment 2 Larry the Git Cow gentoo-dev 2018-07-13 09:36:30 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6b776b26f210470caae41bfdaa53606f156697b5

commit 6b776b26f210470caae41bfdaa53606f156697b5
Author:     Jimi Huotari <chiitoo@gentoo.org>
AuthorDate: 2018-07-09 01:19:49 +0000
Commit:     Tony Vroon <chainsaw@gentoo.org>
CommitDate: 2018-07-13 09:36:16 +0000

    media-video/obs-studio: fix build with Qt 5.11
    
    Upstream commit: https://github.com/obsproject/obs-studio/commit/4fd06b98
    
    Closes: https://bugs.gentoo.org/660350
    Package-Manager: Portage-2.3.41, Repoman-2.3.9

 .../files/obs-studio-21.0.2-qt-5.11.0.patch        | 28 ++++++++++++++++++++++
 media-video/obs-studio/obs-studio-21.0.2.ebuild    |  2 ++
 2 files changed, 30 insertions(+)