Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 659776 - sys-libs/glibc-2.27-r6: elf/tst-debug1 test fails on ppc
Summary: sys-libs/glibc-2.27-r6: elf/tst-debug1 test fails on ppc
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2018-07-01 18:53 UTC by ernsteiswuerfel
Modified: 2019-05-05 11:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_659776.txt,6.35 KB, text/plain)
2018-07-01 18:53 UTC, ernsteiswuerfel
Details
build.log.xz (glibc-2.27-r5:20180701-134145.log.xz,469.34 KB, application/x-xz)
2018-07-01 18:56 UTC, ernsteiswuerfel
Details
build.log.xz (2.27-r6) (build.log.xz,467.80 KB, application/x-xz)
2018-08-15 14:45 UTC, ernsteiswuerfel
Details
tst-debug1.out (tst-debug1.out,48 bytes, text/plain)
2018-10-21 21:52 UTC, Matt Turner
Details
tst-debug1.test-result (tst-debug1.test-result,43 bytes, text/plain)
2018-10-21 21:52 UTC, Matt Turner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2018-07-01 18:53:37 UTC
Created attachment 538018 [details]
emerge --info

Machine is a G5 7,3 (64bit kernel, 32bit userland).

FAIL: conform/ISO/setjmp.h/conform
FAIL: conform/ISO/stdlib.h/conform
FAIL: conform/ISO/stdlib.h/linknamespace
FAIL: conform/ISO/string.h/conform
FAIL: conform/ISO11/inttypes.h/conform
FAIL: conform/ISO11/setjmp.h/conform
FAIL: conform/ISO11/stdio.h/conform
FAIL: conform/ISO11/stdlib.h/conform
FAIL: conform/ISO11/stdlib.h/linknamespace
FAIL: conform/ISO11/string.h/conform
FAIL: conform/ISO11/wchar.h/conform
FAIL: conform/ISO99/inttypes.h/conform
FAIL: conform/ISO99/setjmp.h/conform
FAIL: conform/ISO99/stdio.h/conform
FAIL: conform/ISO99/stdlib.h/conform
FAIL: conform/ISO99/stdlib.h/linknamespace
FAIL: conform/ISO99/string.h/conform
FAIL: conform/ISO99/wchar.h/conform
FAIL: conform/POSIX/stdlib.h/conform
FAIL: conform/POSIX/stdlib.h/linknamespace
FAIL: conform/POSIX/string.h/conform
FAIL: conform/POSIX2008/fcntl.h/conform
FAIL: conform/POSIX2008/inttypes.h/conform
FAIL: conform/POSIX2008/mqueue.h/conform
FAIL: conform/POSIX2008/stdio.h/conform
FAIL: conform/POSIX2008/stdlib.h/conform
FAIL: conform/POSIX2008/stdlib.h/linknamespace
FAIL: conform/POSIX2008/sys/stat.h/conform
FAIL: conform/POSIX2008/wchar.h/conform
FAIL: conform/UNIX98/stdlib.h/conform
FAIL: conform/UNIX98/string.h/conform
FAIL: conform/UNIX98/unistd.h/conform
FAIL: conform/UNIX98/unistd.h/linknamespace
FAIL: conform/UNIX98/wchar.h/conform
FAIL: conform/XOPEN2K/fcntl.h/conform
FAIL: conform/XOPEN2K/inttypes.h/conform
FAIL: conform/XOPEN2K/mqueue.h/conform
FAIL: conform/XOPEN2K/stdio.h/conform
FAIL: conform/XOPEN2K/stdlib.h/conform
FAIL: conform/XOPEN2K/string.h/conform
FAIL: conform/XOPEN2K/syslog.h/conform
FAIL: conform/XOPEN2K/unistd.h/conform
FAIL: conform/XOPEN2K/unistd.h/linknamespace
FAIL: conform/XOPEN2K/wchar.h/conform
FAIL: conform/XOPEN2K8/fcntl.h/conform
FAIL: conform/XOPEN2K8/inttypes.h/conform
FAIL: conform/XOPEN2K8/mqueue.h/conform
FAIL: conform/XOPEN2K8/stdio.h/conform
FAIL: conform/XOPEN2K8/stdlib.h/conform
FAIL: conform/XOPEN2K8/syslog.h/conform
FAIL: conform/XOPEN2K8/unistd.h/conform
FAIL: conform/XOPEN2K8/unistd.h/linknamespace
FAIL: conform/XOPEN2K8/wchar.h/conform
FAIL: conform/XPG4/stdio.h/conform
FAIL: conform/XPG4/stdlib.h/conform
FAIL: conform/XPG4/stdlib.h/linknamespace
FAIL: conform/XPG4/string.h/conform
FAIL: conform/XPG4/unistd.h/conform
FAIL: conform/XPG42/stdio.h/conform
FAIL: conform/XPG42/stdlib.h/conform
FAIL: conform/XPG42/string.h/conform
FAIL: conform/XPG42/unistd.h/conform
FAIL: elf/tst-debug1
UNSUPPORTED: io/tst-fallocate
UNSUPPORTED: io/tst-fallocate64
UNSUPPORTED: math/test-fesetexcept-traps
UNSUPPORTED: math/test-fexcept-traps
UNSUPPORTED: misc/tst-pkey
UNSUPPORTED: misc/tst-set_ppr
UNSUPPORTED: nptl/test-cond-printers
UNSUPPORTED: nptl/test-condattr-printers
UNSUPPORTED: nptl/test-mutex-printers
UNSUPPORTED: nptl/test-mutexattr-printers
UNSUPPORTED: nptl/test-rwlock-printers
UNSUPPORTED: nptl/test-rwlockattr-printers
FAIL: nptl/tst-cond20
FAIL: nptl/tst-cond21
FAIL: nptl/tst-cond24
FAIL: nptl/tst-stackguard1
FAIL: nptl/tst-stackguard1-static
FAIL: nptl/tst-tls3
FAIL: nptl/tst-tls3-malloc
Summary of test results:
     70 FAIL
   4795 PASS
     12 UNSUPPORTED
     16 XFAIL
      2 XPASS
Comment 1 ernsteiswuerfel 2018-07-01 18:56:29 UTC
Created attachment 538020 [details]
build.log.xz
Comment 2 Sergei Trofimovich gentoo-dev 2018-07-03 22:27:35 UTC
All conform/ test failures are caused by me. I plan to push a fix for them this week. My apologies for the FAIL spam.
Comment 3 Sergei Trofimovich gentoo-dev 2018-07-04 22:11:51 UTC
(In reply to Sergei Trofimovich from comment #2)
> All conform/ test failures are caused by me. I plan to push a fix for them
> this week. My apologies for the FAIL spam.

Queued path for next glibc-2.27 patchset as:
    https://github.com/gentoo/glibc/commit/73d2a845b6de75ff401ade30545ce6f82d5c0fc2

It will fix only 'FAIL: conform/*' failures.
Comment 4 ernsteiswuerfel 2018-08-15 14:45:33 UTC
Created attachment 543506 [details]
build.log.xz (2.27-r6)

Much better with 2.27-r6! Only 1 test failing:

FAIL: elf/tst-debug1
XPASS: elf/tst-protected1a
XPASS: elf/tst-protected1b
UNSUPPORTED: io/tst-fallocate
UNSUPPORTED: io/tst-fallocate64
UNSUPPORTED: math/test-fesetexcept-traps
UNSUPPORTED: math/test-fexcept-traps
UNSUPPORTED: misc/tst-pkey
UNSUPPORTED: misc/tst-set_ppr
UNSUPPORTED: nptl/test-cond-printers
UNSUPPORTED: nptl/test-condattr-printers
UNSUPPORTED: nptl/test-mutex-printers
UNSUPPORTED: nptl/test-mutexattr-printers
UNSUPPORTED: nptl/test-rwlock-printers
UNSUPPORTED: nptl/test-rwlockattr-printers
Summary of test results:
      1 FAIL
   4870 PASS
     12 UNSUPPORTED
     16 XFAIL
      2 XPASS
Comment 5 Andreas K. Hüttel gentoo-dev 2018-10-21 20:07:32 UTC
/var/tmp/portage/sys-libs/glibc-2.27-r6/work/build-ppc-powerpc-unknown-linux-gnu-nptl/elf/tst-debug1.out
/var/tmp/portage/sys-libs/glibc-2.27-r6/work/build-ppc-powerpc-unknown-linux-gnu-nptl/elf/tst-debug1.test-result

^ could you please attach these files?

Known upstream, not a stabilization blocker.

https://sourceware.org/glibc/wiki/Release/2.27#PowerPC_.2832-bit_soft-float.29
Comment 6 Matt Turner gentoo-dev 2018-10-21 21:52:31 UTC
Created attachment 552190 [details]
tst-debug1.out
Comment 7 Matt Turner gentoo-dev 2018-10-21 21:52:57 UTC
Created attachment 552194 [details]
tst-debug1.test-result
Comment 8 ernsteiswuerfel 2019-05-05 11:13:18 UTC
Continued for glibc 2.28 in bug #677234.