Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 659346 - media-libs/libepoxy fails to build with uclibc
Summary: media-libs/libepoxy fails to build with uclibc
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-27 11:19 UTC by marius
Modified: 2018-10-17 21:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,22.11 KB, application/octet-stream)
2018-06-27 11:19 UTC, marius
Details
emerge --info (emerge-info.txt,4.76 KB, text/plain)
2018-06-29 17:47 UTC, marius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marius 2018-06-27 11:19:34 UTC
Created attachment 537382 [details]
build log

emerge media-libs/epoxy fails with this error:
[quote]
../libepoxy-1.5.1/test/egl_has_extension_nocontext.c: In function 'main':
../libepoxy-1.5.1/test/egl_has_extension_nocontext.c:58:24: error: implicit declaration of function 'strdup' [-Werror=implicit-function-declaration]
         an_extension = strdup(extensions);
                        ^~~~~~
../libepoxy-1.5.1/test/egl_has_extension_nocontext.c:58:24: warning: incompatible implicit declaration of built-in function 'strdup'
cc1: some warnings being treated as errors[/quote]

The system is amd64, using uclibc.
It might be the same bug as this one: https://bugs.gentoo.org/649212
I tried epoxy v1.5.2, but it fails with the same error.
Comment 1 marius 2018-06-29 17:47:46 UTC
Created attachment 537786 [details]
emerge --info
Comment 2 Matt Turner gentoo-dev 2018-07-06 14:44:35 UTC
blueness, any ideas?
Comment 3 Matt Turner gentoo-dev 2018-10-17 21:10:09 UTC
Feel free to re-cc x11@ when someone who cares about uclibc has investigated.