Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 659330 - =media-libs/avidemux-plugins-2.7.0 - /var/tmp/portage/media-libs/avidemux-plugins-2.7.0/work/avidemux_2.7.0/avidemux_plugins/ADM_videoFilters6/eq2/qt4/Q_eq2.cpp:56:76: error: no matching function for call to ‘QSignalMapper::setMapping(QAction*&, QSlider*&
Summary: =media-libs/avidemux-plugins-2.7.0 - /var/tmp/portage/media-libs/avidemux-plu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 662042 (view as bug list)
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-06-27 06:46 UTC by David Kredba
Modified: 2018-08-17 22:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kredba 2018-06-27 06:46:15 UTC
/var/tmp/portage/media-libs/avidemux-plugins-2.7.0/work/avidemux_2.7.0/avidemux_plugins/ADM_videoFilters6/eq2/qt4/Q_eq2.cpp:56:76: error: no matching function for call to ‘QSignalMapper::setMapping(QAction*&, QSlider*&)’
and many more.

Fixed by adding a line
#include <QAction> after the line 
#include <QSignalMapper>.
Comment 1 Neil Bothwick 2018-07-13 08:43:48 UTC
Same problem here, thanks for the fix.

Portage 2.3.42 (python 2.7.15-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-7.3.0, glibc-2.27-r5, 4.17.5-gentoo x86_64)
=================================================================
System uname: Linux-4.17.5-gentoo-x86_64-Intel-R-_Core-TM-_i5-5200U_CPU_@_2.20GHz-with-gentoo-2.6
KiB Mem:     8073136 total,   2165136 free
KiB Swap:    8389104 total,   8278000 free
Timestamp of repository gentoo: Fri, 13 Jul 2018 06:00:01 +0000
Head commit of repository gentoo: 3b7713187a844e3a010a693aa293b1c7f59b9fbd
sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p3) 2.30.0
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.6::gentoo
dev-util/cmake:           3.11.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r3::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r5::gentoo
Repositories:

nelz
    location: /mnt/portage/nelz
    masters: gentoo
    priority: 15

gentoo
    location: /var/portage
    sync-type: rsync
    sync-uri: rsync://portage.digimed.co.uk/portage
    priority: 20
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24

sunrise
    location: /mnt/portage/layman/sunrise
    masters: gentoo
    priority: 50

digimed
    location: /mnt/portage/local
    masters: gentoo
    priority: 100

Installed sets: @dependencies, @gcc, @kde, @kernels, @laptop, @temp
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/env.d /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/mnt/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --jobs --load-average 7 --quiet-unmerge-warn --backtrack=20"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://tux.rainside.sk/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo http://gentoo.localhost.net.ar/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB"
MAKEOPTS="--jobs 8 --load 10"
PKGDIR="/mnt/portage/packages/fenchurch"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X a52 aac aalib acpi activities alsa amd64 apng audiofile bluetooth bluray branding btrfs bzip2 cairo cdda cddb cdr cli crypt cryptsetup cups curl cxx dbus declarative device-mapper djvu dri dts dvb dvd dvdr ebook emacs encode exif fam ffmpeg flac gdbm gif gimp glamor gmp gnutls gpg gphoto2 gpm gtk iconv id3 imagemagick imap java jpeg jpeg2k kde kdeenablefinal kdeprefix kipi kwallet laptop libnotify libtirpc libwww lzma lzo mad mmx mmxext mng modules mp3 mp4 mpeg mplayer mtp multilib musicbrainz ncurses network-cron nls nptl nptlonly nsplugin offensive ogg opengl openmp pam pcre pdf phonon plasma png policykit pulseaudio qml qt5 quicktime rdesktop readline real scanner sdl seccomp semantic-desktop snmp spell sse sse2 sse3 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upower usb v4l v4l2 vorbis webkit widgets wifi win32codecs wxwidgets x264 xattr xcb xcomposite xinerama xml xmp xulrunner xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi krita sheets stage words" CAMERAS="ptp2 canon" COLLECTD_PLUGINS="apache apcups battery cgroups cpu cpufreq curl df disk ethstat exec filecount interface load logfile md memory network nfs notify_desktop notify_email ntpd ping processes python rrdtool sensors syslog tail thermal uptime vmem wireless" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby23" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="vesa intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Chris Smith 2018-07-15 18:03:08 UTC
Any chance this bug can get conformed and the fix put in the tree?
Comment 3 edes 2018-07-25 23:13:43 UTC
I have the same problem here, what would be needed to confirm the bug (and if possible, to merge the fix in the tree)?
Comment 4 Chiitoo gentoo-dev 2018-07-31 10:28:47 UTC
*** Bug 662042 has been marked as a duplicate of this bug. ***
Comment 5 Larry the Git Cow gentoo-dev 2018-08-17 22:04:04 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3fded280bebd469895db6adefa8b2394309eddca

commit 3fded280bebd469895db6adefa8b2394309eddca
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-08-17 21:15:29 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-08-17 22:02:02 +0000

    media-libs/avidemux-plugins: Fix build with Qt 5.11
    
    Closes: https://bugs.gentoo.org/659330
    Package-Manager: Portage-2.3.46, Repoman-2.3.10

 .../avidemux-plugins/avidemux-plugins-2.7.0.ebuild |  5 ++-
 .../files/avidemux-plugins-2.7.0-qt-5.11.patch     | 48 ++++++++++++++++++++++
 2 files changed, 52 insertions(+), 1 deletion(-)