Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 659234 - app-crypt/gpgme-1.11.1 stable request
Summary: app-crypt/gpgme-1.11.1 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Crypto team [DISABLED]
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: CVE-2018-12020
Blocks:
  Show dependency tree
 
Reported: 2018-06-26 12:34 UTC by Alon Bar-Lev
Modified: 2019-01-03 18:59 UTC (History)
1 user (show)

See Also:
Package list:
=app-crypt/gpgme-1.11.1 alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alon Bar-Lev gentoo-dev 2018-06-26 12:34:52 UTC
Hi,
Please stabilize.
Thanks!
Comment 1 Stabilization helper bot gentoo-dev 2018-06-26 13:08:18 UTC
An automated check of this bug failed - repoman reported dependency errors (51 lines truncated): 

> dependency.bad app-crypt/gpgme/gpgme-1.11.1.ebuild: DEPEND: arm(default/linux/arm/13.0) ['>=dev-libs/libgpg-error-1.29:=']
> dependency.bad app-crypt/gpgme/gpgme-1.11.1.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['>=dev-libs/libgpg-error-1.29:=']
> dependency.badindev app-crypt/gpgme/gpgme-1.11.1.ebuild: DEPEND: arm(default/linux/arm/13.0/armv4) ['>=dev-libs/libgpg-error-1.29:=']
Comment 2 Stabilization helper bot gentoo-dev 2018-06-26 15:04:17 UTC
An automated check of this bug failed - repoman reported dependency errors (51 lines truncated): 

> dependency.bad app-crypt/gpgme/gpgme-1.11.1.ebuild: DEPEND: arm(default/linux/arm/13.0) ['>=dev-libs/libgpg-error-1.29:=']
> dependency.bad app-crypt/gpgme/gpgme-1.11.1.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['>=dev-libs/libgpg-error-1.29:=']
> dependency.badindev app-crypt/gpgme/gpgme-1.11.1.ebuild: DEPEND: arm(default/linux/arm/13.0/armv4) ['>=dev-libs/libgpg-error-1.29:=']
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-06-26 15:35:16 UTC
amd64 stable
Comment 4 Stabilization helper bot gentoo-dev 2018-06-26 16:11:00 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 5 Larry the Git Cow gentoo-dev 2018-06-27 06:25:00 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=40b62b2d63ccbe72a64cc0e01f82afe412dc6c2e

commit 40b62b2d63ccbe72a64cc0e01f82afe412dc6c2e
Author:     Rolf Eike Beer <eike@sf-mail.de>
AuthorDate: 2018-06-27 05:38:44 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-27 06:24:41 +0000

    app-crypt/gpgme: stable 1.11.1 for sparc
    
    Bug: https://bugs.gentoo.org/659234
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="sparc"

 app-crypt/gpgme/gpgme-1.11.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 Tobias Klausmann gentoo-dev 2018-06-27 17:24:11 UTC
Stable on alpha.
Comment 7 Larry the Git Cow gentoo-dev 2018-06-27 21:54:09 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d68e5415b7b5fa0f1e3fed72a5e649bd1c077bd5

commit d68e5415b7b5fa0f1e3fed72a5e649bd1c077bd5
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-06-27 19:39:00 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-27 21:53:47 +0000

    app-crypt/gpgme: stable 1.11.1 for ppc, bug #659234
    
    Bug: https://bugs.gentoo.org/659234
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="ppc"

 app-crypt/gpgme/gpgme-1.11.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 Larry the Git Cow gentoo-dev 2018-06-27 22:14:25 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3d26db2f817f4a75e3be569cb9f85aea63bf3765

commit 3d26db2f817f4a75e3be569cb9f85aea63bf3765
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-06-27 22:01:32 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-27 22:13:56 +0000

    app-crypt/gpgme: stable 1.11.1 for ppc64, bug #659234
    
    Bug: https://bugs.gentoo.org/659234
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="ppc64"

 app-crypt/gpgme/gpgme-1.11.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 9 Larry the Git Cow gentoo-dev 2018-06-27 22:22:09 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=224f108ecfa9eb78145125bb58e45b2b4fa07b58

commit 224f108ecfa9eb78145125bb58e45b2b4fa07b58
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2018-06-27 22:16:40 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2018-06-27 22:22:00 +0000

    app-crypt/gpgme: stable 1.11.1 for ia64, bug #659234
    
    Bug: https://bugs.gentoo.org/659234
    Package-Manager: Portage-2.3.40, Repoman-2.3.9
    RepoMan-Options: --include-arches="ia64"

 app-crypt/gpgme/gpgme-1.11.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 10 Sergei Trofimovich gentoo-dev 2018-06-28 07:25:12 UTC
I see CC
    arm64 m68k s390 sh
but none of them have any stable keywords and they are not in package list for target keywords. Can you clarify what is requested for these arches?
Comment 11 Alon Bar-Lev gentoo-dev 2018-06-28 07:46:55 UTC
> I see CC
>    arm64 m68k s390 sh

this is a mistake, I probably had an issue with my browser.
thanks!
Comment 12 Thomas Deutschmann gentoo-dev Security 2018-07-02 00:51:36 UTC
x86 stable, closing
Comment 13 Alon Bar-Lev gentoo-dev 2018-07-23 21:06:49 UTC
removed arm by mistake, readded, please stabilize, thanks!
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-07-23 22:01:58 UTC
arm stable
Comment 15 Rolf Eike Beer 2019-01-03 04:45:18 UTC
Looks like hppa got lost.
Comment 16 Sergei Trofimovich gentoo-dev 2019-01-03 18:59:20 UTC
hppa stable

Last arch. Closing.