Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 658754 - app-office/libreoffice-bin: switch to python-3.6
Summary: app-office/libreoffice-bin: switch to python-3.6
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 5 votes (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 659024
Blocks: py3_6_switch
  Show dependency tree
 
Reported: 2018-06-22 18:06 UTC by Alexander Tsoy
Modified: 2018-09-29 19:00 UTC (History)
23 users (show)

See Also:
Package list:
app-office/libreoffice-bin-6.0.6.2 amd64 x86 app-office/libreoffice-bin-debug-6.0.6.2 amd64 x86
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Tsoy 2018-06-22 18:06:54 UTC
Profiles have switched to python-3.6.

!!! The ebuild selected to satisfy "app-office/libreoffice-bin" has unmet requirements.
- app-office/libreoffice-bin-6.0.3.2::gentoo USE="gnome -java -kde" ABI_X86="(64)" PYTHON_TARGETS="-python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_targets_python3_5

  The above constraints are a subset of the following complete expression:
    kde? ( !gnome ) gnome? ( !kde ) python_targets_python3_5
Comment 1 Bartosz Krzeszewski 2018-06-26 20:11:48 UTC
I can confirm this bug. I was just going to add it.
Comment 2 Bartosz Krzeszewski 2018-06-26 20:12:30 UTC
emerge  -1vpUD @world

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for app-office/libreoffice-bin from @selected
... done!

!!! The ebuild selected to satisfy "app-office/libreoffice-bin" has unmet requirements.
- app-office/libreoffice-bin-6.0.3.2::gentoo USE="-gnome -java -kde" ABI_X86="(64)" PYTHON_TARGETS="-python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python_targets_python3_5

  The above constraints are a subset of the following complete expression:
    kde? ( !gnome ) gnome? ( !kde ) python_targets_python3_5

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Comment 3 Andrew 2018-07-24 07:37:29 UTC
Same problem here. Any ETA on this? It seems to be blocking upgrade to python3.6.
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-07-24 13:13:04 UTC
(In reply to Andrew from comment #3)
> Same problem here. Any ETA on this? It seems to be blocking upgrade to
> python3.6.

you can easily enable per package py3.5 temporary to avoid conflicts
Comment 5 Andrew 2018-07-24 14:22:26 UTC
(In reply to Mikle Kolyada from comment #4)
> you can easily enable per package py3.5 temporary to avoid conflicts
Thanks, I wasn't aware this was possible.
Comment 6 Franz Trischberger 2018-07-25 06:11:28 UTC
An entry in ${PORTDIR}(profiles/base/package.use (like for all the other non-compatible packages) should be added instead of requiring users to do it on their own.
I also don't understand why the Python 3.6 target switch was done (again) even though there are still bugs blocking.
Comment 7 Andreas Sturmlechner gentoo-dev 2018-07-26 22:05:01 UTC
lo py 3.5 should be set in base profile package.use as long as this isn't fixed.
Comment 8 augustin 2018-08-10 01:25:01 UTC
"You can easily enable per package py3.5"

How to do so? I am currently searching but I cannot find the solution.

I tried: 
/etc/portage/package.use/libreoffice :
app-office/libreoffice-bin PYTHON_SINGLE_TARGET: python3_5
Comment 9 augustin 2018-08-10 01:37:03 UTC
Oh! This worked:

app-office/libreoffice-bin PYTHON_SINGLE_TARGET: python3_5 PYTHON_TARGETS: python3_5   

I finally found the proper documentation:
https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS

Thanks for it! :)
Comment 10 augustin 2018-08-10 01:46:44 UTC
I've documented it, so that the solution is easier to find next time: 
https://linux.overshoot.tv/app-office/libreoffice-bin
Comment 11 Ing. Jaromir Smrcek 2018-08-13 08:44:48 UTC
I'd suggest using "=app-office/libreoffice-bin-6.0.3.2" instead to prevent unnecessary python compilation in the future once the bug is resolved.
Comment 12 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-09-23 13:50:56 UTC
I see Andreas had added the version w/ py3.6 support
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6bf5bb6b1fe0848ac468eedce7ec038f4ed56599

@dilfridge, can we fast-stabilize please? It has been running nicely for me so far, and I believe it is the last py3.5 consumer for the most of our desktop users
Comment 13 Andreas Sturmlechner gentoo-dev 2018-09-29 09:43:02 UTC
No reason to wait any longer imo.
Comment 14 Andreas Sturmlechner gentoo-dev 2018-09-29 09:54:31 UTC
(In reply to augustin from comment #10)
> I've documented it, so that the solution is easier to find next time: 
> https://linux.overshoot.tv/app-office/libreoffice-bin

Please don't use bugzilla to promote your webspace.
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-09-29 19:00:59 UTC
both were done