Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 658408 - net-misc/openssh[-ssl] still requires openssl at compile time
Summary: net-misc/openssh[-ssl] still requires openssl at compile time
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL: https://lists.mindrot.org/pipermail/o...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-18 13:55 UTC by Alex Xu (Hello71)
Modified: 2018-09-13 13:31 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Xu (Hello71) 2018-06-18 13:55:00 UTC
patch set posted at https://marc.info/?l=openssh-unix-dev&r=1&b=201806&w=2, could be a good interim solution to bug 592578
Comment 1 SpanKY gentoo-dev 2018-06-18 14:50:31 UTC
if you have a specific patch you want merged independent of bug 592578, you should highlight it here.  otherwise, "merge the patchset to fix openssl 1.1 builds" is just a dupe of bug 592578.
Comment 2 Alex Xu (Hello71) 2018-06-18 15:46:07 UTC
this is "merge the patchset to fix [-ssl] builds". http://lists.mindrot.org/pipermail/openssh-unix-dev/2018-June/036977.html
Comment 3 Alex Xu (Hello71) 2018-06-18 15:48:57 UTC
although it's occurred to me that openssl is actually indirectly required by @system (via wget, probably all package-managers too), so *shrug* on that one. would be nice for openssl 1.1 though.
Comment 4 SpanKY gentoo-dev 2018-06-18 16:41:14 UTC
(In reply to Alex Xu (Hello71) from comment #3)

that doesn't matter to us in this case.  if the package needs openssl at build time, DEPEND should reflect it, or we should merge a patch to address it.

fortunately, unlike the openssl-1.1 work, i think that particular patch has a higher chance of being merged.
Comment 5 Alex Xu (Hello71) 2018-06-18 16:52:57 UTC
yes, I am assuming that they do actually want --without-openssl to work. seems like nobody actually reads the mailing list though. I'll give it another week then try tech@.
Comment 6 SpanKY gentoo-dev 2018-06-19 06:01:24 UTC
if it gets merged, or you don't hear back in a bit, ping us and we'll just move forward with fixing the build-time dep
Comment 7 Alex Xu (Hello71) 2018-09-13 13:31:46 UTC
couldn't be assed with resending the patch, and with

  >     adapt -portable to OpenSSL 1.1x API                                                                                                                                                                                                    
  >                                                                                                                                                                                                                                            
  >     Polyfill missing API with replacement functions extracted from LibreSSL                                                                                                                                                                

I probably won't bother.