Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 657624 - app-editors/gvim-8.0.1298 fails test_autocmd.vim, test_profile.vim, test_system.vim on ppc
Summary: app-editors/gvim-8.0.1298 fails test_autocmd.vim, test_profile.vim, test_syst...
Status: RESOLVED DUPLICATE of bug 630042
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Vim Maintainers
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2018-06-08 20:18 UTC by ernsteiswuerfel
Modified: 2018-10-20 10:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_657624.txt,5.51 KB, text/plain)
2018-06-08 20:18 UTC, ernsteiswuerfel
Details
build.log.xz (gvim-8.0.1298:20180608-183236.log.xz,145.17 KB, application/x-xz)
2018-06-08 20:21 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2018-06-08 20:18:28 UTC
Created attachment 535324 [details]
emerge --info

Test results:


From test_autocmd.vim:
Found errors in Test_autocmd_bufwipe_in_SessLoadPost():
function RunTheTest[34]..Test_autocmd_bufwipe_in_SessLoadPost line 22: Pattern 'E814' does not match ''
Found errors in Test_autocmd_bufwipe_in_SessLoadPost2():
function RunTheTest[34]..Test_autocmd_bufwipe_in_SessLoadPost2 line 31: Pattern 'SessionLoadPost DONE' does not match ''
Found errors in Test_bufunload_all():
function RunTheTest[34]..Test_bufunload_all line 23: Expected True but got 0

From test_normal.vim:
Found errors in Test_normal22_zet():
function RunTheTest[34]..Test_normal22_zet line 8: Expected [] but got ['1', '2']

From test_profile.vim:
Found errors in Test_profile_file():
function RunTheTest[34]..Test_profile_file line 19: Expected 0 but got 1
Found errors in Test_profile_file_with_cont():
function RunTheTest[34]..Test_profile_file_with_cont line 15: Expected 0 but got 1
Found errors in Test_profile_func():
function RunTheTest[34]..Test_profile_func line 35: Expected 0 but got 1

From test_system.vim:
Found errors in Test_system_exmode():
function RunTheTest[34]..Test_system_exmode line 7: Pattern 'result=0' does not match 'result=1\n'
TEST FAILURE
Comment 1 ernsteiswuerfel 2018-06-08 20:21:12 UTC
Created attachment 535326 [details]
build.log.xz
Comment 2 ernsteiswuerfel 2018-10-20 10:40:56 UTC

*** This bug has been marked as a duplicate of bug 630042 ***