Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 657062 - Qt 5.11.1 version bump
Summary: Qt 5.11.1 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: PMASKED
: 657644 (view as bug list)
Depends on: 653078 qt-5.11
Blocks: 624682
  Show dependency tree
 
Reported: 2018-06-01 19:23 UTC by Eugene Shalygin
Modified: 2018-07-03 10:55 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Shalygin 2018-06-01 19:23:46 UTC
Released on 2018.05.22
Comment 1 Andreas Sturmlechner gentoo-dev 2018-06-01 19:45:09 UTC
devs are well aware of the new release.
Comment 2 Eugene Shalygin 2018-06-01 20:03:08 UTC
(In reply to Andreas Sturmlechner from comment #1)
> devs are well aware of the new release.

I'm glad they are, but 10 days have passed since the release; are there problems with the final 5.11.0 version? RCs were bumped quicker than that.
Comment 3 Andreas Sturmlechner gentoo-dev 2018-06-09 08:42:29 UTC
*** Bug 657644 has been marked as a duplicate of this bug. ***
Comment 4 George L. Emigh 2018-06-10 23:37:13 UTC
The final version 5.11.0 seems to have a fix for this bug that I find rather annoying.


https://bugreports.qt.io/browse/QTBUG-29328

It would be nice to get patched or updated soon.


TIA
Comment 5 Eugene Shalygin 2018-06-12 22:37:58 UTC
Just curious, what could stop for a month renaming a dozen of files?
Comment 6 Manfred Knick 2018-06-13 11:15:03 UTC
(In reply to Eugene Shalygin from comment #5)
> Just curious, what could stop for a month renaming a dozen of files?
Nothing.

Hint_1:
Since 2018-06-01 19:45:09 UTC, this bug "Depends on" Bug 653646 -
thanks to Andreas!

Hint_2:
If you are impatient:
Simply placing "dev-qt/*:5/5.11" into your
   - package.unmask                   and
   - package.accept_keywords,
emerge will carve out if you are still affected.
Comment 7 Eugene Shalygin 2018-06-13 11:56:56 UTC
(In reply to Manfred Knick from comment #6)
I was talking about bumping rc2 to the final version, not 5.10 to 5.11.
Comment 8 Andreas Sturmlechner gentoo-dev 2018-06-13 17:19:45 UTC
5.11.0 is being worked on in Qt overlay. We will not add it to tree and spin multiple revbumps for e.g. qtwebengine when it can be avoided. The masked rc2 you can get in tree is good enough for testing and i.e. helping out with the aforementioned tracker bug 653646 - that would be much appreciated.
Comment 9 Eugene Shalygin 2018-06-13 17:21:50 UTC
Thanks! The bug was created before the version bump in the overlay.
Comment 10 Andreas Sturmlechner gentoo-dev 2018-06-13 17:28:04 UTC
(In reply to George L. Emigh from comment #4)
> The final version 5.11.0 seems to have a fix for this bug that I find rather
> annoying.
The real fix for that is in kde-frameworks/plasma-5.47.0 which ports away from the use of the bad method.
Comment 11 Manfred Knick 2018-06-13 18:14:05 UTC
(In reply to Andreas Sturmlechner from comment #8)
> rc2 you can get in tree is good enough for testing 
CONFIRMATION:     WORKSFORME   (x86_64):

[IP-] [  ] dev-qt/designer-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/linguist-tools-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtchooser-0_p20170803:0
[IP-] [  ] dev-qt/qtconcurrent-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtcore-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtdbus-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtdeclarative-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtgraphicaleffects-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtgui-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtmultimedia-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtnetwork-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtopengl-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtprintsupport-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtquickcontrols-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtquickcontrols2-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtscript-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtserialport-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtsql-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtsvg-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qttest-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtwebchannel-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtwebengine-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtwidgets-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtx11extras-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtxml-5.11.0_rc2:5/5.11
[IP-] [  ] dev-qt/qtxmlpatterns-5.11.0_rc2:5/5.11

############

(In reply to Eugene Shalygin from comment #7)
> I was talking about bumping rc2 to the final version, not 5.10 to 5.11.
Neither Title nor Description specify 
   -) neither any Version 
   -) nor "[Qt] Overlay" vs. "Main Portage Tree".

(In reply to Eugene Shalygin from comment #0)
> Released on 2018.05.22
required searching --> digging into [https://wiki.qt.io/Qt_5.11_Release],

nonetheless I couldn't grasp your intended request
(my 2 cents of sympathetic feedback).
Regards - m.
Comment 12 Eugene Shalygin 2018-06-13 18:39:47 UTC
In the "qt" overlay. Thanks!
Comment 13 Johannes Huber gentoo-dev 2018-06-13 18:56:22 UTC
(In reply to Eugene Shalygin from comment #12)
> In the "qt" overlay. Thanks!

As long it is not in tree this needs to be stay open.
Comment 14 Andreas Sturmlechner gentoo-dev 2018-07-02 16:18:19 UTC
@pesa: We can probably unmask it now, right?
Comment 15 Davide Pesavento gentoo-dev 2018-07-03 01:05:20 UTC
(In reply to Andreas Sturmlechner from comment #14)
> @pesa: We can probably unmask it now, right?

yep
Comment 16 Larry the Git Cow gentoo-dev 2018-07-03 10:55:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a1f37a453acf553d06cf912b4c7eb4d817c733bc

commit a1f37a453acf553d06cf912b4c7eb4d817c733bc
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-07-03 09:58:48 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-07-03 10:55:07 +0000

    profiles: Unmask Qt 5.11.1
    
    Closes: https://bugs.gentoo.org/657062

 profiles/package.mask | 56 ---------------------------------------------------
 1 file changed, 56 deletions(-)