Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 656302 - games-fps/doomsday-2.1.1 has automagic dependency on media-libs/sdl2-mixer
Summary: games-fps/doomsday-2.1.1 has automagic dependency on media-libs/sdl2-mixer
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal QA (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-22 22:18 UTC by Tomasz Golinski
Modified: 2019-05-04 09:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Golinski 2018-05-22 22:18:45 UTC
I had both games-fps/doomsday-2.0.3 and  media-libs/sdl2-mixer-2.0.1 installed. After removing sdl2-mixer I got:

>>> package: media-libs/sdl2-mixer-2.0.1
 *  - /usr/lib64/libSDL2_mixer-2.0.so.0
 *  - /usr/lib64/libSDL2_mixer-2.0.so.0.0.1
 *      used by /usr/bin/doomsday-2.0.3 (games-fps/doomsday-2.0.3)

Doomsday builds fine without sdl2-mixer.
Comment 1 James Le Cuirot gentoo-dev 2019-05-04 09:14:29 UTC
Still true in 2.1.1 but I'll fix this another time.
Comment 2 James Le Cuirot gentoo-dev 2019-05-04 09:15:48 UTC
Just noticed that fluidsynth, fmod, and openal are probably automagic too.